Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54548 - dev-util/gcvs-1.0_beta3-r1 compilation error in TclGlue.cpp
Summary: dev-util/gcvs-1.0_beta3-r1 compilation error in TclGlue.cpp
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 54694 (view as bug list)
Depends on:
Blocks: 54694
  Show dependency tree
 
Reported: 2004-06-20 12:33 UTC by Alexander Dvorkovyy
Modified: 2005-04-20 16:21 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Dvorkovyy 2004-06-20 12:33:21 UTC
Emerging gcvs gives the compilation error message below.

Reproducible: Always
Steps to Reproduce:
emerge gcvs
Actual Results:  
TclGlue.cpp: In function `int tclCvsBrowserProc(void*, Tcl_Interp*, int,
   char**)':
TclGlue.cpp:444: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:449: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:453: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:458: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:463: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:468: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:473: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:478: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:483: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:488: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:495: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:500: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:505: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:510: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:515: error: invalid conversion from `const char*' to `char*'
In file included from UpdateDlg.h:33,
                 from UpdateDlg.cpp:48:
MultiString.h: In member function `virtual const void*
   TMPersistent<T>::GetData() const':
MultiString.h:60: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:60: warning: implicit typename is deprecated, please see the
   documentation for details
MultiString.h: At global scope:
MultiString.h:118: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:118: warning: implicit typename is deprecated, please see the
   documentation for details
MultiString.h:119: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:119: warning: implicit typename is deprecated, please see the
   documentation for details
TclGlue.cpp: In function `int tclCvsEntriesProc(void*, Tcl_Interp*, int,
   char**)':
TclGlue.cpp:647: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp: In constructor `CTcl_Interp::CTcl_Interp()':
TclGlue.cpp:968: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:971: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:973: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:975: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:977: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:979: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:987: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:990: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:993: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:1234:2: warning: no newline at end of file
make[2]: *** [TclGlue.o] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory
`/var/tmp/portage/gcvs-1.0_beta3-r1/work/gcvs-1.0b3/common'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gcvs-1.0_beta3-r1/work/gcvs-1.0b3'
make: *** [all-recursive-am] Error 2

!!! ERROR: dev-util/gcvs-1.0_beta3-r1 failed.
!!! Function src_compile, Line 47, Exitcode 2
!!! (no error message)


emerge info
Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r0,
2.6.7-rc3-mm2)
=================================================================
System uname: 2.6.7-rc3-mm2 i686 Mobile Intel(R) Pentium(R) 4     CPU 2.80GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /etc/tomcat /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="ftp:///ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://ftp.easynet.nl/mirror/gentoo/
http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/
http://ftp.gentoo.skynet.be/pub/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa apm arts avi berkdb cdr crypt cups directfb dvd encode esd
foomaticdb gdbm gif gpm gtk2 imlib innodb java javascript jpeg kde libg++ libwww
mad mikmod mmx motif mpeg mysql ncurses nls nptl oggvorbis opengl oss pam pcmcia
pdflib png python qt quicktime readline samba sdl slang spell sse ssl svga tcpd
tetex tiff truetype video_cards_radeon x86 xinerama xml2 xmms xv zlib"
Comment 1 Doug Goldstein gentoo-dev 2004-08-06 19:27:37 UTC
*** Bug 54694 has been marked as a duplicate of this bug. ***
Comment 2 Shawn Wilson 2004-09-01 13:07:41 UTC
I too cannot compile the gcvs-1.0_beta3-r1 ebuild, except my compilation fails at a different point:


UCvsFolders.cpp: In member function `void UCvsFolders::OnTreeSelecting(int, 
   void*)':
UCvsFolders.cpp:827: error: call of overloaded `ResetView(UStr&)' is ambiguous
UCvsFiles.h:38: error: candidates are: void UCvsFiles::ResetView(const char*, 
   bool)
UCvsFiles.h:41: error:                 void UCvsFiles::ResetView(bool, bool)
make[2]: *** [UCvsFolders.o] Error 1
make[2]: *** Waiting for unfinished jobs....
UCvsFiles.cpp: In member function `int UCvsFiles::OnCmdUpone()':
UCvsFiles.cpp:1208: error: call of overloaded `ResetView(UStr&, bool)' is 
   ambiguous
UCvsFiles.cpp:417: error: candidates are: void UCvsFiles::ResetView(const 
   char*, bool)
UCvsFiles.cpp:475: error:                 void UCvsFiles::ResetView(bool, bool)
UCvsFiles.cpp: In member function `void UCvsFiles::EditSel(EntnodeData*, bool)
   ':
UCvsFiles.cpp:1889: error: call of overloaded `ResetView(UStr&, bool)' is 
   ambiguous
UCvsFiles.cpp:417: error: candidates are: void UCvsFiles::ResetView(const 
   char*, bool)
UCvsFiles.cpp:475: error:                 void UCvsFiles::ResetView(bool, bool)
make[2]: *** [UCvsFiles.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/gcvs-1.0_beta3-r1/work/gcvs-1.0b3/common'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gcvs-1.0_beta3-r1/work/gcvs-1.0b3'
make: *** [all-recursive-am] Error 2

!!! ERROR: dev-util/gcvs-1.0_beta3-r1 failed.
!!! Function src_compile, Line 48, Exitcode 2
!!! (no error message)
Comment 3 kev bailey 2004-10-02 11:31:29 UTC
problems emerging gcvs with

kbailey@skolthree kbailey $ cat /etc/make.conf
# These settings were set by the catalyst build script that automatically built this stage
# Please consult /etc/make.conf.example for a more detailed example
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j2"
USE="alsa cdr dvd matrox opengl scanner usb"
GENTOO_MIRRORS="ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://mir.zyrianes.net/gentoo/ http://www.gigaload.org/gentoo.org/"
LINGUAS="en_GB"

PORT_LOGDIR=/var/log/portage

i have had the following in my log file - hope it helps!


MultiString.h:60: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:60: warning: implicit typename is deprecated, please see the
   documentation for details
MultiString.h: At global scope:
MultiString.h:118: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:118: warning: implicit typename is deprecated, please see the
   documentation for details
MultiString.h:119: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:119: warning: implicit typename is deprecated, please see the
   documentation for details
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../gcvs -I../gcvs/src -I/. -I../cvstree -I../rf  -Wall -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -DqUnix -DqGTK -I/usr/X11R6/include -DqCvsDebug=0  -O2 -march=pentium4 -fomit-frame-pointer -pipe -c TextBinary.cpp
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../gcvs -I../gcvs/src -I/. -I../cvstree -I../rf  -Wall -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -DqUnix -DqGTK -I/usr/X11R6/include -DqCvsDebug=0  -O2 -march=pentium4 -fomit-frame-pointer -pipe -I/usr/include -DUSE_TCL="1" -c TclGlue.cpp
TclGlue.cpp: In function `int tclCvsBrowserProc(void*, Tcl_Interp*, int,
   char**)':
TclGlue.cpp:444: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:449: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:453: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:458: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:463: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:468: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:473: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:478: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:483: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:488: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:495: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:500: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:505: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:510: error: invalid conversion from `const char*' to `char*'
TclGlue.cpp:515: error: invalid conversion from `const char*' to `char*'
g++ -DHAVE_CONFIG_H -I. -I. -I.. -I../gcvs -I../gcvs/src -I/. -I../cvstree -I../rf  -Wall -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -DqUnix -DqGTK -I/usr/X11R6/include -DqCvsDebug=0  -O2 -march=pentium4 -fomit-frame-pointer -pipe -c UpdateDlg.cpp
TclGlue.cpp: In function `int tclCvsEntriesProc(void*, Tcl_Interp*, int,
   char**)':
TclGlue.cpp:647: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp: In constructor `CTcl_Interp::CTcl_Interp()':
TclGlue.cpp:968: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:971: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:973: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:975: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:977: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:979: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:987: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:990: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:993: error: invalid conversion from `int (*)(void*, Tcl_Interp*,
   int, char**)' to `int (*)(void*, Tcl_Interp*, int, const char**)'
TclGlue.cpp:1234:2: warning: no newline at end of file
make[2]: *** [TclGlue.o] Error 1
make[2]: *** Waiting for unfinished jobs....
In file included from UpdateDlg.h:33,
                 from UpdateDlg.cpp:48:
MultiString.h: In member function `virtual const void*
   TMPersistent<T>::GetData() const':
MultiString.h:60: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:60: warning: implicit typename is deprecated, please see the
   documentation for details
MultiString.h: At global scope:
MultiString.h:118: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:118: warning: implicit typename is deprecated, please see the
   documentation for details
MultiString.h:119: warning: `std::vector<T, std::allocator<_CharT>
   >::const_iterator' is implicitly a typename
MultiString.h:119: warning: implicit typename is deprecated, please see the
   documentation for details
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/gcvs-1.0_beta3-r1/work/gcvs-1.0b3/common'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/gcvs-1.0_beta3-r1/work/gcvs-1.0b3'
make: *** [all-recursive-am] Error 2

!!! ERROR: dev-util/gcvs-1.0_beta3-r1 failed.
!!! Function src_compile, Line 48, Exitcode 2
!!! (no error message)
Comment 4 Nick Demchenko 2004-10-04 07:01:14 UTC
Well, I must say, I haven't seen the sources, but a simple solution would be either installing a prior version of this package, comparing USE flags or modifying sources per hand starting with the top-most error: TclGlue.cpp:444: error: invalid conversion from `const char*' to `char*'. I'll take a guess and say there's a missing "const " in a function declaration or needless usage of "const " on variable inititalization. I'll try to figure out what's wrong there (though I never heard of that application before).
Comment 5 Alastair Tse (RETIRED) gentoo-dev 2004-10-17 13:23:46 UTC
can you please try gcvs-1.0 that is now in portage?
Comment 6 quazgar 2004-11-23 14:06:32 UTC
@ #5:
I can confirm the above bug and that using gcvs-1.0 solves the problem.
Comment 7 Dietrich Heise 2004-11-23 14:27:41 UTC
ok, 1.0 works for me too ... closing?
Comment 8 Brian M. Workman 2005-01-04 02:44:09 UTC
I don't see version 1.0 in Portage. I still only see 1.0 beta 3

minahd@lxsrv1 minahd $ sudo emerge -pv gcvs

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild  N    ] dev-util/gcvs-1.0_beta3-r1  0 kB

Total size of downloads: 0 kB

And I did a sync last night which is more than a month after this bug says that 1.0 is in Portage.
Comment 9 Hinko Kocevar 2005-02-01 15:26:15 UTC
try

ACCEPT_KEYWORDS="~x86" emerge -a =dev-util/gcvs-1.0
Comment 10 John N. Laliberte (RETIRED) gentoo-dev 2005-03-26 07:57:56 UTC
package is unmaintained upstream, and has now been package masked.
Comment 11 John N. Laliberte (RETIRED) gentoo-dev 2005-04-20 16:21:04 UTC
removed from the tree, try alternatives like lincvs.