Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 545284 - net-libs/libndp-1.4: Add multilib support
Summary: net-libs/libndp-1.4: Add multilib support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
: 548140 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-04-02 06:43 UTC by Palmer Dabbelt
Modified: 2015-06-07 13:58 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
net-libs/libndp-1.4.ebuild with multilib support (libndp-1.4.ebuild,652 bytes, text/plain)
2015-04-02 06:43 UTC, Palmer Dabbelt
Details
net-libs/libndp-1.4.ebuild with multilib support (using multilib-minimal) (libndp-1.4.ebuild,650 bytes, text/plain)
2015-04-07 19:17 UTC, Palmer Dabbelt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Palmer Dabbelt 2015-04-02 06:43:29 UTC
Created attachment 400366 [details]
net-libs/libndp-1.4.ebuild with multilib support

I'm not sure if I'm doing this right, since this is my first time messing around with the new multilib-related stuff:

I'd like to be able to build "/usr/lib32/libndp.so".  After reading a bit about the new multilib eclasses, I think I've come up with the right way to do this: the diff is very small, and it builds both 32-bit and 64-bit libraries for me.

--- libndp-1.4.ebuild	2015-04-01 23:23:31.075247204 -0700
+++ /usr/portage/net-libs/libndp/libndp-1.4.ebuild	2015-03-15 05:01:15.000000000 -0700
@@ -5,7 +5,7 @@
 EAPI=5
 GCONF_DEBUG="no"
 
-inherit gnome2 autotools-multilib
+inherit gnome2
 
 DESCRIPTION="Library for Neighbor Discovery Protocol"
 HOMEPAGE="http://libndp.org"
@@ -20,8 +20,7 @@
 DEPEND=""
 RDEPEND="${DEPEND}"
 
-multilib_src_configure() {
-	ECONF_SOURCE="${S}" \
+src_configure() {
 	gnome2_src_configure \
 		--disable-static \
 		--enable-logging

I've also attached the full modified ebuild, in case that's easier to read.
Comment 1 Pacho Ramos gentoo-dev 2015-04-07 18:44:45 UTC
Maybe multilib-minimal eclass would be better than autotools-multilib for this case :/
Comment 2 Palmer Dabbelt 2015-04-07 19:17:40 UTC
Created attachment 400774 [details]
net-libs/libndp-1.4.ebuild with multilib support (using multilib-minimal)

You're correct -- just replacing "autotools-multilib" with "mutlilib-minimal" was the only changed I needed to make.  I've attached a new version of the ebuild.
Comment 3 Gilles Dartiguelongue gentoo-dev 2015-05-01 13:38:09 UTC
*** Bug 548140 has been marked as a duplicate of this bug. ***
Comment 4 Pacho Ramos gentoo-dev 2015-06-07 13:58:40 UTC
+*libndp-1.5 (07 Jun 2015)
+
+  07 Jun 2015; Pacho Ramos <pacho@gentoo.org> +libndp-1.5.ebuild:
+  Version bump, add multilib support (#545284 by Palmer Dabbelt)
+