Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 544450 - media-sound/musescore-2.0.2 version bump request
Summary: media-sound/musescore-2.0.2 version bump request
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 2 votes (vote)
Assignee: Gentoo Sound Team
Keywords: EBUILD
: 545888 552716 (view as bug list)
Depends on:
Blocks: 470724 529156
  Show dependency tree
Reported: 2015-03-25 11:47 UTC by lasconic
Modified: 2015-12-29 05:45 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---

musescore-2.0.0.ebuild ** not working ** (musescore-2.0.0.ebuild,1.41 KB, text/plain)
2015-04-03 22:29 UTC, Eugene Cormier
New ebuild (musescore-2.0.ebuild,831 bytes, text/plain)
2015-04-08 09:51 UTC, Artur Wrona
musescore-2.0 fails (file_544450.txt,30.19 KB, text/plain)
2015-04-21 22:08 UTC, Eugene Cormier
Fully working new musescore-2.0.ebuild (file_544450.txt,1008 bytes, text/plain)
2015-04-22 18:19 UTC, Eugene Cormier
ebuild correction for missing lame bdep (file_544450.txt,1.00 KB, text/plain)
2015-04-25 14:25 UTC, Eugene Cormier
musescore-2.0.1.ebuild (musescore-2.0.1.ebuild,1.43 KB, text/plain)
2015-06-29 14:05 UTC, Alex Xu (Hello71)
musescore-2.0.2.ebuild (musescore-2.0.2.ebuild,1.44 KB, text/plain)
2015-08-25 18:47 UTC, Alex Xu (Hello71)
0001-media-sound-musescore-2.0.2-bump.patch (0001-media-sound-musescore-2.0.2-bump.patch,4.02 KB, patch)
2015-11-27 16:43 UTC, Alex Xu (Hello71)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description lasconic 2015-03-25 11:47:50 UTC
Musescore 2.0 is available

Direct link to source tarball:
Comment 1 lasconic 2015-03-25 11:51:54 UTC
If you need any help from upstream, IRC channel #musescore on
Comment 2 Eugene Cormier 2015-04-03 22:29:51 UTC
Created attachment 400504 [details]
musescore-2.0.0.ebuild ** not working **

I was playing with this for a few hours today and took an old ebuild (musescore-1.3) and started messing with it to get musescore to build. 
As it stands, this does not work!!! It fails complaining about -fPIC not being enabled. I can tell you, if you enter the failed work directory and type make, it does compile and finish fine. Also if you download the source and compile yourself after having this ebuild install your dependencies, it does work.

Now we just need a dev to clean up my newb mess and fix the Position-Independent Code, and we should be rocking (I apologize in advanced for the ebuild)
Comment 3 Eugene Cormier 2015-04-04 02:18:06 UTC
actually that last error code is gone away since I did a world update (I noticed qtcore getting rebuilt for an added icu use flag). Now it fails with the following:
/var/tmp/portage/media-sound/musescore-2.0.0/work/MuseScore-2.0.0/manual/genManual.cpp: In function 'void copyAssets(QString&, QString&)':
/var/tmp/portage/media-sound/musescore-2.0.0/work/MuseScore-2.0.0/manual/genManual.cpp:354:41: error: in C++98 'files' must be initialized by constructor, not by '{...}'
       QStringList files = {"mscore.png" };
/var/tmp/portage/media-sound/musescore-2.0.0/work/MuseScore-2.0.0/manual/genManual.cpp:354:41: error: converting to 'QStringList' from initializer list would use explicit constructor 'QStringList::QStringList(const QString&)'
/var/tmp/portage/media-sound/musescore-2.0.0/work/MuseScore-2.0.0/manual/genManual.cpp:357:24: error: range-based 'for' loops are not allowed in C++98 mode
       for (QString f : files) {
Comment 4 lasconic 2015-04-04 18:47:28 UTC
@Eugene it seems your compiler is not recent enough or it doesn't get the C++11 command line flag from CMake.
Comment 5 Eugene Cormier 2015-04-04 19:05:27 UTC
(In reply to lasconic from comment #4)
> @Eugene it seems your compiler is not recent enough or it doesn't get the
> C++11 command line flag from CMake.

I'm using gcc 4.8.4... it has it, maybe the source needs patching?
Comment 6 Artur Wrona 2015-04-08 09:51:26 UTC
Created attachment 400816 [details]
New ebuild

This is modified ebuild. To install you need to put dev-qt/* ~amd64 or dev-qt/* ~x86 to /etc/portage/package.accept_keywords. It does not work with stable qt4 because packages in version 4.8.5 are blocking 5.4.1 depending to qtchooser.
I have installed and it works very well.
Comment 7 Eugene Cormier 2015-04-08 11:45:50 UTC
Artur, are you sure you upped the 'whole' file? seems to be missing some important stuff (and the header still references musescore-1.3)
Comment 8 Ben de Groot (RETIRED) gentoo-dev 2015-04-08 13:56:16 UTC
*** Bug 545888 has been marked as a duplicate of this bug. ***
Comment 9 Ben de Groot (RETIRED) gentoo-dev 2015-04-08 13:56:40 UTC

(from Yuri Tsimbaloff in duplicate bug 545888)
Comment 10 Artur Wrona 2015-04-11 11:34:27 UTC
Eugene. I've forgot change references in header. Is based on ebuild to 1.3 but I've removed additional operations and changed links to latest tarball.
Comment 11 manuel 2015-04-21 20:46:50 UTC
The new ebuild compiles for me. It also seems to work (haven't tested thoroughly) flawlessly.
Comment 12 Eugene Cormier 2015-04-21 22:08:26 UTC
Created attachment 401770 [details]
musescore-2.0 fails

Here's what I'm getting when I download the working ebuild above.... it fails
Comment 13 Eugene Cormier 2015-04-22 16:25:14 UTC
Ok so fixed my dep problems by adding the following atoms to the RDEPEND:

Now I'm getting it compiled properly, but an access violation at the end, it's trying to install directly to /usr/local/share/applications

[100%] Built target pluginDocumentation
make[2]: Leaving directory '/var/tmp/portage/media-sound/musescore-2.0/work/MuseScore-2.0.0/build.release'
Installing the project stripped...
-- Install configuration: "RELEASE"
CMake Error at cmake_install.cmake:36 (FILE):
  file cannot create directory: /usr/local/share/applications.  Maybe need
  administrative privileges.

Makefile:87: recipe for target 'install/strip' failed
make[1]: *** [install/strip] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-sound/musescore-2.0/work/MuseScore-2.0.0/build.release'
Makefile:92: recipe for target 'install' failed
make: *** [install] Error 2
 * ERROR: media-sound/musescore-2.0::Eugenes-Overlay failed (install phase):
 *   emake failed
 * If you need support, post the output of `emerge --info '=media-sound/musescore-2.0::Eugenes-Overlay'`,
 * the complete build log and the output of `emerge -pqv '=media-sound/musescore-2.0::Eugenes-Overlay'`.
 * The complete build log is located at '/var/tmp/portage/media-sound/musescore-2.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-sound/musescore-2.0/temp/environment'.
 * Working directory: '/var/tmp/portage/media-sound/musescore-2.0/work/MuseScore-2.0.0'
 * S: '/var/tmp/portage/media-sound/musescore-2.0/work/MuseScore-2.0.0'
 (null)*(null) --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
 (null)*(null) LOG FILE: "/var/log/sandbox/sandbox-16223.log"
FORMAT: F - Function called
FORMAT: S - Access Status
FORMAT: P - Path as passed to function
FORMAT: A - Absolute Path (not canonical)
FORMAT: R - Canonical Path
FORMAT: C - Command Line

F: mkdir
S: deny
P: /usr/local/share
A: /usr/local/share
R: /usr/local/share
C: /usr/bin/cmake -DCMAKE_INSTALL_DO_STRIP=1 -P cmake_install.cmake 
 (null)*(null) --------------------------------------------------------------------------------
 * QA Notice: make jobserver unavailable:
 * 	make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 * 	make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
 * 	make[1]: warning: jobserver unavailable: using -j1.  Add '+' to parent make rule.
Comment 14 Eugene Cormier 2015-04-22 17:06:13 UTC
fixed, it works, I had added some code to the ebuild, but when I return it to the above, it works perfectly (as long as my RDEP adds are there
Comment 15 Eugene Cormier 2015-04-22 18:19:43 UTC
Created attachment 401828 [details]
Fully working new musescore-2.0.ebuild

Ok so this is a fully working new ebuild, how do we get this added to the tree?
Comment 16 Eugene Cormier 2015-04-25 14:25:33 UTC
Created attachment 401986 [details]
ebuild correction for missing lame bdep

This ebuild adds the lame buildtime dep
Comment 17 Eugene Cormier 2015-04-25 14:33:00 UTC
Here's a link to a patch by the fedora guys to remove mp3/lame functionality at build time in case someone wants a 'mp3' use flag:

and a bug filed at the musescore project:
Comment 18 Alex Xu (Hello71) 2015-06-27 22:16:43 UTC
*** Bug 552716 has been marked as a duplicate of this bug. ***
Comment 19 Alex Xu (Hello71) 2015-06-29 14:05:42 UTC
Created attachment 405950 [details]
Comment 20 altrent 2015-07-27 22:25:57 UTC
I've built successfully the 2.0.1 ebuild, however it refuses to start with the below error:
 # mscore 
mscore: error while loading shared libraries: cannot open shared object file: No such file or directory

I do have qt5Declarative installed:
~ #   eix qtdecl
[I] dev-qt/qtdeclarative
     Available versions:  
     (4)    4.8.5 4.8.6-r1 ~4.8.7
     (5)    (~)5.4.2^t
       {+accessibility aqua debug +exceptions gles2 localstorage pch qt3support test webkit +widgets xml ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"}
     Installed versions:  5.4.2(5)^t(08:59:59 PM 07/26/2015)(widgets xml -debug -gles2 -localstorage -test)
     Description:         The QML and Quick modules for the Qt5 framework

But I don't see the library installed:
~ # ls /usr/lib/libQt5Dec*
ls: cannot access /usr/lib/libQt5Dec*: No such file or directory

Any ideas what's going on?

Comment 21 manuel 2015-07-28 05:26:44 UTC
(In reply to altrent from comment #20)
> I've built successfully the 2.0.1 ebuild, however it refuses to start with
> the below error:
>  # mscore 
> mscore: error while loading shared libraries: cannot
> open shared object file: No such file or directory

> ~ # ls /usr/lib/libQt5Dec*
> ls: cannot access /usr/lib/libQt5Dec*: No such file or directory

I don't have that file either, but musescore starts correctly. (Version 2.0.0) Have you asked in the IRC channel?
Comment 22 altrent 2015-07-29 00:42:13 UTC
Thanks for the reply Manuel. And I apologize for the noise.. it's my mistake. I had an old copy of mscore in /usr/local/bin that was taking precedence. Once I deleted it, everything works like a charm!
Comment 23 lumbrius 2015-08-25 13:05:18 UTC
Current ebuild compiles without error for version 2.0.2 from local overlay but fails in install phase with

CMake Error at cmake_install.cmake:40 (file):
  file INSTALL cannot find

As qt-5 was marked stable, can this ebuild be added in tree soon?
Comment 24 Alex Xu (Hello71) 2015-08-25 18:47:28 UTC
Created attachment 410278 [details]
Comment 25 lumbrius 2015-08-26 12:16:34 UTC
last 2.0.2 ebuild compiles and program works normally
Comment 26 mark.kosmowski 2015-09-02 01:18:53 UTC
I successfully built musescore-2.0.2 using the attached ebuild in a local overlay.

The Gentoo stable net-print/cups-filters package led to a dependency issue with app-text/texlive-2014 (a dependency of musescore) whereby both packages wanted a different version of app-text/poppler.  Accepting ~amd64 to get net-print/cups-filters-1.0.74 solved the problem.  I already had this dependency issue as part of kde4apps to kde5apps migration and just hadn't dealt with it prior to installing this ebuild; few people should experience my issue.

After this dependency issue was resolved, the build worked perfectly and the package appears to be working properly.

Please add this to tree, as ~amd64 if nothing else.
Comment 27 Diogo Pereira 2015-09-02 19:17:14 UTC
jack and lame in DEPEND but not RDEPEND?

Does this really depend on dev-qt/designer?
Comment 28 Alex Xu (Hello71) 2015-09-03 12:23:06 UTC
(In reply to Diogo Pereira from comment #27)
> jack and lame in DEPEND but not RDEPEND?


> Does this really depend on dev-qt/designer?

not sure at this point, but I carefully checked all deps when I submitted. the situation may have changed since then.
Comment 29 matthias.grobarek 2015-11-01 23:09:54 UTC
I tried the ebuild from comment 24 and can confirm that MuseScore builds fine and it seems to work properly as well.

Then I modified the ebuild to experiment with the MuseScore build options. My findings are:
• dev-qt/designer is not necessary. The build logs contains a warning but MuseScore builds and works.
• The ebuild builds fine if I disable the Sountfont3 option, but it segfaults when started. I think this would be interesting for upstream.
Comment 30 Alex Xu (Hello71) 2015-11-27 16:43:36 UTC
Created attachment 418028 [details, diff]

removed designer dep, added postinst msg.
Comment 31 Andriy Utkin (RETIRED) gentoo-dev 2015-12-11 20:56:48 UTC
(In reply to Alex Xu (Hello71) from comment #30)
> Created attachment 418028 [details, diff] [details, diff]
> 0001-media-sound-musescore-2.0.2-bump.patch
> removed designer dep, added postinst msg.

Thanks for this ebuild Alex, it works for me. Going to submit this via Github pull request.
Comment 32 Alex Xu (Hello71) 2015-12-11 21:24:44 UTC
8+ months no bump. I think we can call sound team definitively dead.
Comment 33 Ian Delaney (RETIRED) gentoo-dev 2015-12-19 09:13:50 UTC
(In reply to Alex Xu (Hello71) from comment #32)
> 8+ months no bump. I think we can call sound team definitively dead.

I don't know about dead, but, well ...
Hello71 if you wish to state you would like to proxy- maintain this I can add you and bump it.
Comment 34 Patrice Clement gentoo-dev 2015-12-19 10:45:47 UTC
I will merge your PR.
Comment 35 Patrice Clement gentoo-dev 2015-12-19 10:49:16 UTC
Comment 36 Ian Delaney (RETIRED) gentoo-dev 2015-12-29 05:45:34 UTC
SO let me get this straight. This was merged via a pull request skipping past bugzilla, with a patch by a user, not a dev, who has no real connection to the sound herd or project, despite being offered the opportunity to be set as a proxy maintainer. The patch was reviewed by the committing dev.
What happens with the next bug or bump?