Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 543818 - sys-apps/portage-2.2.18: portage fails with AssertionError on emerge with some prebuilt packages (dev-libs/intel-common, dev-lang/icc)
Summary: sys-apps/portage-2.2.18: portage fails with AssertionError on emerge with som...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, REGRESSION
: 544274 544974 547036 553216 (view as bug list)
Depends on:
Blocks: 694246 484436
  Show dependency tree
 
Reported: 2015-03-19 20:14 UTC by Peter Foley
Modified: 2019-09-12 23:02 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Emerge log (intel-common.log,16.09 KB, text/plain)
2015-03-19 20:15 UTC, Peter Foley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Foley 2015-03-19 20:14:25 UTC
Emerging intel-common fails with a portage AssertionError.

Reproducible: Always

Steps to Reproduce:
1. emerge intel-common
2.
3.
Actual Results:  
Portage crashed.

Expected Results:  
intel-common emerged successfully.

emerge info:

Portage 2.2.18 (python 2.7.8-final-42, default/linux/amd64/13.0, gcc-4.9.2, glibc-2.20-r2, 3.19.0 x86_64)
=================================================================
System uname: Linux-3.19.0-x86_64-Intel-R-_Xeon-R-_CPU_E5-2603_0_@_1.80GHz-with-gentoo-2.2
KiB Mem:    16409688 total,   3053284 free
KiB Swap:    4882428 total,   4846004 free
Timestamp of repository gentoo: Thu, 19 Mar 2015 17:30:01 +0000
sh bash 4.3_p33-r2
ld GNU ld (Gentoo 2.25 p1.0) 2.25
ccache version 3.2.1 [disabled]
app-shells/bash:          4.3_p33-r2::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r2::gentoo, 3.4.3::gentoo
dev-util/ccache:          3.2.1-r1::gentoo
dev-util/cmake:           3.1.0::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.11::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.12.6::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25::gentoo
sys-devel/gcc:            4.9.2::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.6-r1::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r2::gentoo
Repositories:

gentoo
    location: /usr/portage
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

overlay
    location: /usr/overlay
    masters: gentoo
    priority: 0

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA google-chrome PUEL Oracle-BCLA-JavaSE FraunhoferFDK Intel-SDP"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="acl amd64 bash-completion berkdb bzip2 cli cracklib crypt cups cxx dri fortran gdbm iconv ipv6 libav mmx modules multilib ncurses nls nptl openmp pam pcre python readline session sse sse2 ssl systemd tcpd unicode vim-syntax zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias proxy proxy_http proxy_connect proxy_fcgi" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby22" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Peter Foley 2015-03-19 20:15:17 UTC
Created attachment 399272 [details]
Emerge log

Emerge output from failure.
Comment 2 Peter Foley 2015-03-19 23:27:42 UTC
The package emerges successfully with portage 2.2.14.
Comment 3 Jan-Matthias Braun 2015-03-20 17:46:14 UTC
Works with sys-apps/portage-2.2.17.

Without any background knowledge and a bit of google usage, the following commit

  f1c1b8a77eebf7713b32e5f9945690f60f4f46de

  Generate soname dependency metadata (bug 282639)

seems to introduce the problem. This is where I deem it better to leave this to more capable hands and people who know what that change is about.
Keep up the good work and have fun. :-)
Comment 4 Zac Medico gentoo-dev 2015-03-21 22:03:33 UTC
It looks like it's installing some odd binaries that are probably not even intended to execute on your processor. I'll fix it to generate a "QA Notice" in this case.
Comment 5 Zac Medico gentoo-dev 2015-03-22 00:14:55 UTC
There's a patch in the following branch:

	https://github.com/zmedico/portage/tree/bug_543818

I've posted it for review here:

	http://thread.gmane.org/gmane.linux.gentoo.portage.devel/5385
Comment 6 Peter Foley 2015-03-22 00:32:29 UTC
With portage installed from the bug_543818 branch, the build succeeds with the below output:

 * QA Notice: Unrecognized ELF file(s):
 *
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libpdbx.so.5;libpdbx.so.5;;libpthread.so.0,libstdc++.so.6,libm.so.6,libgcc_s.so.1,libc.so.6,ld-linux-k1om.so.2,libdl.so.2;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libsvml.so;libsvml.so;;libintlc.so.5,libc.so.6;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libirc.so;libirc.so;;;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libintlc.so.5;libintlc.so.5;;;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libirng.so;;;libintlc.so.5,libc.so.6;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/offload_main;;;libimf.so,liboffload.so.5,libcoi_device.so.0,libmyo-service.so,libm.so.6,libiomp5.so,libstdc++.so.6,libgcc_s.so.1,libpthread.so.0,libc.so.6,libdl.so.2;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/liboffload.so.5;liboffload.so.5;;libcoi_device.so.0,libmyo-service.so,libimf.so,libsvml.so,libirng.so,libm.so.6,libiomp5.so,libstdc++.so.6,libgcc_s.so.1,libintlc.so.5,libpthread.so.0,libc.so.6,ld-linux-k1om.so.2,libdl.so.2;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libiompstubs5.so;libiompstubs5.so;;libc.so.6;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libicaf.so;libicaf.so;;libm.so.6,libmpi_mt.so.4,libintlc.so.5,libc.so.6;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libiomp5.so;libiomp5.so;;libpthread.so.0,libc.so.6,libdl.so.2;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libcilkrts.so.5;libcilkrts.so.5;;libpthread.so.0,libm.so.6,libstdc++.so.6,libgcc_s.so.1,libc.so.6,libdl.so.2;
 *      NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libimf.so;libimf.so;;libc.so.6;
 *

>>> Installing (1 of 1) dev-libs/intel-common-15.0.2.164::gentoo
Comment 7 Brian Dolbec gentoo-dev 2015-03-22 03:24:09 UTC
*      NOWN_TYPE;/opt/intel/co

looks like a big typo

      KNOWN_TYPE

;)

But I don't see that as having come from Zac's patch
Comment 8 Zac Medico gentoo-dev 2015-03-22 03:57:59 UTC
(In reply to Brian Dolbec from comment #7)
> *      NOWN_TYPE;/opt/intel/co
> 
> looks like a big typo
> 
>       KNOWN_TYPE
> 
> ;)
> 
> But I don't see that as having come from Zac's patch

That's scanelf output. It's actuallly UNKNOWN_TYPE, missing the first 3 characters. Normally, the first 3 characters are always "EM_", so they are trimmed off (the NEEDED.ELF.2 file format has always been this way).
Comment 9 Zac Medico gentoo-dev 2015-03-22 18:48:01 UTC
(In reply to Peter Foley from comment #6)
> With portage installed from the bug_543818 branch, the build succeeds with
> the below output:
> 
>  * QA Notice: Unrecognized ELF file(s):
>  *
>  *     
> NOWN_TYPE;/opt/intel/composerxe-2015_update2.2.164/compiler/lib/mic/libpdbx.
> so.5;libpdbx.so.5;;libpthread.so.0,libstdc++.so.6,libm.so.6,libgcc_s.so.1,
> libc.so.6,ld-linux-k1om.so.2,libdl.so.2;

Some flawed logic in the patch is fixed now, so the warning for this package will be suppressed because it sets QA_PREBUILT="${INTEL_SDP_DIR}/*" in intel-sdb.eclass.
Comment 10 Zac Medico gentoo-dev 2015-03-22 19:39:41 UTC
This is in the master branch now:

http://gitweb.gentoo.org/proj/portage.git/commit/?id=c9aebae4633a972b78f7f999aa755fa6d25c8451
Comment 11 Zac Medico gentoo-dev 2015-03-24 17:41:50 UTC
*** Bug 544274 has been marked as a duplicate of this bug. ***
Comment 12 Guilherme Amadio gentoo-dev 2015-03-30 21:42:50 UTC
*** Bug 544974 has been marked as a duplicate of this bug. ***
Comment 13 Juergen Rose 2015-04-03 13:41:06 UTC
(In reply to Zac Medico from comment #10)
> This is in the master branch now:
> 
> http://gitweb.gentoo.org/proj/portage.git/commit/
> ?id=c9aebae4633a972b78f7f999aa755fa6d25c8451

How can I install the patched portage?
Comment 14 Zac Medico gentoo-dev 2015-04-03 17:21:58 UTC
(In reply to Juergen Rose from comment #13)
> How can I install the patched portage?

ACCEPT_KEYWORDS="**" emerge -1 =sys-apps/portage-9999
Comment 15 Juergen Rose 2015-04-04 09:09:00 UTC
(In reply to Zac Medico from comment #14)
> (In reply to Juergen Rose from comment #13)
> > How can I install the patched portage?
> 
> ACCEPT_KEYWORDS="**" emerge -1 =sys-apps/portage-9999

Thanks, worked.
Comment 16 Juergen Rose 2015-04-08 09:20:50 UTC
(In reply to Juergen Rose from comment #15)
> (In reply to Zac Medico from comment #14)
> > (In reply to Juergen Rose from comment #13)
> > > How can I install the patched portage?
> > 
> > ACCEPT_KEYWORDS="**" emerge -1 =sys-apps/portage-9999
> 
> Thanks, worked.

BTW., when can I return to the normal portage version?
Comment 17 Zac Medico gentoo-dev 2015-04-19 01:15:22 UTC
*** Bug 547036 has been marked as a duplicate of this bug. ***
Comment 18 SpanKY gentoo-dev 2015-04-19 05:30:30 UTC
if a new version isn't slated soon, probably should cherry pick this into an -r1
Comment 19 Brian Dolbec gentoo-dev 2015-04-19 15:26:47 UTC
I'm thinking next weekend.  I want to see if I can make a few changes for the squashfs sync module's release.
Comment 20 Alex Efros 2015-05-13 19:31:52 UTC
Rollback from portage-2.2.18 to 2.2.14 solve this issue.
Comment 21 Brian Dolbec gentoo-dev 2015-05-18 23:47:48 UTC
Released in portage-2.2.19
Comment 22 Kostas 2015-06-25 13:34:10 UTC
Just fell on this bug with portage 2.2.18. Is this bug really fixed, or only on ~ versions?
Comment 23 Zac Medico gentoo-dev 2015-06-25 15:45:01 UTC
(In reply to Kostas from comment #22)
> Just fell on this bug with portage 2.2.18. Is this bug really fixed, or only
> on ~ versions?

Yes, it's only fixed in ~ versions (greater than 2.2.18).
Comment 24 Justin Lecher gentoo-dev 2015-06-29 07:51:03 UTC
*** Bug 553216 has been marked as a duplicate of this bug. ***