Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 543474 - dev-perl/gtk2-fu-0.110.0-r2 fails test t/pod.t
Summary: dev-perl/gtk2-fu-0.110.0-r2 fails test t/pod.t
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Perl team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: perl-testfailure
  Show dependency tree
 
Reported: 2015-03-16 05:20 UTC by Kent Fredric (IRC: kent\n) (RETIRED)
Modified: 2015-03-21 22:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2015-03-16 05:20:10 UTC
This is an example of a bogus spurious failure caused by poor quality "authortests"


t/00-load.t ....... ok   
Ambiguous call resolved as CORE::push(), qualify as such or use & at (eval 89) line 5.
# Testing Gtk2Fu 0.11, Perl 5.008005, /usr/bin/perl5.8.5
t/pod-coverage.t .. ok   
Ambiguous call resolved as CORE::push(), qualify as such or use & at (eval 95) line 5.
t/pod.t ........... Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 

Test Summary Report
-------------------
t/pod.t         (Wstat: 256 Tests: 1 Failed: 1)
  Failed test:  1
  Non-zero exit status: 1
Files=3, Tests=3,  2 wallclock secs ( 0.05 usr  0.01 sys +  0.63 cusr  0.05 csys =  0.74 CPU)
Result: FAIL

---

Solution here is simple:

+ PERL_RM_FILES=(
+ 	t/pod-coverage.t
+ 	t/pod.t
+ )
Comment 1 Andreas K. Hüttel gentoo-dev 2015-03-21 22:44:14 UTC
Fix added