Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 543326 (qt-5.4.2-stable) - Qt 5.4.2 stable request
Summary: Qt 5.4.2 stable request
Status: RESOLVED FIXED
Alias: qt-5.4.2-stable
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 466216 519190 529196 qt-4.8.6-stable 532140 538594 541262 541434 CVE-2015-0295 542698 549140 549170 551318 554644 556032
Blocks: 558602 558660 558948 560900 562966
  Show dependency tree
 
Reported: 2015-03-14 16:18 UTC by Ben de Groot (RETIRED)
Modified: 2016-02-19 11:22 UTC (History)
15 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
5.4.2-stabilization-list-v1 (file_543326.txt,534 bytes, text/plain)
2015-07-26 01:15 UTC, Davide Pesavento
Details
5.4.2-stabilization-list-v2 (file_543326.txt,1.86 KB, text/plain)
2015-08-08 21:42 UTC, Davide Pesavento
Details
5.4.2-stabilization-list-v3 (file_543326.txt,2.02 KB, text/plain)
2015-09-13 22:26 UTC, Davide Pesavento
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben de Groot (RETIRED) gentoo-dev 2015-03-14 16:18:43 UTC
All bugs that should be solved before Qt5 is marked stable must block this tracker.
Comment 1 Jacob Floyd 2015-03-15 01:29:45 UTC
I think this depends on bug 454132 (qtchooser) and 530238 (Qt 4.8.6-r1), or qt5 will conflict with qt4.
Comment 2 Jacob Floyd 2015-03-15 01:31:05 UTC
(In reply to Jacob Floyd from comment #1)
> I think this depends on bug 454132 (qtchooser) ...
I copied the wrong bug #. I meant bug 529196.

Sorry for the bug spam.
Comment 3 Ben de Groot (RETIRED) gentoo-dev 2015-03-15 02:09:39 UTC
Jacob, you're right. I'm adding those.
Comment 4 Davide Pesavento gentoo-dev 2015-06-17 17:33:56 UTC
Stabilization target is Qt 5.4.2
Comment 5 Davide Pesavento gentoo-dev 2015-07-26 01:15:17 UTC
Created attachment 407636 [details]
5.4.2-stabilization-list-v1

@kensington, are these packages enough for KF5/plasma? I'd like to keep the initial stabilization as small as possible (but at least with all packages required by kde and qt-creator).
Comment 6 Johannes Huber gentoo-dev 2015-07-26 10:51:40 UTC
(In reply to Davide Pesavento from comment #5)
> Created attachment 407636 [details]
> 5.4.2-stabilization-list-v1
> 
> @kensington, are these packages enough for KF5/plasma? I'd like to keep the
> initial stabilization as small as possible (but at least with all packages
> required by kde and qt-creator).

dev-qt/qtwayland?
Comment 7 Michael Palimaka (kensington) gentoo-dev 2015-07-26 15:57:09 UTC
(In reply to Johannes Huber from comment #6)
> (In reply to Davide Pesavento from comment #5)
> > Created attachment 407636 [details]
> > 5.4.2-stabilization-list-v1
> > 
> > @kensington, are these packages enough for KF5/plasma? I'd like to keep the
> > initial stabilization as small as possible (but at least with all packages
> > required by kde and qt-creator).
> 
> dev-qt/qtwayland?

Yes, also dev-qt/qtgraphicaleffects.
Comment 8 Davide Pesavento gentoo-dev 2015-07-27 00:52:03 UTC
ok thanks. Are you planning on extending your keywording to arches other than amd64 in the immediate future?
Comment 9 Johannes Huber gentoo-dev 2015-07-28 18:24:22 UTC
(In reply to Davide Pesavento from comment #8)
> ok thanks. Are you planning on extending your keywording to arches other
> than amd64 in the immediate future?

arm would be nice for mobile use cases based on Qt 5 there are still some examples like Sailfish OS or KDE Plasma Mobile. I guess this trend will continue.
Comment 10 Davide Pesavento gentoo-dev 2015-08-08 21:42:08 UTC
Created attachment 408580 [details]
5.4.2-stabilization-list-v2

This should be the final stabilization list for Qt 5.4.2-r0 (-r1 for a few packages).

The list has been generated starting from those arches that currently have Qt5 keyworded, and checking for each arch which packages have their corresponding 4.8.6 version declared stable. Modules that are new in qt5 have been left out for now, except those modules that we already know will be required for other upcoming stabilizations (e.g. for qt-creator or KF5/plasma). Let me know if there are any mistakes in the list.

Note that for some arches (hppa, ppc64) this is an excellent opportunity to drop some packages to ~arch only starting with Qt5, if they think they won't have enough manpower to maintain a stable keyword on those packages.

Conversely, if some arches would like to stabilize more packages than those currently in the list, they're obviously free to do so. However I'd advise against stabilizing qtquick1 and qtwebkit, as they're deprecated upstream and will be removed in Qt 5.6.
Comment 11 Davide Pesavento gentoo-dev 2015-08-23 00:29:19 UTC
Arches, please go ahead with the stabilization of Qt5. See attachment "5.4.2-stabilization-list-v2" and comment #10 for the details and some suggestions.

x86 has not been included at this time because it's still affected by bug 552942.
Comment 12 Jeroen Roovers gentoo-dev 2015-08-23 09:26:34 UTC
Stable for HPPA.
Comment 13 Davide Pesavento gentoo-dev 2015-08-24 13:17:36 UTC
@hppa, we had to do a last minute change to dev-qt/qtdeclarative wrt jit support. Please stabilize the new revision 5.4.2-r1. Nothing should really change for you since the jit isn't supported on hppa anyway. Sorry for the inconvenience.

@everyone else, please ignore qtdeclarative-5.4.2 and stabilize 5.4.2-r1 instead.

Thanks.
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-08-24 13:46:35 UTC
amd64 stable
Comment 15 Davide Pesavento gentoo-dev 2015-08-24 22:28:33 UTC
@hppa, please also stabilize dev-qt/qtconcurrent that you will need for app-crypt/qca eventually (unless you want to drop the stable keyword from qca).
Comment 16 Jeroen Roovers gentoo-dev 2015-08-25 04:45:29 UTC
Comment on attachment 408580 [details]
5.4.2-stabilization-list-v2

Needs revision, then. While you're at it, include version and revision.
Comment 17 Jeroen Roovers gentoo-dev 2015-08-25 05:49:42 UTC
Stable for HPPA.
Comment 18 Johannes Huber gentoo-dev 2015-08-25 10:16:20 UTC
@qt Please move qt use mask for stable arches to specific packages if needed. 

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=bc6f0a1b6ceb93629fd72e748f40a944c6e3959a
Comment 19 Davide Pesavento gentoo-dev 2015-08-27 01:58:11 UTC
(In reply to Johannes Huber from comment #18)
> @qt Please move qt use mask for stable arches to specific packages if
> needed. 
> 
> https://gitweb.gentoo.org/repo/gentoo.git/commit/
> ?id=bc6f0a1b6ceb93629fd72e748f40a944c6e3959a

I know, we should do that too, but it's not part of this bug. In any case, anyone can do it if they wish, I'm not sure when I'll have time. Just make sure you don't break the tree please.
Comment 20 Davide Pesavento gentoo-dev 2015-08-27 02:02:15 UTC
@zlogene, I've noticed you've already stabilized some packages for arm, what else is missing here? I'm asking because arm is still CC'ed...
Comment 21 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-08-27 10:17:04 UTC
(In reply to Davide Pesavento from comment #20)
> @zlogene, I've noticed you've already stabilized some packages for arm, what
> else is missing here? I'm asking because arm is still CC'ed...

I just though about qt use flag, but i see yngwin took care already, so nothing to do here for arm. 

arm stable.
Comment 22 Davide Pesavento gentoo-dev 2015-08-27 16:01:03 UTC
(In reply to Mikle Kolyada from comment #21)
> I just though about qt use flag, but i see yngwin took care already, so
> nothing to do here for arm. 

uh? no, yngwin just moved the qt5 stable mask from the base profile to the arch-specific profiles. The qt5 flag is still stable masked everywhere except on amd64.
Comment 23 Jeroen Roovers gentoo-dev 2015-09-12 06:08:09 UTC
Comment on attachment 408580 [details]
5.4.2-stabilization-list-v2

Please provide a full list of atoms with version and revision.
Comment 24 Davide Pesavento gentoo-dev 2015-09-13 22:26:26 UTC
Created attachment 411860 [details]
5.4.2-stabilization-list-v3
Comment 25 Jeroen Roovers gentoo-dev 2015-09-21 05:00:01 UTC
Stable for PPC64.
Comment 26 Agostino Sarubbo gentoo-dev 2015-11-12 10:45:05 UTC
PPC team can handle this. Can I have a list for ppc?
Comment 27 Michael Palimaka (kensington) gentoo-dev 2015-11-12 10:49:36 UTC
(In reply to Agostino Sarubbo from comment #26)
> PPC team can handle this. Can I have a list for ppc?

Perhaps we should prepare this as part of 5.5.1 stablerequest?
Comment 28 Davide Pesavento gentoo-dev 2015-12-22 17:46:42 UTC
(In reply to Michael Palimaka (kensington) from comment #27)
> (In reply to Agostino Sarubbo from comment #26)
> > PPC team can handle this. Can I have a list for ppc?
> 
> Perhaps we should prepare this as part of 5.5.1 stablerequest?

Yeah, if you don't mind waiting a couple of weeks I think it would be better to move on to 5.5.1 at this point. x86 will do the same.
Comment 29 Davide Pesavento gentoo-dev 2016-02-03 16:36:42 UTC
Nothing else to do here. x86 and ppc (and maybe others) will skip 5.4.2 and stabilize 5.5.1