Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 54121 - possibly bad mirror? - Updating mailx results in error while unemerging latest version
Summary: possibly bad mirror? - Updating mailx results in error while unemerging lates...
Status: VERIFIED WORKSFORME
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: Mirror Admins
URL:
Whiteboard:
Keywords:
: 57065 57319 60508 60663 65505 80450 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-06-16 14:05 UTC by Paulo J. Matos
Modified: 2005-02-02 09:46 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Paulo J. Matos 2004-06-16 14:05:58 UTC
During an emerge -uD world I get an error while unemerging old mailx:
[mailx compilation...]
>>> Install mailx-8.1.2.20021129-r3 into /var/tmp/portage/mailx-8.1.2.20021129-r3/image/ category mail-client
man:
fixing man page symlink: Mail.1.gz
removing old symlink: Mail.1
prepallstrip:
strip:
strip:
   bin/mail
>>> Completed installing into /var/tmp/portage/mailx-8.1.2.20021129-r3/image/ 
>>> Merging mail-client/mailx-8.1.2.20021129-r3 to /
--- /bin/
>>> /bin/Mail -> mail
>>> /bin/mail
>>> /bin/mailx -> mail
--- /etc/
>>> /etc/mail.rc
--- /usr/
--- /usr/lib/
>>> /usr/lib/mail.tildehelp
>>> /usr/lib/mail.help
--- /usr/share/
--- /usr/share/man/
--- /usr/share/man/man1/
>>> /usr/share/man/man1/Mail.1.gz -> mail.1.gz
>>> /usr/share/man/man1/mail.1.gz
>>> Regenerating /etc/ld.so.cache...
 * Caching service dependencies...
>>> mail-client/mailx-8.1.2.20021129-r3 merged.
 
 mail-client/mailx
    selected: 8.1.2.20021129-r2
   protected: 8.1.2.20021129-r3
     omitted: none
 
>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.
 
>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging mail-client/mailx-8.1.2.20021129-r2...
No package files given... Grabbing a set.
/usr/sbin/ebuild.sh: /var/db/pkg/mail-client/mailx-8.1.2.20021129-r2/mailx-8.1.2.20021129-r2.ebuild: line 43: unexpected EOF while looking for matching `"'
/usr/sbin/ebuild.sh: /var/db/pkg/mail-client/mailx-8.1.2.20021129-r2/mailx-8.1.2.20021129-r2.ebuild: line 70: syntax error: unexpected end of file
 
!!! ERROR: mail-client/mailx-8.1.2.20021129-r2 failed.
!!! Function , Line 1297, Exitcode 1
!!! error sourcing ebuild
 
!!! FAILED prerm: 1

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




Portage 2.0.50-r8 (default-x86-1.4, gcc-3.3.3, glibc-2.3.3.20040420-r0,
2.6.5-gentoo-r1)
=================================================================
System uname: 2.6.5-gentoo-r1 i686 Mobile Intel(R) Pentium(R) 4 - M CPU 2.20GHz
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -mcpu=pentium4 -march=pentium4 -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O3 -mcpu=pentium4 -march=pentium4 -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="ftp://ftp.rnl.ist.utl.pt/pub/gentoo/
ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo
ftp://ftp.uninett.no/pub/linux/Gentoo
ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo
http://ftp.snt.utwente.nl/pub/os/linux/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://descartes/gentoo-portage/"
USE="3ds X X509 Xaw3d aalib acpi acpi4linux alsa apache2 auctex avi berkdb
bonobo cdr cjk clamav cmucl crypt cups dillo djbfft dv dvd emacs encode esd f77
faad fbcon flac fmod foomaticdb gdbm gif gimpprint ginac gnome gnomedb gnuplot
gphoto2 gpm gs gsl gstreamer gtk gtk2 gtkhtml guile hdf5 imlib imlib2 innodb
irda java jpeg libg++ libwww lirc mad mikmod mmx motif mozilla moznocompose
moznoirc moznomail mpeg mpeg4 mpi music ncurses nls offensive oggvorbis opengl
oss pam pcmcia pdflib perl pg-intdatetime plotutils png pnp postgres python
qhull quicktime radeon readline ruby sdl slang speex spell sse ssl
stencil-buffer stroke svga tcltk tcpd tetex theora tiff transcode truetype
trusted type1 v4l v4l2 videos virus-scan wsconvert wxwindows x86 xface xine xml2
xmms xv xvid yv12 zlib"
Comment 1 Meder Bakirov 2004-06-17 05:11:46 UTC
Got same here:

 mail-client/mailx
    selected: 8.1.2.20021129-r2
   protected: 8.1.2.20021129-r3
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging mail-client/mailx-8.1.2.20021129-r2...
No package files given... Grabbing a set.
/usr/sbin/ebuild.sh: /var/db/pkg/mail-client/mailx-8.1.2.20021129-r2/mailx-8.1.2.20021129-r2.ebuild: line 43: unexpected EOF while looking for matching `"'
/usr/sbin/ebuild.sh: /var/db/pkg/mail-client/mailx-8.1.2.20021129-r2/mailx-8.1.2.20021129-r2.ebuild: line 70: syntax error: unexpected end of file

!!! ERROR: mail-client/mailx-8.1.2.20021129-r2 failed.
!!! Function , Line 1297, Exitcode 1
!!! error sourcing ebuild

!!! FAILED prerm: 1
dotcoder root #



dotcoder root # emerge --info
Portage 2.0.50-r8 (default-x86-2004.0, gcc-3.3.3, glibc-2.3.3.20040420-r0, 2.6.5)
=================================================================
System uname: 2.6.5 i686 AMD Athlon(tm) XP 1800+
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-xp -O3 -mfpmath=sse -fforce-addr -fomit-frame-pointer -funroll-loops -funroll-all-loops -fprefetch-loop-arrays -maccumulate-outgoing-args -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.2/share/config /usr/kde/3/share/config /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon-xp -O3 -mfpmath=sse -fforce-addr -fomit-frame-pointer -funroll-loops -funroll-all-loops -fprefetch-loop-arrays -maccumulate-outgoing-args -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="ftp://81.88.192.4/pub/gentoo/portage http://mirror.gentoo.ru/pub/mirror/gentoo/ rsync://mirror.gentoo.ru/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://81.88.192.4/gentoo-portage"
USE="3dnow acpi alsa arts avi berkdb crypt cups dga fbcon gd gdbm gif gpm imap java jpeg kde ldap lesstif maildir mmx mpeg ncurses nls nptl oggvorbis opengl pam png qt quicktime readline samba slang snmp spell sse ssl svga tiff truetype unicode x86 xml xml2 xmms zlib"

dotcoder root #
Comment 2 Aaron Walker (RETIRED) gentoo-dev 2004-06-18 14:16:10 UTC
I also started encountering this error a week or two ago, but until now haven't had time to investigate or see if someone submitted a bug..

The following commands fixed the problem for me:

# emerge -C =mailx-8.1.2.20021129-r3
# emerge =mailx-8.1.2.20021129-r2
# emerge mailx

In english:

 - unmerge the latest version of mailx (r3)
 - reemerge r2
 - upgrade to r3 (r2 should unmerge correctly this time)
Comment 3 Tobias Klausmann gentoo-dev 2004-06-24 00:45:09 UTC
FWIW, I have pinpointed the place where ebuild.sh croaks: it's both in the mailx and the logwatch ebuilds (at least those were the ones that failed on me). The error is at the end of the dependency list (DEPEND="..."). It ends like this:

    mail-client/mailx-support^A

Yes, including that ^A, where a " should be.

Naturally, ebuild.sh does not understand that and bombs. How that ^A got there is completely beyond me, though.

The logwatch ebuild had the exact same problem. Did some script/portage update tweak the mail-client/mailx-support deps throughout the tree?
Comment 4 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2004-06-24 00:52:30 UTC
The CVS tree and the master RSYNC server both give me files that don't contain any ^A in them, so I'm suspecting you've all hit a bad rsync mirror somewhere.
Comment 5 Jeffrey Forman (RETIRED) gentoo-dev 2004-06-28 06:53:58 UTC
If this problem persists please re-open the bug with a specific rsync server that gave you the issue. No further problems with this bug at this moment, so closing it.

-Jeffrey
Comment 6 ra 2004-07-13 10:38:28 UTC
I got this problem with the this mirror rsync://156.56.111.198/gentoo-portage

The problem was with the mailx ebuild.
Comment 7 Ajay Sharma 2004-07-13 10:45:27 UTC
This is a duplicate of Bug 46096 .   Just replace the ^A with a quote (") in the ebuild:

/var/db/pkg/mail-client/mailx-8.1.2.20021129-r2/mailx-8.1.2.20021129-r2.ebuild

and then it'll unmerge after that.  Someone may want to change the resolution from "WORKSFORME" to "DUPLICATE".
Comment 8 Jeffrey Forman (RETIRED) gentoo-dev 2004-07-14 06:54:12 UTC
Confirmed duplicate. THanks.
Comment 9 Tuan Van (RETIRED) gentoo-dev 2004-07-14 12:54:07 UTC
*** Bug 57065 has been marked as a duplicate of this bug. ***
Comment 10 Tuan Van (RETIRED) gentoo-dev 2004-07-16 12:53:24 UTC
*** Bug 57319 has been marked as a duplicate of this bug. ***
Comment 11 Tuan Van (RETIRED) gentoo-dev 2004-08-15 19:51:33 UTC
*** Bug 60508 has been marked as a duplicate of this bug. ***
Comment 12 Tuan Van (RETIRED) gentoo-dev 2004-08-17 10:45:08 UTC
*** Bug 60663 has been marked as a duplicate of this bug. ***
Comment 13 Tuan Van (RETIRED) gentoo-dev 2004-09-27 13:07:29 UTC
*** Bug 65505 has been marked as a duplicate of this bug. ***
Comment 14 Tuan Van (RETIRED) gentoo-dev 2005-02-02 09:46:25 UTC
*** Bug 80450 has been marked as a duplicate of this bug. ***