Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 540872 - media-gfx/ufraw-0.21-r1 : media-libs/jpeg-9a + gcc 4.9.x trivial compatibility fix
Summary: media-gfx/ufraw-0.21-r1 : media-libs/jpeg-9a + gcc 4.9.x trivial compatibilit...
Status: RESOLVED DUPLICATE of bug 520882
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-21 03:07 UTC by Moran Z.
Modified: 2018-02-03 16:43 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Proposed (Trivial) Patch (ufraw-0.20-gcc49.patch,1.01 KB, patch)
2015-02-21 03:07 UTC, Moran Z.
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Moran Z. 2015-02-21 03:07:28 UTC
Created attachment 397108 [details, diff]
Proposed (Trivial) Patch

Same As On Gentoo-Bug #533470 & Probably a DUPLICATE of Gentoo-Bug #520882.

I Wrote The Proposed (Attached) Patch & It Includes a Few Trivial Cpp-Style Type-Casting Fix (from 'bool' to 'boolean') - as Needed To Build This Package.
Comment 1 Andrew Savchenko gentoo-dev 2015-02-27 16:39:36 UTC
Please post the patch at bug 520882.

And for the future: do not create a separate bug just to send a patch for an existing bug. And thank your for your contribution.

*** This bug has been marked as a duplicate of bug 520882 ***
Comment 2 Larry the Git Cow gentoo-dev 2018-02-03 16:43:24 UTC
The bug has been referenced in the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=99f327c67cf7ff29d8ef4608f21ad75285a435ad

commit 99f327c67cf7ff29d8ef4608f21ad75285a435ad
Author:     Andreas Sturmlechner <asturm@gentoo.org>
AuthorDate: 2018-02-03 16:42:55 +0000
Commit:     Andreas Sturmlechner <asturm@gentoo.org>
CommitDate: 2018-02-03 16:42:55 +0000

    media-gfx/ufraw: Fix build w/ jpeg-9, migrate to xdg-utils
    
    Bug: https://bugs.gentoo.org/540872
    Closes: https://bugs.gentoo.org/520882
    Package-Manager: Portage-2.3.24, Repoman-2.3.6

 media-gfx/ufraw/files/ufraw-0.22-jpeg9.patch | 32 ++++++++++
 media-gfx/ufraw/ufraw-0.22-r2.ebuild         | 94 ++++++++++++++++++++++++++++
 2 files changed, 126 insertions(+)}