Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 540826 - <dev-libs/libuv-1.4.2: incorrect revocation order while relinquishing privileges (CVE-2015-0278)
Summary: <dev-libs/libuv-1.4.2: incorrect revocation order while relinquishing privile...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Security
Classification: Unclassified
Component: Vulnerabilities (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Security
URL: https://bugzilla.redhat.com/show_bug....
Whiteboard: B2 [glsa cve]
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-20 17:11 UTC by Agostino Sarubbo
Modified: 2016-11-17 10:09 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Agostino Sarubbo gentoo-dev 2015-02-20 17:11:19 UTC
From ${URL} :

It was found [1] that libuv does not call setgoups before calling setuid/setgid.
This may potentially allow an attacker to gain elevated privileges.
Upstream fix for 0.10: https://github.com/libuv/libuv/pull/215

[1]: https://github.com/libuv/libuv/commit/66ab38918c911bcff025562cf06237d7fedaba0c


@maintainer(s): after the bump, in case we need to stabilize the package, please let us know if it is ready for the stabilization or not.
Comment 1 Julian Ospald 2015-02-22 02:20:00 UTC
there is nothing to bump, this code is already in 1.4.0:
https://github.com/libuv/libuv/blob/v1.4.0/src/unix/process.c#L328

just stabilize it WHILE TESTING REVERSE DEPS
Comment 2 GLSAMaker/CVETool Bot gentoo-dev 2015-06-17 17:59:51 UTC
CVE-2015-0278 (http://nvd.nist.gov/nvd.cfm?cvename=CVE-2015-0278):
  libuv before 0.10.34 does not properly drop group privileges, which allows
  context-dependent attackers to gain privileges via unspecified vectors.
Comment 3 Julian Ospald 2015-10-26 12:28:36 UTC
please finalize this bug, the affected versions are gone
Comment 4 Aaron Bauman Gentoo Infrastructure gentoo-dev Security 2016-11-17 08:32:28 UTC
Upstream GitHub links confirm this is in 1.10.0 which is the oldest in Portage as well.
Comment 5 Kristian Fiskerstrand gentoo-dev Security 2016-11-17 09:47:20 UTC
(In reply to Aaron Bauman from comment #4)
> Upstream GitHub links confirm this is in 1.10.0 which is the oldest in
> Portage as well.

1.10.0 is the newest in the gentoo tree, not the oldest. But the version reference in CVE is for nodejs, not libuv, which has fix in 1.4.0 as described in comment 1.
Comment 6 GLSAMaker/CVETool Bot gentoo-dev 2016-11-17 10:09:48 UTC
This issue was resolved and addressed in
 GLSA 201611-10 at https://security.gentoo.org/glsa/201611-10
by GLSA coordinator Aaron Bauman (b-man).