Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 5405 - Compile failure on xkbcomp in Xfree86-4.2.0-r12
Summary: Compile failure on xkbcomp in Xfree86-4.2.0-r12
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: x86 Linux
: High critical (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2002-07-22 14:27 UTC by John Davis (zhen) (RETIRED)
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John Davis (zhen) (RETIRED) gentoo-dev 2002-07-22 14:27:23 UTC
When compiling Xfree86-4.2.0-r12 through portage, the compile bails on xkbcomp 
with the error : xkbcomp not found in ../../../exports/bin.
I have replicated the bug several times, and the only way that I have found to 
circumvent it was to open another terminal and manually compile xkbcomp and its 
components during the emerge. It seems that the xkbcomp tree is not getting 
built at all, and it is causing the build to bail out.
Comment 1 John Davis (zhen) (RETIRED) gentoo-dev 2002-07-22 14:35:12 UTC
Just as an addendum, this is the system that I was building on:

Athlon XP 1900+
abit KG7 motherboard
512M PC2100
GeForce4 TI4400

Comment 2 Toonse 2002-07-22 21:31:10 UTC
I get the same problem.  However xkbcomp IS being compiled, it is
just not being copied to ../../../exports/bin, so the compat.dir
creation that it does fails.  If I then copy xkbcomp to the proper
directory and do ebuild xfree-* install, then ebuild xfree-* qmerge,
it appears to work, but I can't get the resulting X installation to
run, just dies immediately with IO Error 104 on :0.0
Very frustrating.  Running on an Athlon 1800+.  This happened for
2 fresh 1.2 installations and one 1.3b installation.
Comment 3 John Davis (zhen) (RETIRED) gentoo-dev 2002-07-22 23:06:52 UTC
Seems that Toonse and I have resolved the problem.
It seems that grsecurity was set to "high" in our kernels. This caused X to not 
be able to bind to a screen. I am not sure if this is the same for the other 
settings of grsecurity, but it would be interesting to find out.

Comment 4 John Davis (zhen) (RETIRED) gentoo-dev 2002-07-22 23:38:34 UTC
Sorry for the error, but its really late/early ;-)
My above fix solves's toonse's problem of x not starting and just hanging. The 
compilation issue w/ xkbcomp *still exists*

Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2002-07-23 00:07:12 UTC
What about remerging with grsecurity disabled ?
Comment 6 John Davis (zhen) (RETIRED) gentoo-dev 2002-07-23 08:47:14 UTC
I haven't tried that yet, as I just got X working and don't have another box to 
try it on... I will try and find another box, but that is not looking good 
right now. Give it a try if you want to ;-)

Comment 7 Martin Schlemmer (RETIRED) gentoo-dev 2002-07-23 14:16:51 UTC
I despise grsecurity :/  This I guess I can add to the list of things why.  It
is just too deeply rooted, causes things to misbehave,  a massive slowdown,
and just general unstable system.  Ok, ok, so it was some time since I did
try it out last.

Just as an note .... I have compiled -r12 near 20 times on this box alone
now, if not more during debugging, adding patches, etc.  It also has compiled
fine on a few others.  So, maybe its grsecurity, maybe something else.  Thus
you have my vote of it working ( *g* ).  It would have been nice though to
know if it worked fine on the systems that it failed to compile with grsecurity
or not.  This now without making too many (except for kernel) changes to the

Anyhow, ill see if I can find anything out until maybe one of you guys gets
a moment to test it.

Comment 8 Jean-Denis Langelier 2002-08-05 09:17:08 UTC
 I get the same error when I try to compile xfree-4.2.0-r12 on my cyrix  
pr200+(150mhz), 64 mb ram, 6gb hdd, s3 968, 3dfx voodoo 1.  Also, gsecurity is 
disabeld in my kernel 
Comment 9 dav7id 2002-08-12 22:12:32 UTC
I also get the same error.  I am running on an athalon xp1800 and gresecurity 
is enabled, high i think.  this is a fresh 1.2 stage 1 install.
Comment 10 dav7id 2002-08-12 23:02:33 UTC
I just recompiled my kernel without gresecurity and got the same error.
Comment 11 dav7id 2002-08-13 22:33:37 UTC
I got xfree-4.2.0-r12 to merge.  First i built a new kernel without 
gresecurity, and added "-nogresec" to the maefiles extra version, rebooted to 
the new kernel and had the same problem.  Then I tried changing 
the /usr/src/linux link to point to a new linux source tree which was renamed 
to match the kernel version as given by uname -a.
then it worked.:)