Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 540154 - dev-ruby/bluecloth-2.2.0-r2 - src_compile(): This Rakefile requires rake-compiler (gem install rake-compiler)
Summary: dev-ruby/bluecloth-2.2.0-r2 - src_compile(): This Rakefile requires rake-comp...
Status: RESOLVED DUPLICATE of bug 424339
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-15 16:24 UTC by Juergen Rose
Modified: 2016-03-06 08:12 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,25.57 KB, text/plain)
2015-02-15 16:24 UTC, Juergen Rose
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Juergen Rose 2015-02-15 16:24:47 UTC
Created attachment 396516 [details]
build.log

'MAKEOPTS=-j1 emerge -v1 bluecloth' fails with:
...
cp spec/markdowntest_spec.rb tmp/x86_64-linux/stage/spec/markdowntest_spec.rb
install -c tmp/x86_64-linux/bluecloth_ext/2.0.0/bluecloth_ext.so lib/bluecloth_ext.so
cp tmp/x86_64-linux/bluecloth_ext/2.0.0/bluecloth_ext.so tmp/x86_64-linux/stage/lib/bluecloth_ext.so
 * Running compile phase for all ...
This Rakefile requires rake-compiler (gem install rake-compiler)
 * ERROR: dev-ruby/bluecloth-2.2.0-r2::gentoo failed (compile phase):
 *   (no error message)




root@lynx:/root(8)# emerge --info '=dev-ruby/bluecloth-2.2.0-r2::gentoo'
Portage 2.2.17 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.2, glibc-2.20-r1, 3.19.0-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.19.0-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T9500_@_2.60GHz-with-gentoo-2.2
KiB Mem:     8100304 total,   2021692 free
KiB Swap:   12582908 total,  12533216 free
Timestamp of repository gentoo: Sun, 15 Feb 2015 14:00:01 +0000
sh bash 4.3_p33-r1
ld GNU ld (Gentoo 2.25 p1.0) 2.25
distcc[20476] (dcc_trace_version) distcc 3.2rc1 x86_64-pc-linux-gnu; built Jan  2 2015 07:30:34 [disabled]
app-shells/bash:          4.3_p33-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.9-r2::gentoo, 3.3.5-r1::gentoo, 3.4.2::gentoo
dev-util/cmake:           3.1.0::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.13.9::gentoo
sys-apps/sandbox:         2.6-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.9.6-r4::gentoo, 1.10.3-r1::gentoo, 1.11.6-r1::gentoo, 1.12.6::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25::gentoo
sys-devel/gcc:            4.9.2::gentoo
sys-devel/gcc-config:     1.8::gentoo
sys-devel/libtool:        2.4.5::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 3.19::gentoo (virtual/os-headers)
sys-libs/glibc:           2.20-r1::gentoo
Repositories:

gentoo
    location: /usr/portage_lynx
    sync-type: rsync
    sync-uri: rsync://rsync.gentoo.org/gentoo-portage
    priority: -1000

sage-on-gentoo
    location: /var/lib/layman/sage-on-gentoo
    masters: gentoo
    priority: 0

science
    location: /var/lib/layman/science
    masters: gentoo
    priority: 1

sunrise
    location: /var/lib/layman/sunrise
    masters: gentoo
    priority: 2

x11
    location: /var/lib/layman/x11
    masters: gentoo
    priority: 3

ago
    location: /var/lib/layman/ago
    masters: gentoo
    priority: 4

tlp
    location: /var/lib/layman/tlp
    masters: gentoo
    priority: 5

local
    location: /usr/local/portage
    masters: gentoo
    priority: 6

g-cpan
    location: /var/lib/cpan
    masters: gentoo
    priority: 7

g-octave
    location: /var/lib/g-octave
    masters: gentoo
    priority: 8

Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA PUEL Intel-SDP dlj-1.1 skype-eula skype-4.0.0.7-copyright googleearth AdobeFlash-11.x cadsoft Oracle-BCLA-JavaSE MakeMKV-EULA NVIDIA-CUDA Nero-AAC-EULA GIMPS"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=native -O2 -pipe"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://ftp.tu-clausthal.de/pub/linux/gentoo ftp://ftp.easynet.nl/mirror/gentoo/ "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
USE="64bit R X Xaw3d a52 aac acl acpi admin afs alsa amd64 ao apache2 apng applet archive armadillo arpack asf aspell atlas audacious audiofile automap automount bash-completion berkdb blas blast bluetooth bluray boost branding bzip2 cairo cdda cddb cdf cdio cdparanoia cdr cg cgi chm cli cmake consolekit cracklib crypt css cups curl cxx daap db dbi dbm dbus declarative designer devhelp device-mapper dga dia dirac djvu doc dot dri ds2490 ds9097 ds9097u dts dv dvb dvd dvdr dvi dynamicplugin eds egl elf emacs emboss emf encode epiphany evo examples exif expat extensions extra extras faac faad fam ffmpeg fftw firefox fits flac fltk fontconfig foomaticdb fortran fortran95 fpm fpx fuse g3dvl garmin gcj gd gdal gdbm gdu gedit geoip geolocation geos gfortran gif gimp git glade glamor glib glpk gml gmp gnome gnome-keyring gnome-print gnuplot gnutls gold gphoto2 gpm grammar graphics graphtft graphviz grass gsl gsm gstreamer gtk gtk3 gudev guile hdaps hddtemp hdf hdf5 hdri html http httpd hvm hwdb iconv icq icu id3tag ide imagemagick imap inotify introspection ipod ipv6 irda ithreads jabber jadetex java java6 jbig jit john jpeg jpeg2k kate kde kdepim kdrive kerberos keymap kpathsea kvm ladspa lame lapack laptop latex lcms ldap lensfun libffi libkms libnotify libsamplerate lirc live lua lzma lzo mad mail maildir mapnik math matroska media-library mercurial mikmod mkl mmx mmxext mng mod modules mono motif mozilla mp3 mp4 mpeg mpi mplayer mtp multilib multimedia musepack musicbrainz mysql mysqli nautilus ncurses neXt netcdf netpbm network networking nfs nls nntp nptl nsplugin ntfs ntp numpy obex objc ocaml ocr octave odbc ofa ogdi ogg openexr opengl openmp openvg pam pango pcre pda pdf pdl2 perl plasma plotutils plugins png podcast policykit portaudio posix postgres postscript ppds preview-latex proj projectm pstricks pulseaudio python python-bindings q16 q32 qemu qhull qt3support qt4 quicktime raw readline reiserfs reports rle romio rpc rrdcgi rrdtool sage samba sasl schroedinger science sdk sdl secure-delete semantic-desktop server session shout sip slang slp smart smbclient smp sms sndfile snmp soap sockets sound soup sox speex spell sql sqlite sse sse2 sse4 sse4_1 ssl ssse3 startup-notification stlport subtitles subversion sudo suexec svg svm swig systemd szip t1lib tcl tcpd tex tex4ht texmacs theora thesaurus thinkpad threads thunderbird tidy tiff tk tools truetype udev udisks unicode upower usb utempter v4l vaapi vala valgrind vdpau video virt-network virtualbox visio vorbis vpx vtk wav webdav webdav-serf webkit wifi wmf wxwidgets x264 xa xattr xcb xetex xext xft xine xml xmlreader xmlrpc xpm xv xvid xvmc yaml youtube zlib zvbi" ABI_X86="64" ALSA_CARDS="intel8x0" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_core authn_dbm authn_default authn_file authz_core authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache env expires ext_filter file_cache filter headers ident imagemap include info lbmethod_byrequests log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif slotmem_shm so socache_shmcb speling status unique_id unixd userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="canon fuji ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog sensors thermal" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" CURL_SSL="nss" DRACUT_MODULES="caps lvm syslog" DVB_CARDS="usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev synaptics void" KERNEL="linux" LCD_DEVICES="cfontz hd44780 mtxorb ncurses X lcd2usb lcdlinux png usblcd" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de fr ru" NETBEANS_MODULES="apisupport cnd dlight enterprise ergonomics groovy gsf harness ide identity j2ee java mobility nb php profiler websvccommon xml" OFFICE_IMPLEMENTATION="libreoffice" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="arm i386 x86_64" QEMU_USER_TARGETS="arm i386 x86_64" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau displaylink" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON



root@lynx:/root(9)# emerge -pqv '=dev-ruby/bluecloth-2.2.0-r2::gentoo'
[ebuild  N    ] dev-ruby/bluecloth-2.2.0-r2  USE="doc {-test}" RUBY_TARGETS="ruby19 ruby20 -ruby21"
Comment 1 Andrey Grozin gentoo-dev 2015-02-25 17:36:49 UTC
Same here: RUBY_TARGETS="ruby19 ruby22", ruby22 eselected
Comment 2 Hans de Graaff gentoo-dev 2015-02-25 17:52:58 UTC
(In reply to Juergen Rose from comment #0)

>  * Running compile phase for all ...
> This Rakefile requires rake-compiler (gem install rake-compiler)
>  * ERROR: dev-ruby/bluecloth-2.2.0-r2::gentoo failed (compile phase):
>  *   (no error message)

> root@lynx:/root(9)# emerge -pqv '=dev-ruby/bluecloth-2.2.0-r2::gentoo'
> [ebuild  N    ] dev-ruby/bluecloth-2.2.0-r2  USE="doc {-test}"
> RUBY_TARGETS="ruby19 ruby20 -ruby21"

I can't reproduce this. Based on the bluecloth emerge output I assume you have ruby19 or ruby20 eselected?
Comment 3 Hans de Graaff gentoo-dev 2015-02-25 17:55:09 UTC
(In reply to Andrey Grozin from comment #1)
> Same here: RUBY_TARGETS="ruby19 ruby22", ruby22 eselected

We currently can't support eselecting ruby22 yet since many packages are not marked for it yet, bug 424339.
Comment 4 Hans de Graaff gentoo-dev 2015-07-08 10:07:51 UTC

*** This bug has been marked as a duplicate of bug 424339 ***
Comment 5 Juergen Rose 2016-03-06 08:12:15 UTC
The issue happens on the next system. 'emerge -pvD bluecloth' shows 
RUBY_TARGETS="ruby20 ruby21 ruby22 (-ruby19)". But anyway ruby23 was eselected.

This Rakefile requires rake-compiler (gem install rake-compiler)
 * ERROR: dev-ruby/bluecloth-2.2.0-r2::gentoo failed (compile phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  133:  Called src_compile
 *   environment, line 4524:  Called ruby-ng_src_compile
 *   environment, line 4215:  Called _ruby_invoke_environment 'all' 'all_ruby_compile'
 *   environment, line  732:  Called all_ruby_compile
 *   environment, line  816:  Called die
 * The specific snippet of code:
 *       rake man/man1/bluecloth.1 || die;
 * 
 * If you need support, post the output of `emerge --info '=dev-ruby/bluecloth-2.2.0-r2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-ruby/bluecloth-2.2.0-r2::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=  CLASSPATH="/usr/libexec/ccp4/bin:" JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info =bluecloth-2.2.0
 * The complete build log is located at '/var/tmp/portage/dev-ruby/bluecloth-2.2.0-r2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-ruby/bluecloth-2.2.0-r2/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-ruby/bluecloth-2.2.0-r2/work/all/bluecloth-2.2.0'
 * S: '/var/tmp/portage/dev-ruby/bluecloth-2.2.0-r2/work/all/bluecloth-2.2.0'

>>> Failed to emerge dev-ruby/bluecloth-2.2.0-r2, Log file:

>>>  '/var/tmp/portage/dev-ruby/bluecloth-2.2.0-r2/temp/build.log'

 * GNU info directory index is up-to-date.
....
root@leopard:/root(107)# grep RUBY /etc/make.conf
#RUBY_TARGETS="ruby18 jruby"
root@leopard:/root(108)# eselect ruby list
Available Ruby profiles:
  [1]   ruby20 (with Rubygems)
  [2]   ruby21 (with Rubygems)
  [3]   ruby22 (with Rubygems)
  [4]   ruby23 (with Rubygems) *
root@leopard:/root(109)# emerge -pvD bluecloth

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-ruby/bluecloth-2.2.0-r2::gentoo  USE="doc {-test}" RUBY_TARGETS="ruby20 ruby21 ruby22 (-ruby19)" 0 KiB



After eselecting ruby22 'emerge bluecloth' worked.