Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 539968 - kernel 3.14.? - screen LVDS1 turns black early at boot
Summary: kernel 3.14.? - screen LVDS1 turns black early at boot
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL: https://bugzilla.kernel.org/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-13 12:11 UTC by charles17
Modified: 2015-03-28 21:15 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (emerge --info,5.45 KB, text/plain)
2015-02-13 12:11 UTC, charles17
Details
reverse git bisect (reverse bisect,3.43 KB, text/plain)
2015-02-13 12:16 UTC, charles17
Details
Kernel configuration (config-3.14.31-gentoo,77.37 KB, text/plain)
2015-02-13 12:19 UTC, charles17
Details
lspci -vvv -s 00:02.0 (lspci -vvv -s 00:02.0,1.02 KB, text/plain)
2015-02-13 12:23 UTC, charles17
Details
dmesg without VGA plugged (dmesg_not_plugged,86.73 KB, text/plain)
2015-02-14 13:01 UTC, charles17
Details

Note You need to log in before you can comment on or make changes to this bug.
Description charles17 2015-02-13 12:11:11 UTC
Created attachment 396348 [details]
emerge --info

Screen LVDS1 turns black early at boot with kernel 3.14

The computer is a laptop and  has been used with an external screen plugged (VGA) for several months.

After unplugging the VGA from the laptop I was getting a black screen at boot. Grub2 screen is ok but in the very early stage at boot just after showing the first few kernel lines the built-in screen turns black.  

CTRL-ALT-F1 + CTRL-ALT--F7 does not help.  Built-in screen stays black until a VGA is plugged.  

With the VGA plugged (even when it's power is off) the boot is normal with all the boot messages visible on the built-in screen. This behaviour is reproducible:

  VGA plugged: Screen is ok
  VGA unplugged: Screen tuns black at boot

The problem seems to be fixed later in kernel v3.15
Comment 1 charles17 2015-02-13 12:16:04 UTC
Created attachment 396350 [details]
reverse git bisect

I did a reverse git bisect leading to 484b41dd70a9fbea894632d8926bbb93f05021c7 

$ git branch --contains 484b41dd70a9fbea894632d8926bbb93f05021c7
master

$ git tag --contains 484b41dd70a9fbea894632d8926bbb93f05021c7
v3.15
v3.15-rc1
v3.15-rc2
v3.15-rc3
v3.15-rc4
... until ...
v3.19-rc6
v3.19-rc7

Checked out v.3.15 for testing and was ok.
Comment 2 charles17 2015-02-13 12:19:19 UTC
Created attachment 396354 [details]
Kernel configuration
Comment 3 charles17 2015-02-13 12:23:02 UTC
Created attachment 396358 [details]
lspci -vvv -s 00:02.0
Comment 4 Jeroen Roovers gentoo-dev 2015-02-13 19:42:57 UTC
(In reply to charles17 from comment #0)
> After unplugging the VGA from the laptop I was getting a black screen at
> boot. Grub2 screen is ok but in the very early stage at boot just after
> showing the first few kernel lines the built-in screen turns black.  

Does it turn "black" or does it simply switch off?

> The problem seems to be fixed later in kernel v3.15

There isn't anything to fix then? 3.17 is stable and 3.19 is in the tree. 3.15 was removed in October 2014. If it's fixed in 3.15 then the fix may have got backported to a later 3.14 release.
Comment 5 charles17 2015-02-13 22:20:47 UTC
(In reply to Jeroen Roovers from comment #4)
> [...]
> Does it turn "black" or does it simply switch off?

Black.  And the Fn keys (brightness) are working, regardless if VGA is plugged or not.  In case VGA is unplugged even the black gets kinda darker or brighter with these keys. 

> 
> > The problem seems to be fixed later in kernel v3.15
> 
> There isn't anything to fix then? 3.17 is stable and 3.19 is in the tree.
> 3.15 was removed in October 2014. If it's fixed in 3.15 then the fix may
> have got backported to a later 3.14 release.

Which one?  I did the git bisect and it turned out tha tcommit is not in any 3.14.  Any 3.14.x I've tested fails.
Comment 6 charles17 2015-02-14 13:01:54 UTC
Created attachment 396446 [details]
dmesg without VGA plugged
Comment 7 Mike Pagano gentoo-dev 2015-02-24 17:02:57 UTC
Not sure it's worth back porting this patch.  Have you thought about upgrading your kernel > 3.14 ?
Comment 8 charles17 2015-02-25 07:56:25 UTC
(In reply to Mike Pagano from comment #7)
> Not sure it's worth back porting this patch.  

According to https://www.kernel.org/category/releases.html kernel 3.14 will be supported until Aug. 2016.  Do you think there is some chance getting it fixed upstream?
Comment 9 Mike Pagano gentoo-dev 2015-03-01 13:58:45 UTC
You can certainly try. You did a lot of work and acutally identified the commit.  If you want, submit to bugzilla.kernel.org and please post the bug # back here.

Thanks!