Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 539458 - dev-db/mariadb-10.0.15-r1 - In file included from .../work/mysql/vio/vio.c:24: .../work/mysql/include/my_pthread.h:169:19: fatal error: synch.h: No such file or directory
Summary: dev-db/mariadb-10.0.15-r1 - In file included from .../work/mysql/vio/vio.c:24...
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: ARM Linux
: Normal normal (vote)
Assignee: Gentoo Linux MySQL bugs team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-09 12:36 UTC by Fab
Modified: 2016-09-05 09:40 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,90.90 KB, text/plain)
2015-02-09 12:37 UTC, Fab
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fab 2015-02-09 12:36:55 UTC
Build log will follow.

# emerge -pv mariadb

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-db/mariadb-10.0.15-r1 [5.5.40-r1] USE="community pam perl ssl -bindist -cluster -debug -embedded -extraengine -jemalloc -latin1 -minimal -odbc% -oqgraph -profiling (-selinux) -sphinx -static -static-libs -systemtap -tcmalloc {-test} (-tokudb) -xml% (-max-idx-128%)" 0 KiB
[ebuild     U  ] virtual/mysql-5.6-r2:0/18 [5.5:0/0] USE="-embedded -minimal -static -static-libs" 0 KiB

Reproducible: Always




# emerge --info
Portage 2.2.14 (python 2.7.9-final-0, default/linux/arm/13.0/armv7a, gcc-4.8.3, glibc-2.19-r1, 3.4.105+ armv7l)
=================================================================
System uname: Linux-3.4.105+-armv7l-ARMv7_Processor_rev_4_-v7l-with-gentoo-2.2
KiB Mem:      898552 total,    168556 free
KiB Swap:     262140 total,    223256 free
Timestamp of tree: Mon, 09 Feb 2015 07:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 armv7a-hardfloat-linux-gnueabi [enabled]
app-shells/bash:          4.2_p53
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.9
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo voyageur
ACCEPT_KEYWORDS="arm"
ACCEPT_LICENSE="* -@EULA"
CBUILD="armv7a-hardfloat-linux-gnueabi"
CFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -ggdb"
CHOST="armv7a-hardfloat-linux-gnueabi"
CONFIG_PROTECT="/etc /var/bind"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -ggdb"
DISTDIR="/portage/distfiles/"
EMERGE_DEFAULT_OPTS="--with-bdeps=y"
FCFLAGS="-O2 -pipe -march=armv7-a"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distcc distcc-pump distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -march=armv7-a"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="fr_FR.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/portage/packages/armv7-a/"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/portage/trees/gentoo"
PORTDIR_OVERLAY="/portage/trees/layman/voyageur"
USE="arm armv5te armv6 armv6t2 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 libav modules mysql ncurses nls nptl openmp pam pcre readline session ssl tcpd unicode zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Fab 2015-02-09 12:37:35 UTC
Created attachment 395968 [details]
build.log
Comment 2 Brian Evans Gentoo Infrastructure gentoo-dev 2015-02-10 14:07:12 UTC
What in the world is this?

> shell-init: error retrieving current directory: getcwd: cannot access parent directories: Permission denied
> shell-init: error retrieving current directory: getcwd: cannot access parent directories: Permission denied
> job-working-directory: error retrieving current directory: getcwd: cannot access parent directories: Permission denied
> chdir: error retrieving current directory: getcwd: cannot access parent directories: Permission denied


Might more problems than just this error.


> -- Looking for include file synch.h
> -- Looking for include file synch.h - found

That's why it tries to load it.

#ifdef HAVE_SYNCH_H
#include <synch.h>
#endif
Comment 3 Brian Evans Gentoo Infrastructure gentoo-dev 2015-02-10 14:19:52 UTC
Does it fail if distcc is disabled?
Comment 4 Fab 2015-02-10 15:31:39 UTC
> What in the world is this?
[...]
> Might more problems than just this error.

I don't know, these errors occurs at each emerge phase on some (not all)
packages since the system was installed, but I never had any problem.
I already tried to find the root cause without success.


Before opening this bug I tried to disable tmpfs, and to redefine MAKEOPTS but I did not think to disable distcc. Without it it seems to build fine, the build process is at 40% and is in progress, but obviously without distcc it seems endless. Thanks.
Comment 5 Brian Evans Gentoo Infrastructure gentoo-dev 2015-02-10 17:53:09 UTC
Nothing i can do to fix distcc.

Closing
Comment 6 Fab 2016-09-05 09:40:00 UTC
For the record, the guilty is distcc-pump mode.
Builds fine with distcc, but does not build when pump mode activated.

See also bug #574102 and bug #581732.

Pump mode is causing a lot of « random » build failures on various packages.