Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 538864 - Configuration instructions for cronie and anacron is misleading
Summary: Configuration instructions for cronie and anacron is misleading
Status: RESOLVED INVALID
Alias: None
Product: [OLD] Docs on www.gentoo.org
Classification: Unclassified
Component: Other documents (show other bugs)
Hardware: All Linux
: Normal normal with 1 vote (vote)
Assignee: Docs Team
URL: https://wiki.gentoo.org/wiki/Cron
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-04 22:38 UTC by Lars
Modified: 2016-02-06 13:13 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lars 2015-02-04 22:38:05 UTC
I had to search the bug reports to find out why anacron was not running on my system although I emerged cronie with the anacron USE-flag. Although the documentation says:

> Additionally cronie comes with an anacron implementation which must be enabled through the anacron USE flag.

However, anacron is not *enabled* at all without further configuration!

1) Neither the documentation nor cronie's einfo says that anacron has to be started as hourly cronjob. I found this information here: https://bugs.gentoo.org/show_bug.cgi?id=503666#c5

> Working configuration for /etc/crontab, when using anacron:
> 01 * * * * root run-parts /etc/cron.hourly

This line could also be placed in /etc/crontab (at least commented-out). 

2) I have to make sure that all scripts below /etc/cron.* are executable. This not mentioned in the documentation and I never saw a einfo explaining this when I emerged a package that installed cron-scripts. Again I found it in a bug report: https://bugs.gentoo.org/show_bug.cgi?id=503634

> After installing sys-process/cronie with anacron USE flag, anacron was never launched.
> 
> I understand that anacron is launched by cron thanks to /etc/cron.hourly/0anacron.
> And this script isn't executable.
> After doing chmod +x /etc/cron.hourly/0anacron, anacron is correctly executed.

3. The advice to comment-out the checks for cron.daily, cron.weekly and cron.monthly in /etc/crontab (https://wiki.gentoo.org/wiki/Cron#Using_anacron) is misleading. The default crontab for cronie already checks if /etc/cron.hourly/0anacron exists and is executable.

4. It should be clearly stated that "crontab /etc/crontab" copies the content of /etc/crontab to the users crontab which leads to "root: command not found" errors when using cronie (https://bugs.gentoo.org/show_bug.cgi?id=455476)

Reproducible: Always

Steps to Reproduce:
1. Read the documentation 
2. Emerge cronie with the anacron USE-flag.

Actual Results:  
Anacron is not running though the USE flag has been set and the documentation says this would enable anacron.

Expected Results:  
Anacron is running by default OR the documentation clearly points out the configuration steps needed to get in running. Some comments in /etc/crontab
/etc/cron.hourly/0anacron or /etc/anacrontab would be helpful.
Comment 1 SpanKY gentoo-dev 2015-09-26 14:48:53 UTC
*** Bug 551352 has been marked as a duplicate of this bug. ***
Comment 2 nm (RETIRED) gentoo-dev 2016-02-06 07:42:42 UTC
please use the "discussion" tab on the appropriate wiki page for suggestions, rather than opening bugs.
Comment 3 Jaak Ristioja 2016-02-06 13:13:18 UTC
(In reply to Josh Saddler from comment #2)
> please use the "discussion" tab on the appropriate wiki page for
> suggestions, rather than opening bugs.

Huh, what!? The b.g.o BugZilla has like 5 categories for documentation bugs and none of these apply to Gentoo's documentation? I thought this is where doc bugs should go, as has always been the case in the past. Has somebody forgotten to add a note somewhere on b.g.o about where wiki.g.o bugs should go?

Secondly, as far as I can tell this is not a mere suggestion but an actual documentation bug. Which should be handled as such instead of getting lost on some discussion forum.