Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 538504 - media-video/mpv requests wrong ffmpeg upstream
Summary: media-video/mpv requests wrong ffmpeg upstream
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-02 06:59 UTC by Joe Kappus
Modified: 2015-02-02 18:50 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joe Kappus 2015-02-02 06:59:57 UTC
Upstream mpv suggests ffmpeg to be used.  Using libav opens users to missing functionality. 

This is dishonest and reckless behavior to set a default that upstream doesn't support.  Please correct this. 

Upstream's position: https://github.com/mpv-player/mpv/wiki/FFmpeg-versus-Libav
Comment 1 Ben de Groot (RETIRED) gentoo-dev 2015-02-02 07:12:37 UTC
This is not a bug. Our ebuilds offer ffmpeg and libav useflags, so the user can choose which implementation they want to use with mpv.
Comment 2 Joe Kappus 2015-02-02 09:45:22 UTC
You misunderstood, it is a bug because libav is not recommended and it was set as default in this revision. This is going to lead to problems for uninformed users.  

There should be information added to the ebuild warning that merging with libav will cause broken/limited subtitle support, as it's very likely users will start to file bugs on here when things that used to work stop working.
Comment 3 Nikoli 2015-02-02 11:11:33 UTC
Joe, now it is not possible to install both ffmpeg and libav in one Gentoo system, so whether ffmpeg or libav is default is distro wide choice, not per package:
http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/profiles/base/make.defaults?r1=1.121&r2=1.122

Also did you read metadata/news/2015-02-01-use-libav/2015-02-01-use-libav.en.txt ?
If you want ffmpeg, disable USE libav in your make.conf.


In mpv both ffmpeg and libav are supported:
https://github.com/mpv-player/mpv/wiki/FFmpeg-versus-Libav#is-ffmpeg-or-libav-preferred-for-use-with-mpv
"Although mpv attempts to work well with both FFmpeg and Libav, FFmpeg is preferred in general."
Comment 4 Joe Kappus 2015-02-02 18:34:57 UTC
Thanks for directing me to the news item, at least there was a notification.  I stand corrected.  I will close this.

This just seems a bad way to handle things, the news item states mplayer won't build off libav, mpv will build off it, but doesn't suggest it because of lost functionality.  Are their any cases where libav is actually preferred?

All I've seen is a long history of the libav developers trying to hijack their way into getting used in place of ffmpeg while rewriting things to make it look like ffmpeg doesn't exist.  Anything they bring to the table ends up in ffmpeg anyway.

"the user can choose which implementation they want to use with mpv." yes they can, but this is a poor default that the casual user loses with.  Hell, even the devs lose out, look at all the dozens of open bugs because packages don't build with libav, or call ffmpeg directly (instead of avconv).  And this is the situation a year after the default was swapped and 4 years after the fork.
Comment 5 Nikoli 2015-02-02 18:50:50 UTC
> Are their any cases where libav is actually preferred?

Yes, at least these projects use libav instead of ffmpeg:
media-plugins/gst-plugins-libav http://gstreamer.freedesktop.org/modules/gst-libav.html
media-video/handbrake https://handbrake.fr/news.php