Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 538468 - sys-devel/llvm-3.5.0 - .../work/llvm-3.5.0.src/lib/LTO/LTOCodeGenerator.cpp:154:1: internal compiler error: in merge_if_block, at ifcvt.c:3193
Summary: sys-devel/llvm-3.5.0 - .../work/llvm-3.5.0.src/lib/LTO/LTOCodeGenerator.cpp:1...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: ARM Linux
: Normal normal with 1 vote (vote)
Assignee: LLVM support project
Depends on:
Blocks: lto
  Show dependency tree
Reported: 2015-02-01 19:50 UTC by Vladimir Monchenko
Modified: 2018-03-29 07:47 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---

Buld log (build.log.bz2,30.09 KB, application/x-bzip2)
2015-02-02 16:57 UTC, Vladimir Monchenko

Note You need to log in before you can comment on or make changes to this bug.
Description Vladimir Monchenko 2015-02-01 19:50:04 UTC
llvm-3.5.0 fails to build.

End of build log:

echo 'Created.' > /var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/.dir
llvm[2]: Compiling LTOCodeGenerator.cpp for Release build
if  armv7a-hardfloat-linux-gnueabi-g++ -I/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/include -I/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO -I/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/include -I/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/lib/LTO  -DNDEBUG -D_GNU_SOURCE -D__STDC_CONSTANT_MACROS -D__STDC_FORMAT_MACROS -D__STDC_LIMIT_MACROS   -std=c++11 -fvisibility-inlines-hidden -fno-exceptions -fPIC -Woverloaded-virtual -ffunction-sections -fdata-sections -Wcast-qual -O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -I/usr/lib/libffi-3.0.13/include   -pedantic -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings    -Wno-maybe-uninitialized -Wno-missing-field-initializers -c -MMD -MP -MF "/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.d.tmp" -MT "/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.o" -MT "/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.d" /var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/lib/LTO/LTOCodeGenerator.cpp -o /var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.o ; \
        then /bin/mv -f "/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.d.tmp" "/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.d"; else /bin/rm "/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.d.tmp"; exit 1; fi
/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/lib/LTO/LTOCodeGenerator.cpp: In member function ‘void llvm::LTOCodeGenerator::setCodePICModel(lto_codegen_model)’:
/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/lib/LTO/LTOCodeGenerator.cpp:154:1: internal compiler error: in merge_if_block, at ifcvt.c:3193
Please submit a full bug report,
with preprocessed source if appropriate.
See <> for instructions.
/bin/rm: cannot remove ‘/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.d.tmp’: No such file or directory
/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/Makefile.rules:1519: recipe for target '/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.o' failed
make[2]: *** [/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO/Release/LTOCodeGenerator.o] Error 1
make[2]: Leaving directory '/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib/LTO'
/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/Makefile.rules:937: recipe for target 'LTO/.makeall' failed
make[1]: *** [LTO/.makeall] Error 2
make[1]: Leaving directory '/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src-.arm/lib'
/var/tmp/portage/sys-devel/llvm-3.5.0/work/llvm-3.5.0.src/Makefile.rules:878: recipe for target 'all' failed
make: *** [all] Error 1
 * ERROR: sys-devel/llvm-3.5.0::gentoo failed (compile phase):
 *   emake failed

emerge --info '=sys-devel/llvm-3.5.0::gentoo'
Portage 2.2.14 (python 2.7.9-final-0, default/linux/arm/13.0/armv7a/desktop, gcc-4.7.3, glibc-2.19-r1, 3.14.14+ armv7l)
                         System Settings
System uname: Linux-3.14.14+-armv7l-with-gentoo-2.2
KiB Mem:     1026100 total,    496120 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of tree: Sat, 31 Jan 2015 05:30:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.7.3-r1, 4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo Cubox-i
CFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard"
FCFLAGS="-O2 -pipe -march=armv7-a"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe -march=armv7-a"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa arm armv5te armv6 armv6t2 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif glamor gles gpm gtk iconv ipv6 jpeg lcms libnotify mad mng modules mp3 mp4 mpeg ncurses neon nfs nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support readline sdl session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets xcb xml xv xvid zlib" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="ru" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2015-02-02 10:31:38 UTC
You very likely ran out of memory.

But please attach the entire build log to this bug report.
Comment 2 Vladimir Monchenko 2015-02-02 16:57:36 UTC
Created attachment 395384 [details]
Buld log
Comment 3 Vladimir Monchenko 2015-02-02 17:00:05 UTC
Max memory consumption during compilation:

hummingboard ~ # free
             total       used       free     shared    buffers     cached
Mem:       1026100     705420     320680        372      56400     269376
-/+ buffers/cache:     379644     646456
Swap:      2097148          0    2097148
hummingboard ~ # 

I tried to compile this package four times, the result is always the same.
Comment 4 Bernard Cafarelli gentoo-dev 2015-02-18 17:57:12 UTC
Thanks for the report!

This sounds like 

I am not sure if a fix was added to 3.5.1 but it could be worth the try
Comment 5 Marko Moberg 2015-04-17 05:16:19 UTC
This is truly a show-stopper for us unless a proper workaround or fix is provided. We need to get llvmpipe SW rastering to work on ARM device. Can somebody confirm if this is fixed in some release already?
Comment 6 Bernard Cafarelli gentoo-dev 2015-04-17 09:46:21 UTC
The code did not change upstream, as they were not sure other the 3 fixes listed would be enough (potentially lots of switch places missing the default:return line)

Have you tried with gcc 4.8? It is marked stable on arm, and we had a few bugreports on llvm builds with 4.7 (mostly on Intel Atom though)