Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 537572 - dev-vcs/monotone-1.0-r4 with dev-libs/botan-1.10.3 - configure: error: Must be able to compile and link programs against botan. // conftest.cpp:14:25: fatal error: botan/botan.h: No such file or directory
Summary: dev-vcs/monotone-1.0-r4 with dev-libs/botan-1.10.3 - configure: error: Must b...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: No maintainer - Look at if you want to take care of it
Depends on:
Reported: 2015-01-24 17:19 UTC by Toralf Förster
Modified: 2018-01-28 01:27 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

config log (config.log,18.23 KB, text/plain)
2015-01-24 19:49 UTC, Toralf Förster
emerge-info.txt (emerge-info.txt,8.21 KB, text/plain)
2016-10-25 10:10 UTC, Toralf Förster
config.log (config.log,19.58 KB, text/plain)
2016-10-25 10:10 UTC, Toralf Förster
dev-vcs:monotone-1.0-r4:20161025-095623.log (dev-vcs:monotone-1.0-r4:20161025-095623.log,5.05 KB, text/plain)
2016-10-25 10:11 UTC, Toralf Förster
emerge-history.txt (emerge-history.txt,300.49 KB, text/plain)
2016-10-25 10:11 UTC, Toralf Förster
environment (environment,96.63 KB, text/plain)
2016-10-25 10:11 UTC, Toralf Förster

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2015-01-24 17:19:14 UTC
checking for x86_64-pc-linux-gnu-pkg-config... /usr/bin/x86_64-pc-linux-gnu-pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for botan... no
botan.pc not found
checking for botan... not found; guessing
checking whether botan is usable... no
configure: *** botan_CFLAGS=
configure: *** botan_LIBS=-lbotan
configure: error: in `/var/tmp/portage/dev-vcs/monotone-1.0-r4/work/monotone-1.0':
configure: error: Must be able to compile and link programs against botan.
See `config.log' for more details

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-vcs/monotone-1.0-r4/work/monotone-1.0/config.log
 * ERROR: dev-vcs/monotone-1.0-r4::gentoo failed (configure phase):
 *   econf failed
 * Call stack:
 *, line   93:  Called src_configure
 *        environment, line 2540:  Called econf '--enable-nls' '--enable-ipv6'
 *, line  584:  Called die
 * The specific snippet of code:
 *   			die "econf failed"
 * If you need support, post the output of `emerge --info '=dev-vcs/monotone-1.0-r4::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-vcs/monotone-1.0-r4::gentoo'`.
 * The complete build log is located at '/var/log/portage/dev-vcs:monotone-1.0-r4:20150124-171455.log'.
 * For convenience, a symlink to the build log is located at '/var/tmp/portage/dev-vcs/monotone-1.0-r4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-vcs/monotone-1.0-r4/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-vcs/monotone-1.0-r4/work/monotone-1.0'
 * S: '/var/tmp/portage/dev-vcs/monotone-1.0-r4/work/monotone-1.0'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: sys-cluster/openmpi-1.4.3
 *  - /usr/lib64/
 *  - /usr/lib64/
 *  - /usr/lib64/
 *  - /usr/lib64/
 *  - /usr/lib64/
 *  - /usr/lib64/
 *      used by /usr/bin/ABYSS-P (sci-biology/abyss-1.3.3)
>>> package: sys-devel/llvm-3.5.0
 *  - /usr/lib64/
 *      used by /usr/bin/shivanimator (media-libs/opengtl-0.9.18)
 *      used by /usr/lib64/ (media-libs/opengtl-0.9.18)
 *      used by /usr/lib64/ (media-libs/opengtl-0.9.18)
 *      used by 3 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries

! ! !  This is a build bot chroot located at a hardened amd64 host ! ! !

Portage 2.2.14 (python 2.7.9-final-0, default/linux/amd64/13.0, gcc-4.8.3, glibc-2.19-r1, 3.18.3-hardened x86_64)
                         System Settings
System uname: Linux-3.18.3-hardened-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16166860 total,   1614644 free
KiB Swap:   16777212 total,  16755044 free
Timestamp of tree: Sat, 24 Jan 2015 15:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.8
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.9.6-r4, 1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.4
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/lib64/fax /usr/share/gnupg/qualified.txt /var/spool/fax/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe"
EMERGE_DEFAULT_OPTS="--nospinner --tree --quiet-build --deep --jobs 1"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl amd64 berkdb bindist bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mbox mmx modules multilib ncurses nls nptl openmp pam pax_kernel pcre readline session sse sse2 ssl tcpd unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

The build log is stored in /var/log/portage/_emerge_20150124-171504.log
The chroot image is amd64
Comment 1 Jeroen Roovers (RETIRED) gentoo-dev 2015-01-24 19:15:41 UTC
Please post your `emerge -vpq dev-libs/botan' output in a comment.
Comment 2 Jeroen Roovers (RETIRED) gentoo-dev 2015-01-24 19:16:08 UTC
And the config.log, please.
Comment 3 Toralf Förster gentoo-dev 2015-01-24 19:49:30 UTC
Created attachment 394794 [details]
config log

# emerge -vpq dev-libs/botan
[ebuild   R   ] dev-libs/botan-1.10.3  USE="bindist bzip2 ssl zlib -gmp -threads"
Comment 4 Juergen Rose 2016-03-27 20:53:52 UTC
I just see the same error.
Comment 5 Juergen Rose 2016-03-27 21:22:34 UTC
After reemerging botan (here botan-1.10.12) the issue disappeared for me.
Comment 6 Toralf Förster gentoo-dev 2016-10-25 10:10:52 UTC
Created attachment 451410 [details]

same at a tinderbox image
Comment 7 Toralf Förster gentoo-dev 2016-10-25 10:10:57 UTC
Created attachment 451412 [details]
Comment 8 Toralf Förster gentoo-dev 2016-10-25 10:11:00 UTC
Created attachment 451414 [details]
Comment 9 Toralf Förster gentoo-dev 2016-10-25 10:11:03 UTC
Created attachment 451416 [details]
Comment 10 Toralf Förster gentoo-dev 2016-10-25 10:11:06 UTC
Created attachment 451418 [details]
Comment 11 Toralf Förster gentoo-dev 2016-10-25 13:00:57 UTC
FWIW I continued this bug repoet b/c at the tinderbox image amd64-13.0-unstable_20161018-154022 I re-emerged dev-libs/botan-1.11.32 but monotone failed after that with the same error.
Comment 12 Larry the Git Cow gentoo-dev 2018-01-28 01:27:47 UTC
The bug has been closed via the following commit(s):

commit 48cb223907cae5bbe36d9cd35fb10865e15c414b
Author:     Mikle Kolyada <>
AuthorDate: 2018-01-28 01:23:07 +0000
Commit:     Mikle Kolyada <>
CommitDate: 2018-01-28 01:27:26 +0000

    dev-vcs/monotone: remove last rited package

 dev-vcs/monotone/Manifest                  |   2 -
 dev-vcs/monotone/files/hooks.lua           |   4 -
 dev-vcs/monotone/files/monotone-0.36.initd |  84 ---------------------
 dev-vcs/monotone/files/monotone.confd      |  25 ------
 dev-vcs/monotone/files/read-permissions    |   7 --
 dev-vcs/monotone/files/write-permissions   |   2 -
 dev-vcs/monotone/metadata.xml              |  15 ----
 dev-vcs/monotone/monotone-1.0-r4.ebuild    | 117 -----------------------------
 8 files changed, 256 deletions(-)