Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 536836 - >=dev-libs/boost-1.52.0: orphaned files in /usr/include/boost-1_51 not under package manager control
Summary: >=dev-libs/boost-1.52.0: orphaned files in /usr/include/boost-1_51 not under ...
Status: RESOLVED CANTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: C++ Team [disbanded]
URL:
Whiteboard: was: dev-cpp/lucene++-3.0.6 - .../wor...
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-17 12:52 UTC by Lukas Schneiderbauer
Modified: 2015-07-13 12:32 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,12.73 KB, text/plain)
2015-01-17 12:52 UTC, Lukas Schneiderbauer
Details
build.log (gcc 4.9.2) (build-gcc-4.9.2.log,12.69 KB, text/plain)
2015-01-24 22:06 UTC, Lukas Schneiderbauer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Schneiderbauer 2015-01-17 12:52:33 UTC
Created attachment 394156 [details]
build.log

$ emerge --info '=dev-cpp/lucene++-3.0.6::gentoo'
Portage 2.2.15 (python 2.7.9-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.4, glibc-2.20-r1, 3.17.7-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.17.7-gentoo-x86_64-Intel-R-_Core-TM-_i7_CPU_Q_720_@_1.60GHz-with-gentoo-2.2
KiB Mem:     8109244 total,   1717004 free
KiB Swap:    8388604 total,   8351600 free
Timestamp of tree: Sat, 17 Jan 2015 11:30:01 +0000
sh bash 4.3_p33
ld GNU ld (GNU Binutils) 2.24
app-shells/bash:          4.3_p33
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r4
dev-lang/python:          2.7.9-r1, 3.3.5-r1, 3.4.1
dev-util/cmake:           3.1.0
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.7
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.15
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.4
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.4
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.20-r1
Repositories: gentoo local_overlay gamerlay vooteys-overlay sunrise java kde steam-overlay
Installed sets: @ktp, @my_kde
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=y --autounmask-write"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks downgrade-backup ebuild-locks fixlafiles merge-sync news noinfo parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /var/lib/layman/gamerlay /var/lib/layman/vooteys /var/lib/layman/sunrise /var/lib/layman/java /var/lib/layman/kde /var/lib/layman/steam-overlay"
USE="X a52 aac acl acpi akonadi alsa amd64 apng avahi berkdb bidi bluetooth bluray branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cryptsetup cups cxx dbus declarative device-mapper dirac djvu dri dts dvd dvdr emboss encode exif fam firefox flac fortran g3dvl gdbm gif git glamor gnutls gpg gpm hdaps iconv icu id3tag inotify ipv6 jabber jpeg kde kdepim kipi latex lcms libass libnotify lyx lzma mad matroska mmx mng modules mp3 mp4 mpeg msn multilib musicbrainz ncurses networkmanager nls nptl ogg opengl openmp oscar pam pango pcre pdf phonon plasma png policykit ppds pulseaudio qt3support qt4 readline rss ruby samba schroedinger sdl semantic-desktop session sftp skype smp sse sse2 ssl ssse3 startup-notification steamruntime svg tcpd theora threads tiff truetype udev udisks unicode upnp upower usb v4l vcd vcdx vdpau video vim-with-x vorbis x264 xcb xcomposite xinerama xml xscreensaver xv xvid zeroconf zlib" ABI_X86="64 32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="braindump flow sheets stage words" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="lvm crypt" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en ja zh_CN zh_TW" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON
Comment 1 Lukas Schneiderbauer 2015-01-17 15:56:54 UTC
The issue was reported upstream, but the file was closed (and never reopened despite the fact that the "fix" allegedly was not a fix.)
Comment 2 Johannes Huber gentoo-dev 2015-01-24 21:14:26 UTC
Could you please test with gcc-4.9.2?
Comment 3 Lukas Schneiderbauer 2015-01-24 22:06:36 UTC
Created attachment 394818 [details]
build.log (gcc 4.9.2)

Yes. As far as I can tell there's no difference.
But to be sure I attach the build log anyhow.
Comment 4 Lukas Schneiderbauer 2015-01-24 22:31:25 UTC
Should it bother me, that the build log says:

[...]
-- Boost version: 1.52.0
[...]
Boost Include:  /usr/include/boost-1_51
[...]

and the actual installed version is 1.56.0-r1 ?
Comment 5 Johannes Huber gentoo-dev 2015-01-24 22:35:09 UTC
(In reply to Lukas Schneiderbauer from comment #4)
> Should it bother me, that the build log says:
> 
> [...]
> -- Boost version: 1.52.0
> [...]
> Boost Include:  /usr/include/boost-1_51
> [...]
> 
> and the actual installed version is 1.56.0-r1 ?

That could be the cause.
Comment 6 Lukas Schneiderbauer 2015-01-25 02:35:08 UTC
(In reply to Johannes Huber from comment #5)
> That could be the cause.

You were right. I found a orphaned directory "/usr/include/boost-1_51/" which didn't belong to any package. Coudn't think of any reason why it should be there. I removed it and its content. Now cmake finds the correct version and lucene++ builds fine.
It scares me a little that I appearently updated boost for nothing since november 2012.

Anyway, I'm sorry for wasting your time.
Comment 7 Johannes Huber gentoo-dev 2015-01-25 09:07:45 UTC
(In reply to Lukas Schneiderbauer from comment #6)
> You were right. I found a orphaned directory "/usr/include/boost-1_51/"
> which didn't belong to any package. Coudn't think of any reason why it
> should be there. I removed it and its content. Now cmake finds the correct
> version and lucene++ builds fine.
> It scares me a little that I appearently updated boost for nothing since
> november 2012.

@cpp is this a known issue?
Comment 8 Sergey Popov gentoo-dev 2015-01-25 10:11:40 UTC
(In reply to Johannes Huber from comment #7)
> (In reply to Lukas Schneiderbauer from comment #6)
> > You were right. I found a orphaned directory "/usr/include/boost-1_51/"
> > which didn't belong to any package. Coudn't think of any reason why it
> > should be there. I removed it and its content. Now cmake finds the correct
> > version and lucene++ builds fine.
> > It scares me a little that I appearently updated boost for nothing since
> > november 2012.
> 
> @cpp is this a known issue?

No, but i think that it is someway related to bug #473768, in which we drop symlinks to obsoleted slotted Boost versions.
Comment 9 Sergey Popov gentoo-dev 2015-07-13 12:32:29 UTC
Unfortunately i can not see any solution to this problem. We are alredy doing our best to clean up slotted boost files