Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 53627 - grep-2.5.1-r2 + libpcre-4.4 broken
Summary: grep-2.5.1-r2 + libpcre-4.4 broken
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: x86 Linux
: Highest major (vote)
Assignee: Mr. Bones. (RETIRED)
Depends on:
Reported: 2004-06-11 04:34 UTC by Master One
Modified: 2004-06-12 01:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Master One 2004-06-11 04:34:13 UTC
I performed an emerge -uD world today, which updated grep from 2.5.1-r1 to 2.5.1-r2 and installed libpcre-4.4 as a dependency (the perl useflag is new in grep-2.5.1-r2, it's not in the 2.5.1-r1 ebuild).

This led to a failure in calculating module dependencies on boot.

I just downgraded to grep-2.5.1-r1, unmerged libpcre, and everything seems to be fine again.
Comment 1 Master One 2004-06-11 06:04:07 UTC
Ok, I just reemerged latest grep-2.5.1-r2 with USE="-perl" and everything is still working fine, no error messages on boot, so it has to be a problem related to libpcre-4.4.
Comment 2 Tim Tailor 2004-06-11 13:24:25 UTC
Just hit the same problem and then also downgraded grep. After that it worked again. I think it is a dependency problem.. localmount -> -> grep and grep is dynamically linked to /usr/lib/  So in case your /usr is on a partition of its own, you are in trouble..  
Comment 3 Mr. Bones. (RETIRED) gentoo-dev 2004-06-11 16:31:09 UTC
yep.  comment #2 is right on.  I've modified the ebuild to link it statically
if you have USE="perl" which should fix this.
Comment 4 Mr. Bones. (RETIRED) gentoo-dev 2004-06-11 16:31:35 UTC
Resync and try it again please.
Comment 5 Mr. Bones. (RETIRED) gentoo-dev 2004-06-11 23:48:42 UTC
Actually, -r4 is better.
Comment 6 Master One 2004-06-12 01:19:22 UTC
I indeed have /usr on a separate partition, and 2.5.1-r4 fixed it, I just emerged it, unmerged libpcre and did a reboot, now everything is fine again.