Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 534726 - app-office/libreoffice binary packages fail to install ("PYTHON_CFLAGS is invalid for python-r1 suite")
Summary: app-office/libreoffice binary packages fail to install ("PYTHON_CFLAGS is inv...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Office Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-04 23:45 UTC by Andreas K. Hüttel
Modified: 2015-02-25 03:24 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas K. Hüttel gentoo-dev 2015-01-04 23:45:00 UTC
Because of an unintended interaction between python-single-r1.eclass and the app-office/libreoffice ebuilds, merging self-generated libreoffice binary packages fails with the error

 * ERROR: app-office/libreoffice-4.3.5.2::gentoo failed (setup phase):
 *   PYTHON_CFLAGS is invalid for python-r1 suite, please take a look @ https://wiki.gentoo.org/wiki/Project:Python/Python.eclass_conversion#PYTHON_CFLAGS

The problem is fixed [1], but any libreoffice binary packages generated with a portage tree from Fri Jan 2 00:15:15 2015 UTC to Sun Jan 4 22:18:12 2015 UTC will fail to reinstall.

Current recommendation is to delete the self-generated binary package and re-install libreoffice from sources (or use libreoffice-bin).

[I'm not versed enough in the binpackage format to write a "fixer" script. What would need to be done is to unset PYTHON_CFLAGS in the stored environment.]

This does NOT affect app-office/libreoffice-bin.

[1] http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/eclass/python-single-r1.eclass?r1=1.30&r2=1.31
Comment 1 Zac Medico gentoo-dev 2015-01-05 00:47:33 UTC
(In reply to Andreas K. Hüttel from comment #0)
> Current recommendation is to delete the self-generated binary package and
> re-install libreoffice from sources (or use libreoffice-bin).

If rebuilding the package bothers someone then they should probably be using libreoffice-bin.

> [I'm not versed enough in the binpackage format to write a "fixer" script.
> What would need to be done is to unset PYTHON_CFLAGS in the stored
> environment.]

It can be done using qtbz2 and qxpak from portage-utils:

1) Use 'qtbz2 --split' to split the package into separate tbz2 and xpak files
2) Use 'qxpak --extract' to extrack the xpak file
3) Use bunzip2 to decompress environment.bz2
4) Use sed to edit the environment file appropriately
5) Use bzip2 to compress the environment file
6) Use 'qxpak --create' to create a new xpak file
7) Use 'qtbz2 --join' to join the tbz2 file with the new xpak file
8) Put the new tbz2 file in the appropriate place in $PKGDIR, and run 'emaint --fix binhost' to fix the digests in $PKGDIR/Packages
Comment 2 Andreas K. Hüttel gentoo-dev 2015-01-05 09:29:00 UTC
Thanks a lot. Keeping the bug open for a while so people can find the information.
Comment 3 Andreas K. Hüttel gentoo-dev 2015-02-08 21:10:59 UTC
(In reply to Andreas K. Hüttel from comment #2)
> Thanks a lot. Keeping the bug open for a while so people can find the
> information.

A month is over, so closing.