Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 534432 - net-fs/samba-4*: multilib support
Summary: net-fs/samba-4*: multilib support
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: gx86-multilib samba-4 447022
  Show dependency tree
 
Reported: 2015-01-03 13:54 UTC by Michał Górny
Modified: 2016-09-02 19:11 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2015-01-03 13:54:23 UTC
A boilerplate bug to block unmasking of samba-4* until it gets proper multilib support. So far, it would be good to figure out if the client libs can live without 32-bit python.
Comment 1 Andrei Slavoiu 2015-03-10 20:25:05 UTC
Apparently this bug failed and samba 4 got unmasked even without proper multilib support. Now I get:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

net-fs/samba:0

  (net-fs/samba-4.1.17:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=net-fs/samba-4.0.0_alpha1 required by (net-fs/cifs-utils-6.4:0/0::gentoo, installed)
    ^^             ^^^^^^^^^^^^                                                                                                                  
    (and 1 more with the same problem)

  (net-fs/samba-3.6.25:0/0::gentoo, installed) pulled in by
    >=net-fs/samba-3.6.23-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-video/ffmpeg-2.6:0/54.56.56::gentoo, ebuild scheduled for merge)
Comment 2 Torsten Kurbad 2015-04-13 20:33:55 UTC
(In reply to Andrei Slavoiu from comment #1)
> Apparently this bug failed and samba 4 got unmasked even without proper
> multilib support. Now I get:
> 
> !!! Multiple package instances within a single package slot have been pulled
> !!! into the dependency graph, resulting in a slot conflict:
> 
> net-fs/samba:0
> 
>   (net-fs/samba-4.1.17:0/0::gentoo, ebuild scheduled for merge) pulled in by
>     >=net-fs/samba-4.0.0_alpha1 required by
> (net-fs/cifs-utils-6.4:0/0::gentoo, installed)
>     ^^             ^^^^^^^^^^^^                                             
> 
>     (and 1 more with the same problem)
> 
>   (net-fs/samba-3.6.25:0/0::gentoo, installed) pulled in by
>    
> >=net-fs/samba-3.6.23-r1[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,
> abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,
> abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by
> (media-video/ffmpeg-2.6:0/54.56.56::gentoo, ebuild scheduled for merge)

+1 here.
Comment 3 Dennis Schridde 2015-04-24 08:47:38 UTC
This also blocks bug #490872 via the abi_x86_32 requirement of e.g. ffmpeg.
Comment 4 Dennis Schridde 2015-06-04 15:46:20 UTC
(In reply to Dennis Schridde from comment #3)
> This also blocks bug #490872 via the abi_x86_32 requirement of e.g. ffmpeg.

Was any progress made recently? Can someone please add the bug-dependency I mentioned?
Comment 5 Dennis Schridde 2015-06-04 15:49:09 UTC
(In reply to Dennis Schridde from comment #4)
> Can someone please add the bug-dependency I mentioned?

Sorry, wrong bug. Again.
Comment 6 Stijn Tintel 2015-07-04 15:00:48 UTC
For those with the slot conflict, I too had this problem.

In make.conf I have:

ABI_X86="64 32"

To work around the conflict, I created /etc/portage/package.use/abi_x86_32:

gnome-base/gnome-vfs            -abi_x86_32
media-plugins/gst-plugins-libav -abi_x86_32
media-video/ffmpeg              -abi_x86_32
virtual/ffmpeg                  -abi_x86_32

Then you can do "emerge -1 media-plugins/gst-plugins-libav media-video/ffmpeg net-fs/samba virtual/ffmpeg".

(Add gnome-vfs only if you have it installed).
Comment 7 Víctor Ostorga (RETIRED) gentoo-dev 2016-01-19 20:04:50 UTC
Multilib is working on samba-4.2.7-r1 and samba-4.3.4
Comment 8 Víctor Ostorga (RETIRED) gentoo-dev 2016-02-07 20:20:13 UTC
Multilib is working on samba-4.2.8 and samba-4.3.4-r1
Comment 9 Jiří Moravec 2016-09-01 09:05:24 UTC
(In reply to Víctor Ostorga from comment #8)
> Multilib is working on samba-4.2.8 and samba-4.3.4-r1

I'm not so sure. Two version of samba compiled with 'abi_x86_32' (result of gnome-base/gnome-vfs abi_x86_32). Always in abi_x86_32.x86/ linking with 64bit libraries! Only solution was remove 'abi_x86_32' so no multilib!

Samba-4.2.14:

[1899/2273] Linking default/source3/timelimit
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libpthread.so while searching for pthread
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libkrb5.so while searching for krb5
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/librt.so while searching for rt
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libdl.so while searching for dl
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libroken.so while searching for roken
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libcrypt.so while searching for crypt
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libhcrypto.so while searching for hcrypto
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libbsd.so while searching for bsd
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libnsl.so while searching for nsl
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libheimntlm.so while searching for heimntlm
/usr/bin/x86_64-pc-linux-gnu-ld.gold: error: /lib64/libattr.so.1: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libc.so while searching for c
[1900/2273] Linking default/source3/lib/pthreadpool/pthreadpooltest
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libpthread.so while searching for pthread
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libkrb5.so while searching for krb5
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/librt.so while searching for rt
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libdl.so while searching for dl
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libroken.so while searching for roken
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libcrypt.so while searching for crypt
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libasn1.so while searching for asn1
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libhcrypto.so while searching for hcrypto
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libbsd.so while searching for bsd
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libnsl.so while searching for nsl
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libheimntlm.so while searching for heimntlm
/usr/bin/x86_64-pc-linux-gnu-ld.gold: error: /lib64/libattr.so.1: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libc.so while searching for c
x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1 (use -v to see invocation)
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libpthread.so while searching for pthread
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libkrb5.so while searching for krb5
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/librt.so while searching for rt
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libdl.so while searching for dl
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libroken.so while searching for roken
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libcrypt.so while searching for crypt
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libhcrypto.so while searching for hcrypto
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libbsd.so while searching for bsd
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libnsl.so while searching for nsl
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libheimntlm.so while searching for heimntlm
/usr/bin/x86_64-pc-linux-gnu-ld.gold: error: /lib64/libattr.so.1: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible /usr/lib64/libc.so while searching for c
x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1 (use -v to see invocation)
x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1 (use -v to see invocation)
Waf: Leaving directory `/var/tmp/portage/net-fs/samba-4.2.14/work/samba-4.2.14-abi_x86_32.x86/bin'
Build failed:
 -> task failed (err #1): 
        {task: cc_link print_version_2.o,version_2.o,kinit_5.o -> samba4kinit}
 -> task failed (err #1): 
        {task: cc_link print_version_2.o,version_2.o,kgetcred_7.o -> samba4kgetcred}
 -> task failed (err #1): 
        {task: cc_link print_version_2.o,version_2.o,kpasswd_9.o -> samba4kpasswd}
Makefile:8: recipe for target 'all' failed
make: *** [all] Error 1

Samba-4.3.11:

[1951/2266] Linking default/nsswitch/wbinfo
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libpthread.so while searching for pthread
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libgssapi_krb5.so while searching for gssapi_krb5
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libkrb5.so while searching for krb5
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libk5crypto.so while searching for k5crypto
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/librt.so while searching for rt
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libdl.so while searching for dl
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libnsl.so while searching for nsl
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libcrypt.so while searching for crypt
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libpthread.so while searching for pthread
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libtalloc.so while searching for talloc
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libbsd.so while searching for bsd
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libgssapi_krb5.so while searching for gssapi_krb5
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libkrb5.so while searching for krb5
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libk5crypto.so while searching for k5crypto
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/librt.so while searching for rt
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libldb.so while searching for ldb
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libtalloc.so while searching for talloc
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libdl.so while searching for dl
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libnsl.so while searching for nsl
/usr/bin/x86_64-pc-linux-gnu-ld: warning: /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libtdb.so while searching for tdbskipping incompatible /usr/lib64/libtdb.so while searching for tdb

/usr/bin/x86_64-pc-linux-gnu-ld: warning: /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libcrypt.so while searching for cryptskipping incompatible /usr/lib64/libpopt.so while searching for popt

/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libbsd.so while searching for bsd
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libtevent.so while searching for tevent
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libtevent.so while searching for tevent
/usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libcom_err.so.2: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libz.so.1: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libattr.so.1: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libc.so while searching for c
/usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libcom_err.so.2: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libz.so.1: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libattr.so.1: incompatible target
/usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible /usr/lib64/libc.so while searching for c
x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1 (use -v to see invocation)
x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1 (use -v to see invocation)
Waf: Leaving directory `/var/tmp/portage/net-fs/samba-4.3.11/work/samba-4.3.11-abi_x86_32.x86/bin'
Build failed:
 -> task failed (err #1): 
        {task: cc_link wbinfo_18.o,popt_common_5.o,afs_settoken_2.o -> wbinfo}
 -> task failed (err #1): 
        {task: cc_link util_6.o,util_trusts_6.o,util_groups_6.o,util_samr_6.o,dsdb_dn_6.o,dsdb_access_6.o,util_ldb_64.o -> libsamdb-common-samba4.so}
Makefile:8: recipe for target 'all' failed
make: *** [all] Error 1
Comment 10 Ian Stakenvicius gentoo-dev 2016-09-01 16:05:15 UTC
(In reply to Jiří Moravec from comment #9)
> (In reply to Víctor Ostorga from comment #8)
> > Multilib is working on samba-4.2.8 and samba-4.3.4-r1
> 
> I'm not so sure. Two version of samba compiled with 'abi_x86_32' (result of
> gnome-base/gnome-vfs abi_x86_32). Always in abi_x86_32.x86/ linking with
> 64bit libraries! Only solution was remove 'abi_x86_32' so no multilib!
> 
> Samba-4.2.14:
> 
> [1899/2273] Linking default/source3/timelimit
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libpthread.so while searching for pthread
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libkrb5.so while searching for krb5
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/librt.so while searching for rt
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libdl.so while searching for dl
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libroken.so while searching for roken
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libcrypt.so while searching for crypt
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libhcrypto.so while searching for hcrypto
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libbsd.so while searching for bsd
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libnsl.so while searching for nsl
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libheimntlm.so while searching for heimntlm
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: error: /lib64/libattr.so.1:
> incompatible target
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libc.so while searching for c
> [1900/2273] Linking default/source3/lib/pthreadpool/pthreadpooltest
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libpthread.so while searching for pthread
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libkrb5.so while searching for krb5
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/librt.so while searching for rt
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libdl.so while searching for dl
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libroken.so while searching for roken
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libcrypt.so while searching for crypt
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libasn1.so while searching for asn1
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libhcrypto.so while searching for hcrypto
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libbsd.so while searching for bsd
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libnsl.so while searching for nsl
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libheimntlm.so while searching for heimntlm
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: error: /lib64/libattr.so.1:
> incompatible target
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libc.so while searching for c
> x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1
> (use -v to see invocation)
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libpthread.so while searching for pthread
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libkrb5.so while searching for krb5
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/librt.so while searching for rt
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libdl.so while searching for dl
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libroken.so while searching for roken
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libcrypt.so while searching for crypt
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libhcrypto.so while searching for hcrypto
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libbsd.so while searching for bsd
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libnsl.so while searching for nsl
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libheimntlm.so while searching for heimntlm
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: error: /lib64/libattr.so.1:
> incompatible target
> /usr/bin/x86_64-pc-linux-gnu-ld.gold: warning: skipping incompatible
> /usr/lib64/libc.so while searching for c
> x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1
> (use -v to see invocation)
> x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1
> (use -v to see invocation)
> Waf: Leaving directory
> `/var/tmp/portage/net-fs/samba-4.2.14/work/samba-4.2.14-abi_x86_32.x86/bin'
> Build failed:
>  -> task failed (err #1): 
>         {task: cc_link print_version_2.o,version_2.o,kinit_5.o ->
> samba4kinit}
>  -> task failed (err #1): 
>         {task: cc_link print_version_2.o,version_2.o,kgetcred_7.o ->
> samba4kgetcred}
>  -> task failed (err #1): 
>         {task: cc_link print_version_2.o,version_2.o,kpasswd_9.o ->
> samba4kpasswd}
> Makefile:8: recipe for target 'all' failed
> make: *** [all] Error 1
> 
> Samba-4.3.11:
> 
> [1951/2266] Linking default/nsswitch/wbinfo
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libpthread.so while searching for pthread
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libgssapi_krb5.so while searching for gssapi_krb5
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libkrb5.so while searching for krb5
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libk5crypto.so while searching for k5crypto
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/librt.so while searching for rt
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libdl.so while searching for dl
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libnsl.so while searching for nsl
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libcrypt.so while searching for crypt
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libpthread.so while searching for pthread
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libtalloc.so while searching for talloc
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libbsd.so while searching for bsd
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libgssapi_krb5.so while searching for gssapi_krb5
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libkrb5.so while searching for krb5
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libk5crypto.so while searching for k5crypto
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/librt.so while searching for rt
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libldb.so while searching for ldb
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libtalloc.so while searching for talloc
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libdl.so while searching for dl
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libnsl.so while searching for nsl
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: /usr/bin/x86_64-pc-linux-gnu-ld:
> warning: skipping incompatible /usr/lib64/libtdb.so while searching for
> tdbskipping incompatible /usr/lib64/libtdb.so while searching for tdb
> 
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: /usr/bin/x86_64-pc-linux-gnu-ld:
> warning: skipping incompatible /usr/lib64/libcrypt.so while searching for
> cryptskipping incompatible /usr/lib64/libpopt.so while searching for popt
> 
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libbsd.so while searching for bsd
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libtevent.so while searching for tevent
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libtevent.so while searching for tevent
> /usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libcom_err.so.2: incompatible
> target
> /usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libz.so.1: incompatible target
> /usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libattr.so.1: incompatible
> target
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libc.so while searching for c
> /usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libcom_err.so.2: incompatible
> target
> /usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libz.so.1: incompatible target
> /usr/bin/x86_64-pc-linux-gnu-ld: error: /lib64/libattr.so.1: incompatible
> target
> /usr/bin/x86_64-pc-linux-gnu-ld: warning: skipping incompatible
> /usr/lib64/libc.so while searching for c
> x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1
> (use -v to see invocation)
> x86_64-pc-linux-gnu-clang-3.8: error: linker command failed with exit code 1
> (use -v to see invocation)
> Waf: Leaving directory
> `/var/tmp/portage/net-fs/samba-4.3.11/work/samba-4.3.11-abi_x86_32.x86/bin'
> Build failed:
>  -> task failed (err #1): 
>         {task: cc_link wbinfo_18.o,popt_common_5.o,afs_settoken_2.o ->
> wbinfo}
>  -> task failed (err #1): 
>         {task: cc_link
> util_6.o,util_trusts_6.o,util_groups_6.o,util_samr_6.o,dsdb_dn_6.o,
> dsdb_access_6.o,util_ldb_64.o -> libsamdb-common-samba4.so}
> Makefile:8: recipe for target 'all' failed
> make: *** [all] Error 1


So most of that is normal. What isn't normal is that you're missing the libs in /usr/lib32/ that it's looking for, and as such it is -only- finding the incompatible 64bit versions.  And the only reason or way that this would occur is if you're using a rather messed up portage configuration for how abi_x86_32 packages are installed.

I know many of you do this, but the ABI_X86 use-expand is *not* actually meant to be set globally.  You should allow --autounmask-write to handle setting abi_x86_32 on each of the packages that need it, instead.  Yes it amounts to a fairly large package.use file, but it also keeps you from installing a slew of 32bit packages that don't need to be there.
Comment 11 Jiří Moravec 2016-09-02 19:11:51 UTC
(In reply to Ian Stakenvicius from comment #10)
> (In reply to Jiří Moravec from comment #9)
> > (In reply to Víctor Ostorga from comment #8)
> > > Multilib is working on samba-4.2.8 and samba-4.3.4-r1

You're probably right, but I can't find any specific reason for such behaviour.
All three libs, for which linker thrown error - libcom_err.so.2, libz.so.1 and libattr.so.1 are present in /usr/lib32 directory and 'ldconfig -XNv' reported them, so there is no reason why linker can't find them. All packages with abi_x86_32 are exclusively listed in one file '/etc/portage/package.use/multilib', so I have no idea how it can be messed in the first place.