Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 534028 - <=dev-libs/libclc-0.0.1_pre20140101 should depend on <sys-devel/llvm-3.5.0 - ./utils/prepare-builtins.cpp:1:10: fatal error: 'llvm/ADT/OwningPtr.h' file not found
Summary: <=dev-libs/libclc-0.0.1_pre20140101 should depend on <sys-devel/llvm-3.5.0 - ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
: 536966 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-30 18:01 UTC by Michael Jones
Modified: 2015-02-08 20:14 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log.gz (build.log.gz,36.84 KB, application/x-gzip)
2014-12-30 18:16 UTC, Michael Jones
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Jones 2014-12-30 18:01:27 UTC
Compile fails with

./utils/prepare-builtins.cpp:1:10: fatal error: 'llvm/ADT/OwningPtr.h' file not found
#include "llvm/ADT/OwningPtr.h"

This seems to be recognized as a bug by debian as well: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=764835


keywording and emerging =dev-libs/libclc-0.0.1_pre20141027 seems to work fine with =sys-devel/llvm-3.5.0



Portage 2.2.14 (python 3.3.5-final-0, hardened/linux/amd64/no-multilib, gcc-4.8.3, glibc-2.19-r1, 3.15.10-hardened-r1 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.15.10-hardened-r1-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9550_@_2.83GHz-with-gentoo-2.2
KiB Mem:     8179968 total,   1390068 free
KiB Swap:   20495396 total,  20495036 free
Timestamp of tree: Mon, 29 Dec 2014 20:30:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
distcc 3.1 x86_64-pc-linux-gnu [disabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.18.2-r2
dev-lang/python:          2.7.9-r1, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.12.6, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo Aerosta-LLC-Overlay atlassian-ebuilds
Installed sets: @android, @archive, @creative, @desktop-applications, @development-cli, @development-gui, @games, @java, @lxde, @multimedia, @network-manager, @pc-base-system, @portage, @qt, @vcs, @virt-client
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=x86-64 -mtune=generic -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS=" --jobs --keep-going --newuse --deep --backtrack=3000 --complete-graph --with-bdeps=y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg clean-logs compress-build-logs compressdebug config-protect-if-modified distlocks ebuild-locks fixlafiles installsources merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms split-elog split-log splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirrors.rit.edu/gentoo/ http://mirror.datapipe.net/gentoo http://mirror.usu.edu/mirrors/gentoo/ http://gentoo.mirrors.hoobly.com/ http://gentoo.netnitco.net"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_COMPRESS="xz"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/aerosta /var/lib/layman/atlassian"
USE="X a52 aac acl acpi alsa amd64 apng autoipd avahi berkdb branding bzip2 cairo cdda cdr clang cli cracklib crypt cxx dbus dconf dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac gd gdbm gif gnome-keyring gpm gstreamer gtk gudev hardened iconv icu ipv6 jpeg justify lcms libnotify libsecret lm_sensors mad mdnsresponder-compat minizip mmx mng modules mp3 mp4 mpeg ncurses networkmanager nls nptl ogg opengl openmp pam pango pax_kernel pcre pdf png policykit postgres ppds pulseaudio python qt4 readline samba sdl session sound spell sqlite sse sse2 ssl startup-notification svg systemd tcpd theora threads tiff truetype udev udisks unicode upower urandom usb vorbis x264 xattr xcb xinerama xml xtpax xv xvid zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="coreboot efi-32 efi-64 emu qemu pc" INPUT_DEVICES="evdev synaptics mouse keyboard wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="arm aarch64 i386 x86_64" QEMU_USER_TARGETS="arm aarch64 i386 x86_64" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="intel i965 nouveau vesa modesetting fbdev qxl radeon r600 radeonsi" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


Reproducible: Always
Comment 1 Jeroen Roovers gentoo-dev 2014-12-30 18:05:00 UTC
Please attach the entire build log to this bug report.
Comment 2 Jeroen Roovers gentoo-dev 2014-12-30 18:06:52 UTC

*** This bug has been marked as a duplicate of bug 523232 ***
Comment 3 Michael Jones 2014-12-30 18:16:21 UTC
Created attachment 392708 [details]
build.log.gz
Comment 4 Michael Jones 2014-12-30 18:18:42 UTC
Hrmm....



Why didn't the duplicate bug show up when I searched for libclc ? I wouldn't have posted this bug if it was in search...
Comment 5 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-12-31 10:09:08 UTC
That is because resolved bugs are not included in search results by default.

That being said, libclc-0.0.1_pre20131010 probably needs to depend on old llvm version.
Comment 6 Jeroen Roovers gentoo-dev 2015-01-18 13:51:37 UTC
*** Bug 536966 has been marked as a duplicate of this bug. ***
Comment 7 Chí-Thanh Christopher Nguyễn gentoo-dev 2015-02-08 20:14:28 UTC
+  08 Feb 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+  libclc-0.0.1_pre20131010.ebuild, libclc-0.0.1_pre20140101.ebuild:
+  Make old versions depend on old llvm/clang.