Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 532082 - x11-drivers/nvidia-drivers with kernel 3.18.0 - WARNING: CPU: 1 PID: 2396 at drivers/gpu/drm/drm_ioctl.c:143 drm_setversion+0xd7/0x16b() // No drm_driver.set_busid() implementation provided by nvidia_frontend_exit_module [nvidia].
Summary: x11-drivers/nvidia-drivers with kernel 3.18.0 - WARNING: CPU: 1 PID: 2396 at ...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Jeroen Roovers
URL: https://devtalk.nvidia.com/default/to...
Whiteboard:
Keywords:
: 536278 541184 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-09 21:15 UTC by Pavel Volkov
Modified: 2015-03-06 11:47 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nvidia drm patch (nvidia-346.22_v3.patch,1.76 KB, patch)
2014-12-30 10:51 UTC, Mario Bachmann
Details | Diff
nvidia drm fix for 346.35 (nvidia-drivers-346.35-linux-3.18-drm-fix.patch,598 bytes, patch)
2015-01-18 17:55 UTC, Mark R. Pariente
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Volkov 2014-12-09 21:15:28 UTC
This is dmesg output during boot (also happens after reloading nvidia module).
Still, video seems to work (I see KDM login screen).
I tried downgrading to kernel 3.17.4 and it does not happen.

[    3.495633] ------------[ cut here ]------------
[    3.495641] WARNING: CPU: 0 PID: 271 at drivers/gpu/drm/drm_ioctl.c:143 drm_setversion+0xd7/0x16b [drm]()
[    3.495679] No drm_driver.set_busid() implementation provided by nvidia_frontend_exit_module [nvidia]. Use drm_dev_set_unique() to set the unique name explicitly.
[    3.495680] Modules linked in:
[    3.495680]  nft_limit nft_meta nft_hash nft_rbtree nf_tables_inet nf_tables_ipv6 nf_tables_ipv4 nf_tables btusb bluetooth nct6775 hwmon_vid hid_logitech_dj arc4 snd_hda_codec_generic snd_cmipci snd_mpu401_uart snd_opl3_lib snd_hwdep snd_rawmidi ath9k nvidia(PO) led_class ath9k_common ath9k_hw coretemp hwmon x86_pkg_temp_thermal ath mac80211 snd_hda_intel cfg80211 snd_hda_controller snd_hda_codec drm rfkill snd_pcm snd_seq_device wmi snd_timer lpc_ich snd i2c_i801 video soundcore mfd_core sha512_generic sha256_generic fuse
[    3.495699] CPU: 0 PID: 271 Comm: X Tainted: P        W  O   3.18.0-gentoomelf #1
[    3.495699] Hardware name: System manufacturer System Product Name/P8H67, BIOS 3604 06/25/2012
[    3.495700]  0000000000000000 0000000000000009 ffffffff814df24a ffff88000ae0fd68
[    3.495702]  ffffffff8106df43 ffff88040c331918 ffffffffa00aec5a 0000000000008002
[    3.495704]  ffff88040b4dc000 ffff88000ae0fe28 ffff8804095b1580 ffffffffa00c5cd0
[    3.495705] Call Trace:
[    3.495710]  [<ffffffff814df24a>] ? dump_stack+0x49/0x6a
[    3.495713]  [<ffffffff8106df43>] ? warn_slowpath_common+0x7d/0x95
[    3.495717]  [<ffffffffa00aec5a>] ? drm_setversion+0xd7/0x16b [drm]
[    3.495719]  [<ffffffff8106dfa5>] ? warn_slowpath_fmt+0x4a/0x4f
[    3.495723]  [<ffffffffa00aec5a>] ? drm_setversion+0xd7/0x16b [drm]
[    3.495727]  [<ffffffffa00aea7f>] ? drm_ioctl+0x36c/0x3b8 [drm]
[    3.495730]  [<ffffffffa00aeb83>] ? drm_version+0x8d/0x8d [drm]
[    3.495732]  [<ffffffff8113c1ab>] ? do_filp_open+0x30/0x74
[    3.495734]  [<ffffffff8113df26>] ? do_vfs_ioctl+0x35d/0x42b
[    3.495736]  [<ffffffff8114619c>] ? __fd_install+0x21/0x53
[    3.495738]  [<ffffffff8112eba0>] ? do_sys_open+0x1b8/0x1ca
[    3.495740]  [<ffffffff8113e02c>] ? SyS_ioctl+0x38/0x5d
[    3.495742]  [<ffffffff814e3ad2>] ? system_call_fastpath+0x12/0x17
[    3.495743] ---[ end trace 3597c14d7504c45b ]---
[    3.495744] ------------[ cut here ]------------
[    3.495748] WARNING: CPU: 0 PID: 271 at drivers/gpu/drm/drm_ioctl.c:143 drm_setversion+0xd7/0x16b [drm]()
[    3.495778] No drm_driver.set_busid() implementation provided by nvidia_frontend_exit_module [nvidia]. Use drm_dev_set_unique() to set the unique name explicitly.
[    3.495779] Modules linked in:
[    3.495779]  nft_limit nft_meta nft_hash nft_rbtree nf_tables_inet nf_tables_ipv6 nf_tables_ipv4 nf_tables btusb bluetooth nct6775 hwmon_vid hid_logitech_dj arc4 snd_hda_codec_generic snd_cmipci snd_mpu401_uart snd_opl3_lib snd_hwdep snd_rawmidi ath9k nvidia(PO) led_class ath9k_common ath9k_hw coretemp hwmon x86_pkg_temp_thermal ath mac80211 snd_hda_intel cfg80211 snd_hda_controller snd_hda_codec drm rfkill snd_pcm snd_seq_device wmi snd_timer lpc_ich snd i2c_i801 video soundcore mfd_core sha512_generic sha256_generic fuse
[    3.495795] CPU: 0 PID: 271 Comm: X Tainted: P        W  O   3.18.0-gentoomelf #1
[    3.495796] Hardware name: System manufacturer System Product Name/P8H67, BIOS 3604 06/25/2012
[    3.495796]  0000000000000000 0000000000000009 ffffffff814df24a ffff88000ae0fd68
[    3.495798]  ffffffff8106df43 ffff88040c331918 ffffffffa00aec5a 0000000000008002
[    3.495799]  ffff88040b4dc000 ffff88000ae0fe28 ffff8804095b1580 ffffffffa00c5cd0
[    3.495801] Call Trace:
[    3.495803]  [<ffffffff814df24a>] ? dump_stack+0x49/0x6a
[    3.495805]  [<ffffffff8106df43>] ? warn_slowpath_common+0x7d/0x95
[    3.495808]  [<ffffffffa00aec5a>] ? drm_setversion+0xd7/0x16b [drm]
[    3.495810]  [<ffffffff8106dfa5>] ? warn_slowpath_fmt+0x4a/0x4f
[    3.495813]  [<ffffffffa00aec5a>] ? drm_setversion+0xd7/0x16b [drm]
[    3.495817]  [<ffffffffa00aea7f>] ? drm_ioctl+0x36c/0x3b8 [drm]
[    3.495820]  [<ffffffffa00aeb83>] ? drm_version+0x8d/0x8d [drm]
[    3.495821]  [<ffffffff8113c1ab>] ? do_filp_open+0x30/0x74
[    3.495823]  [<ffffffff8113df26>] ? do_vfs_ioctl+0x35d/0x42b
[    3.495824]  [<ffffffff8114619c>] ? __fd_install+0x21/0x53
[    3.495826]  [<ffffffff8112eba0>] ? do_sys_open+0x1b8/0x1ca
[    3.495827]  [<ffffffff8113e02c>] ? SyS_ioctl+0x38/0x5d
[    3.495829]  [<ffffffff814e3ad2>] ? system_call_fastpath+0x12/0x17
[    3.495829] ---[ end trace 3597c14d7504c45c ]---
[    3.750493] ------------[ cut here ]------------
[    3.750505] WARNING: CPU: 3 PID: 271 at drivers/gpu/drm/drm_ioctl.c:143 drm_setversion+0xd7/0x16b [drm]()
[    3.750552] No drm_driver.set_busid() implementation provided by nvidia_frontend_exit_module [nvidia]. Use drm_dev_set_unique() to set the unique name explicitly.
[    3.750553] Modules linked in:
[    3.750553]  nft_limit nft_meta nft_hash nft_rbtree nf_tables_inet nf_tables_ipv6 nf_tables_ipv4 nf_tables btusb bluetooth nct6775 hwmon_vid hid_logitech_dj arc4 snd_hda_codec_generic snd_cmipci snd_mpu401_uart snd_opl3_lib snd_hwdep snd_rawmidi ath9k nvidia(PO) led_class ath9k_common ath9k_hw coretemp hwmon x86_pkg_temp_thermal ath mac80211 snd_hda_intel cfg80211 snd_hda_controller snd_hda_codec drm rfkill snd_pcm snd_seq_device wmi snd_timer lpc_ich snd i2c_i801 video soundcore mfd_core sha512_generic sha256_generic fuse
[    3.750573] CPU: 3 PID: 271 Comm: X Tainted: P        W  O   3.18.0-gentoomelf #1
[    3.750574] Hardware name: System manufacturer System Product Name/P8H67, BIOS 3604 06/25/2012
[    3.750575]  0000000000000000 0000000000000009 ffffffff814df24a ffff88000ae0fd68
[    3.750577]  ffffffff8106df43 ffff88040c331918 ffffffffa00aec5a 0000000000008002
[    3.750578]  ffff88040b4dc000 ffff88000ae0fe28 ffff88000aeb2640 ffffffffa00c5cd0
[    3.750580] Call Trace:
[    3.750585]  [<ffffffff814df24a>] ? dump_stack+0x49/0x6a
[    3.750589]  [<ffffffff8106df43>] ? warn_slowpath_common+0x7d/0x95
[    3.750593]  [<ffffffffa00aec5a>] ? drm_setversion+0xd7/0x16b [drm]
[    3.750595]  [<ffffffff8106dfa5>] ? warn_slowpath_fmt+0x4a/0x4f
[    3.750599]  [<ffffffffa00aec5a>] ? drm_setversion+0xd7/0x16b [drm]
[    3.750602]  [<ffffffffa00aea7f>] ? drm_ioctl+0x36c/0x3b8 [drm]
[    3.750605]  [<ffffffffa00aeb83>] ? drm_version+0x8d/0x8d [drm]
[    3.750608]  [<ffffffff8113c1ab>] ? do_filp_open+0x30/0x74
[    3.750610]  [<ffffffff8113df26>] ? do_vfs_ioctl+0x35d/0x42b
[    3.750612]  [<ffffffff8114619c>] ? __fd_install+0x21/0x53
[    3.750614]  [<ffffffff8112eba0>] ? do_sys_open+0x1b8/0x1ca
[    3.750615]  [<ffffffff8113e02c>] ? SyS_ioctl+0x38/0x5d
[    3.750618]  [<ffffffff814e3ad2>] ? system_call_fastpath+0x12/0x17
[    3.750619] ---[ end trace 3597c14d7504c45d ]---

Reproducible: Always




Portage 2.2.15 (python 3.3.5-final-0, default/linux/amd64/13.0/desktop/kde/systemd, gcc-4.8.3, glibc-2.20, 3.17.4-gentoomelf x86_64)
=================================================================
System uname: Linux-3.17.4-gentoomelf-x86_64-Intel-R-_Core-TM-_i5-2400_CPU_@_3.10GHz-with-gentoo-2.2
KiB Mem:    16412532 total,  14325820 free
KiB Swap:   17825788 total,  17825788 free
Timestamp of tree: Tue, 09 Dec 2014 19:45:01 +0000
sh bash 4.3_p30-r1
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30-r1
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.1-r3
dev-lang/python:          2.7.8, 3.3.5-r1, 3.4.2
dev-util/cmake:           3.0.2
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.3-r2
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc:           2.20
Repositories: gentoo custom
Installed sets: @fonts, @mkde, @python-extra, @vim
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="@FREE MPEG-4 myspell-ru_RU-ALexanderLebedev freedist vim.org unRAR BitstreamCyberbit MSttfEULA grass-ipafonts free-noncomm CC-BY-NC-ND-3.0 NVIDIA-r2 google-chrome Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native -mtune=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/easy-rsa /usr/share/gnupg/qualified.txt /usr/share/ibus/component/simple.xml"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -march=native -mtune=native"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.yandex.ru/gentoo-distfiles/ http://trumpetti.atm.tut.fi/gentoo/"
INSTALL_MASK="/etc/init.d/"
LANG="ru_RU.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 anthy bluetooth branding bzip2 cairo cdda cdr cjk cli cracklib crypt cryptsetup cups cxx dbus declarative djvu dri dts dvd dvdr embedded emboss encode exif fam ffmpeg firefox flac fortran gdbm gif git glamor gpm gstreamer gtk iconv icu idn ipv6 jpeg kde kipi lame lcms libnotify lm_sensors mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp openvg pam pango pcre pdf phonon plasma png policykit ppds pulseaudio python qt3support qt4 raw readline samba scanner sdl session spell sse sse2 ssl startup-notification svg systemd tcpd tiff truetype udev udisks unicode upower usb vdpau vorbis wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_GB ru ja" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3 python3_4" QEMU_SOFTMMU_TARGETS="x86_64 i386" RUBY_TARGETS="ruby21" SANE_BACKENDS="genesys" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.3"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC
Comment 1 Jeroen Roovers gentoo-dev 2014-12-10 13:16:40 UTC
Everything seems to just work fine despite this error message. Maybe I should downgrade the supported version again just in case?
Comment 2 Pavel Volkov 2014-12-10 20:02:56 UTC
I think it can be reported to upstream if they claim 3.18 is supported.
Comment 3 Jeroen Roovers gentoo-dev 2014-12-11 00:02:33 UTC
(In reply to Pavel Volkov from comment #2)
> I think it can be reported to upstream if they claim 3.18 is supported.

Well, that's always tricky. [1] claims "Improved compatibility with recent Linux kernels" and came out on 8 December, a day after kernel 3.18 was released. So far the forums[2] do not mention any 3.18 problems, so maybe you should report it there.


[1] http://www.nvidia.com/download/driverResults.aspx/80652/en-us
[2] https://devtalk.nvidia.com/default/board/98/
Comment 4 Pavel Volkov 2014-12-22 13:11:08 UTC
I'm found a better solution: installed a card with AMD chip (switched mostly because of the noise of my old card but the driver openness played its part as well).
I'm leaving this bug open since you also see those messages.
Comment 5 Jeroen Roovers gentoo-dev 2014-12-27 11:08:03 UTC
https://bugs.archlinux.org/task/43147
Comment 6 Mario Bachmann 2014-12-30 10:51:39 UTC
Created attachment 392698 [details, diff]
nvidia drm patch
Comment 7 Mario Bachmann 2014-12-30 10:54:31 UTC
I solved the problem with a patch from:
https://devtalk.nvidia.com/default/topic/796645/346-22-343-36-regression-no-dp1-2-daisy-chaining-on-gtx770-worked-with-343-22-/

I patched the files manually. 
Perhaps someone can make a patch for the ebuild.
Comment 8 Jeroen Roovers gentoo-dev 2014-12-30 17:03:36 UTC
(In reply to Mario Bachmann from comment #7)
> I solved the problem with a patch from:
> https://devtalk.nvidia.com/default/topic/796645/346-22-343-36-regression-no-
> dp1-2-daisy-chaining-on-gtx770-worked-with-343-22-/

Amazing that you solved it after I pointed it out in comment #5.

> I patched the files manually. 

You could have used epatch_user.

> Perhaps someone can make a patch for the ebuild.

Don't bother. It isn't going into the tree as per the usual policy.
Comment 9 tman 2015-01-11 17:22:53 UTC
*** Bug 536278 has been marked as a duplicate of this bug. ***
Comment 10 Mark R. Pariente 2015-01-18 17:55:50 UTC
Created attachment 394292 [details, diff]
nvidia drm fix for 346.35

It looks like for nvidia-drivers 346.35 the inode fixes from the previous patch aren't needed anymore (upstream wrapped access with NV_FILE_INODE which does the proper thing) - only fix needed is the drm part in nv-drm.c.
Comment 11 Harris Landgarten 2015-01-18 19:03:16 UTC
interesting that I have no message like that my logs. Just the usual taints kernel. Wonder if it is board specific.
Comment 12 tman 2015-02-02 00:50:02 UTC
kernel 3.18.5-gentoo 


also have this problem :( with x11-drivers/nvidia-drivers-346.35
Comment 13 Jeroen Roovers gentoo-dev 2015-02-02 11:00:57 UTC
(In reply to tman from comment #12)
> kernel 3.18.5-gentoo 
> 
> 
> also have this problem :( with x11-drivers/nvidia-drivers-346.35

No me-toos required.
Comment 14 张通 2015-02-08 23:52:36 UTC
nvidia_drm_fix_for_346.35 fixed this problem on my system.
Comment 15 Jeroen Roovers gentoo-dev 2015-03-04 14:03:18 UTC
*** Bug 541184 has been marked as a duplicate of this bug. ***
Comment 16 Jeroen Roovers gentoo-dev 2015-03-04 14:04:18 UTC
346.47 no longer has this issue.