Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 531956 - sys-libs/gpm: unspecified dependency on sys-apps/texinfo leads to build failure: /usr/bin/makeinfo: Can't locate Unicode/EastAsianWidth.pm in @INC
Summary: sys-libs/gpm: unspecified dependency on sys-apps/texinfo leads to build failu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Development (show other bugs)
Hardware: AMD64 Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: InVCS
Depends on:
Blocks:
 
Reported: 2014-12-08 02:33 UTC by Austin English (RETIRED)
Modified: 2014-12-10 23:52 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (log.txt,58.17 KB, text/plain)
2014-12-08 02:34 UTC, Austin English (RETIRED)
Details
gpm-1.20.7-r2.ebuild: add sys-apps/texinfo to DEPEND (gpm-1.20.7-r2.ebuild.patch,202 bytes, patch)
2014-12-10 09:31 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Austin English (RETIRED) gentoo-dev 2014-12-08 02:33:20 UTC
Bootstrapping a new system from a base install, and doing:
MAKEOPTS=-j24 emerge -uDavN --jobs 13 -b -k --binpkg-respect-use --rebuild-if-new-slot --rebuild-if-new-rev --with-bdeps=y @world

fails on the first pass in dev-libs/gpm:
Can't locate Unicode/EastAsianWidth.pm in @INC (you may need to install the Unicode::EastAsianWidth module) (@INC contains: /usr/share/texinfo /etc/perl /usr/local/lib64/perl5/5.20.1/x86_64-linux-thread-multi /usr/local/lib64/perl5/5.20.1 /usr/lib64/perl5/vendor_perl/5.20.1/x86_64-linux-thread-multi /usr/lib64/perl5/vendor_perl/5.20.1 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.20.1/x86_64-linux-thread-multi /usr/lib64/perl5/5.20.1 .) at /usr/share/texinfo/Texinfo/Convert/Unicode.pm line 31.
BEGIN failed--compilation aborted at /usr/share/texinfo/Texinfo/Convert/Unicode.pm line 31.
Compilation failed in require at /usr/share/texinfo/Texinfo/Convert/Text.pm line 27.
BEGIN failed--compilation aborted at /usr/share/texinfo/Texinfo/Convert/Text.pm line 27.
Compilation failed in require at /usr/share/texinfo/Texinfo/Parser.pm line 55.
BEGIN failed--compilation aborted at /usr/share/texinfo/Texinfo/Parser.pm line 55.
Compilation failed in require at /usr/bin/makeinfo line 101.
BEGIN failed--compilation aborted at /usr/bin/makeinfo line 101.
Makefile:53: recipe for target '/var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_32.x86/doc/gpm.info' failed
make[1]: *** [/var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_32.x86/doc/gpm.info] Error 2
rm /var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_32.x86/doc/gpm.texinfo
make[1]: Leaving directory '/var/tmp/portage/sys-libs/gpm-1.20.7-r2/work/gpm-1.20.7-abi_x86_32.x86/doc'
Makefile:77: recipe for target 'do-all' failed
make: *** [do-all] Error 1
 * ERROR: sys-libs/gpm-1.20.7-r2::gentoo failed (compile phase):

If I retry with some binary packages built, it usually succeeds. Presumably perl needs to be upgraded before dependencies, or not upgraded piecemeal whlie other packagkes are too.

Reproducible: Always

Steps to Reproduce:
1. Chroot into a multilib base image.
2. Emerge world an xfce-desktop system (or could be some of the other packages, haven't narrowed down the dependency that caused it), and make sure dev-libs/gpm is included
Actual Results:  
Fails on dev-libs/gpm

Expected Results:  
Build succeeds
Comment 1 Austin English (RETIRED) gentoo-dev 2014-12-08 02:34:18 UTC
Created attachment 391194 [details]
build log
Comment 2 Jeroen Roovers gentoo-dev 2014-12-08 07:31:15 UTC

*** This bug has been marked as a duplicate of bug 41124 ***
Comment 3 Zac Medico gentoo-dev 2014-12-10 02:57:09 UTC
It fails when it calls /usr/bin/makeinfo which is a perl script installed by sys-apps/texinfo. So, if we add sys-apps/texinfo to DEPEND in the sys-libs/gpm ebuild, then hopefully it will solve the problem.
Comment 4 Zac Medico gentoo-dev 2014-12-10 03:04:44 UTC
(In reply to Jeroen Roovers from comment #2)
> 
> *** This bug has been marked as a duplicate of bug 41124 ***

Relying on perl-cleaner is a poor solution, since EAPI 5 sub-slot rebuilds should be able to handle this (if dependencies are properly specified).
Comment 5 Zac Medico gentoo-dev 2014-12-10 09:31:14 UTC
Created attachment 391346 [details, diff]
gpm-1.20.7-r2.ebuild: add sys-apps/texinfo to DEPEND
Comment 6 Austin English (RETIRED) gentoo-dev 2014-12-10 23:30:03 UTC
(In reply to Zac Medico from comment #3)
> It fails when it calls /usr/bin/makeinfo which is a perl script installed by
> sys-apps/texinfo. So, if we add sys-apps/texinfo to DEPEND in the
> sys-libs/gpm ebuild, then hopefully it will solve the problem.

That works for me, thanks.

dev-scheme/guile has the same issue, I opened bug 532214 for that.
Comment 7 Zac Medico gentoo-dev 2014-12-10 23:52:01 UTC
(In reply to austinenglish@gmail.com from comment #6)\
> That works for me, thanks.

Thanks for testing. This is fixed in CVS now.