Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 53166 - net-analyzer/xtraceroute-0.9.1 doesn't compile, Cannot find proper gtkgl version
Summary: net-analyzer/xtraceroute-0.9.1 doesn't compile, Cannot find proper gtkgl version
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Netmon project
Depends on:
Reported: 2004-06-06 15:08 UTC by Boris Fersing (RETIRED)
Modified: 2004-07-14 11:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Boris Fersing (RETIRED) gentoo-dev 2004-06-06 15:08:12 UTC
xtraceroute-0.9.1 doesn't compile, but x11-libs/gtkglarea is installed !

*  x11-libs/gtkglarea
      Latest version available: 1.99.0
      Latest version installed: 1.99.0
      Size of downloaded files: 205 kB
      Description: GL extensions for gtk+

Reproducible: Always
Steps to Reproduce:
1.emerge xtraceroute

Actual Results:  
checking for nl_langinfo and CODESET... yes
checking for LC_MESSAGES... yes
checking for bison... bison
checking version of bison... 1.875, ok
checking whether NLS is requested... yes
checking whether included gettext is requested... no
checking for GNU gettext in libc... yes
checking for traceroute... /usr/sbin/traceroute
checking for gtk-config... /usr/bin/gtk-config
checking for GTK - version >= 1.0.0... yes
checking for gdk-pixbuf-config... /usr/bin/gdk-pixbuf-config
checking for GDK_PIXBUF - version >= 0.8.0... yes
checking GL... yes
checking GtkGLArea... no
configure: error: Cannot find proper gtkgl version

!!! ERROR: net-analyzer/xtraceroute-0.9.1 failed.
!!! Function src_compile, Line 32, Exitcode 1
!!! ./configure failed

# emerge info
Portage 2.0.50-r7 (default-x86-1.4, gcc-3.3.3, glibc-, 2.6.6)
System uname: 2.6.6 i686 Mobile Intel(R) Pentium(R) 4     CPU 3.06GHz
Gentoo Base System version 1.4.16
distcc 2.14 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.3 [enabled]
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5
CFLAGS=" -g -pipe -march=pentium4 -mcpu=pentium4 -mfpmath=sse,387 -O2
-frename-registers -fomit-frame-pointer -ffast-math -fforce-addr"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config
/usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config
/usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/
/usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/
/usr/share/texmf/xdvi/ /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS=" -g -pipe -march=pentium4 -mcpu=pentium4 -mfpmath=sse,387 -O2
-frename-registers -fomit-frame-pointer -ffast-math -fforce-addr"
FEATURES="autoaddcvs buildsyspkg ccache fixpackages sandbox userpriv usersandbox"
PORTDIR_OVERLAY="/usr/local/bmg-main/ /usr/local/portage"
USE="3ds S3TC X X509 aac aalib acpi acpi4linux aim alsa anthy apache2 ardour-ksi
avi berkdb bonobo canna cdr chasen chroot cjk crypt cscope dga directfb dv dvb
dvd encode escreen esd evo faad fam fbcon fbdev ffmpeg fftw flac flash freetype
freewnn gb gd gdbm gif gnome gphoto2 gpm gstreamer gtk gtk2 gtkhtml guile icq
imagemagick imap imlib jabber java javascript jbig jpeg libwww mad matroska
mikmod mldonkeypango mmx motif mozdomi mozilla moznoirc moznomail mozsvg mpeg
mpeg4 msn music ncurses net nls nptl nvidia objc ocaml offensive oggvorbis
openal opengl openssh oscar oss pam pcmcia pdflib perl php pic png pnp pthreads
python quicktime readline rogue ruby samba sdl skk slang spell sse ssl svg svga
tcltk tcpd tetex tiff transcode truetype unicode usb videos wifi x86 xfs xine
xinerama xml xml2 xmms xosd xv xvid yahoo zlib"
Comment 1 Boris Fersing (RETIRED) gentoo-dev 2004-06-08 12:39:28 UTC
I re-emerged gtkglarea-1.2.3-r1 and now it works ! marked as FIXED !
Comment 2 Douglas Muth 2004-07-14 11:11:33 UTC
Just an additional note that I tried doing the same thing, and discovered that it didn't work unless I re-emerged the specific version 1.2.3-r1 of gtkglarea.  Ugh.