Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 531268 - app-crypt/dieharder-3.31.1 - In file included from bits.c:7: /usr/include/unistd.h:1043:20: error: unknown type name 'intptr_t'
Summary: app-crypt/dieharder-3.31.1 - In file included from bits.c:7: /usr/include/uni...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Crypto team
URL:
Whiteboard:
Keywords:
Depends on: 549754
Blocks:
  Show dependency tree
 
Reported: 2014-11-30 20:53 UTC by Toralf Förster
Modified: 2015-06-21 00:11 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge log (app-crypt:dieharder-3.31.1:20141130-190007.log,8.25 KB, text/plain)
2014-11-30 20:53 UTC, Toralf Förster
Details
patch to add stdint.h include (dieharder-3.31.1-add-stdint-include.patch,347 bytes, patch)
2015-05-17 20:25 UTC, Michael Trinque
Details | Diff
dieharder-3.31.1-build.patch (dieharder-3.31.1-build.patch,4.05 KB, patch)
2015-05-18 19:19 UTC, Alon Bar-Lev
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Toralf Förster gentoo-dev 2014-11-30 20:53:28 UTC
Created attachment 390670 [details]
emerge log

make[1]: Entering directory '/var/tmp/portage/app-crypt/dieharder-3.31.1/work/dieharder-3.31.1/libdieharder'
/bin/sh ../libtool  --tag=CC   --mode=compile x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I..  -DVERSION=3.31.1 -DLITTLE_ENDIAN=1 -I ../include -I /usr/include  -std=c99 -Wall -pedantic -O2 -pipe -c -o libdieharder_la-bits.lo `test -f 'bits.c' || echo './'`bits.c
libtool: compile:  x86_64-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I.. -DVERSION=3.31.1 -DLITTLE_ENDIAN=1 -I ../include -I /usr/include -std=c99 -Wall -pedantic -O2 -pipe -c bits.c  -fPIC -DPIC -o .libs/libdieharder_la-bits.o
In file included from ../include/dieharder/libdieharder.h:22:0,
                 from bits.c:7:
/usr/include/unistd.h:1043:20: error: unknown type name 'intptr_t'
 extern void *sbrk (intptr_t __delta) __THROW;
                    ^
bits.c: In function 'fill_uint_buffer':
bits.c:407:15: warning: variable 'bufbits' set but not used [-Wunused-but-set-variable]
  unsigned int bufbits,bdelta;
               ^
Makefile:570: recipe for target 'libdieharder_la-bits.lo' failed
make[1]: *** [libdieharder_la-bits.lo] Error 1
make[1]: Leaving directory '/var/tmp/portage/app-crypt/dieharder-3.31.1/work/dieharder-3.31.1/libdieharder'
Makefile:412: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
 * ERROR: app-crypt/dieharder-3.31.1::gentoo failed (compile phase):
 *   emake failed
 





This chroot image is located at a hardened amd64 system.

Portage 2.2.14 (python 3.3.5-final-0, hardened/linux/amd64, gcc-4.8.3, glibc-2.20, 3.17.4-hardened-r1 x86_64)
=================================================================
System uname: Linux-3.17.4-hardened-r1-x86_64-Intel-R-_Core-TM-_i7-3770_CPU_@_3.40GHz-with-gentoo-2.2
KiB Mem:    16166892 total,   2362012 free
KiB Swap:   16777212 total,  16773544 free
Timestamp of tree: Sun, 30 Nov 2014 13:45:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.3_p30-r1
dev-lang/perl:            5.20.1-r3
dev-lang/python:          2.7.8, 3.3.5-r1
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.6
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.3-r2
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.17-r1 (virtual/os-headers)
sys-libs/glibc:           2.20
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--nospinner --tree --quiet-build --deep --jobs 1"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.leaseweb.com/gentoo/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.hs-esslingen.de/pub/Mirrors/gentoo/ http://gd.tuwien.ac.at/opsys/linux/gentoo/"
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j1"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="acl amd64 berkdb bindist bzip2 cli cracklib crypt cxx dri fortran gdbm hardened iconv ipv6 justify mbox mmx modules multilib ncurses nls nptl openmp pam pax_kernel pcre readline session sse sse2 ssl tcpd unicode urandom xattr xtpax zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Comment 1 Alon Bar-Lev gentoo-dev 2015-01-09 21:39:50 UTC
it seems glibc-2.20 issue, I cannot reproduce with glibc-2.19
Comment 2 Michael Trinque 2015-05-17 20:25:44 UTC
Created attachment 403502 [details, diff]
patch to add stdint.h include

Adding this include fixes the build with glibc 2.20-r2.
Comment 3 Alon Bar-Lev gentoo-dev 2015-05-17 20:33:27 UTC
shouldn't stdint.h be included from unistd.h if it uses its types?
Comment 4 Michael Trinque 2015-05-17 21:28:36 UTC
I am not sure. I have filed a bug against glibc here:
https://bugs.gentoo.org/show_bug.cgi?id=549754
Comment 5 SpanKY gentoo-dev 2015-05-18 02:08:52 UTC
dieharder is broken:
include/dieharder/libdieharder.h:#define __USE_MISC 1
include/dieharder/libdieharder.h:#define __USE_BSD 1

that code is completely invalid.  it needs to use the public _USE_xxx defines instead.  see the feature_test_macros man page for details.
Comment 6 Michael Trinque 2015-05-18 18:02:21 UTC
Thanks SpanKY, it does appear that dieharder is improperly using glibc internals, and the switch to std=c99 exposed this. I will see about producing a patch that fixes it, and will ping upstream with that.
Comment 7 Alon Bar-Lev gentoo-dev 2015-05-18 18:26:37 UTC
please try to remove the following from ./include/dieharder/libdieharder.h

#define __USE_MISC 1
#define __USE_BSD 1

and set -D_GNU_SOURCE at CPPFLAGS or CFLAGS and see if it helps you, working for me for the stable glibc.

if it works for you we can workout this in ebuild.
Comment 8 Alon Bar-Lev gentoo-dev 2015-05-18 19:09:51 UTC
ok, this is one of the worse build system I've ever seen.
Comment 9 Alon Bar-Lev gentoo-dev 2015-05-18 19:19:57 UTC
Created attachment 403570 [details, diff]
dieharder-3.31.1-build.patch

and this is only the start, now every source should contain:

#ifdef HAVE_CONFIG_H
#include <config.h>
#endif

here is where I stopped... this project abuses the autoconf/automake to a level that is unfixable, not sure it worth to maintain this package.
Comment 10 Michael Trinque 2015-05-19 22:29:20 UTC
Seems an incredibly useful package to abandon.
Comment 11 MickKi 2015-05-24 12:20:09 UTC
(In reply to Michael Trinque from comment #10)
> Seems an incredibly useful package to abandon.

Yes, I wish I had the knowledge to fix this.  Can't upstream be offered friendly advice on how to fix it?
-- 
Regards,
Mick
Comment 12 Alon Bar-Lev gentoo-dev 2015-05-24 19:50:35 UTC
please try comment#7.
Comment 13 Alon Bar-Lev gentoo-dev 2015-06-21 00:11:48 UTC
Ugly hack was added to dieharder-3.31.1-r1.
Expect more breakage.
If upstream is not alive we will not be able to fix as build system is one of the worse.