Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 530712 - net-misc/openssh-6.7_p1-r2[-kerberos,ldns]: /usr/include/krb5/krb5.h:7830:1: error: expected identifier or ‘(’ before ‘while’ krb5_free_error_message(krb5_context ctx, const char *msg);
Summary: net-misc/openssh-6.7_p1-r2[-kerberos,ldns]: /usr/include/krb5/krb5.h:7830:1: ...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Robin Johnson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-26 03:40 UTC by Andrew Savchenko
Modified: 2014-12-31 07:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,71.48 KB, text/x-log)
2014-11-26 03:40 UTC, Andrew Savchenko
Details
environment (environment,150.63 KB, text/plain)
2014-11-26 03:41 UTC, Andrew Savchenko
Details
emerge --info (emerge.info,8.96 KB, application/x-info)
2014-11-26 03:41 UTC, Andrew Savchenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Savchenko gentoo-dev 2014-11-26 03:40:01 UTC
Hello,

openssh[-kerberos ldns] fails with openssl[kerberos] with the following error:

x86_64-pc-linux-gnu-gcc -march=native -O2 -funswitch-loops -fpredictive-commoning -ftree-vectorize -ftree-slp-vectorize -fvect-cost-model  -fgcse-after-reload -ftree-partial-pre -ftree-loop-im -fweb -frename-registers -fomit-frame-pointer -fexcess-precision=fast -pipe -frecord-gcc-switches -fno-stack-protector -Wall -Wpointer-arith -Wuninitialized -Wsign-compare -Wformat-security -Wsizeof-pointer-memaccess -Wno-pointer-sign -Wno-unused-result -fno-strict-aliasing  -ftrapv -fno-builtin-memset -fstack-protector-all -fPIE  -I. -I.. -I. -I./..  -DHAVE_CONFIG_H -c bsd-misc.c
In file included from /usr/include/krb5.h:8:0,
                 from /usr/include/openssl/kssl.h:72,
                 from /usr/include/openssl/ssl.h:165,
                 from /usr/include/ldns/dane.h:31,
                 from /usr/include/ldns/ldns.h:98,
                 from getrrsetbyname-ldns.c:53:
/usr/include/krb5/krb5.h:7830:1: error: expected identifier or ‘(’ before ‘while’
 krb5_free_error_message(krb5_context ctx, const char *msg);
 ^

Perhaps openssh[ldns] needs the same kerberos dependency as openssl.

$ emerge -pqv '=net-misc/openssh-6.7_p1-r2::gentoo'
[ebuild     U ] net-misc/openssh-6.7_p1-r2 [6.6.1_p1-r4] USE="X hpn ldns pam pie%* -X509* -bindist -kerberos* -ldap -libedit -sctp% (-selinux) -skey -static (-tcpd%*)"

$ eix -e openssl:
[...]
 Installed versions:  1.0.1j{tbz2}(03:18:51 PM 11/03/2014)(gmp kerberos rfc3779 sse2 tls-heartbeat zlib -bindist -static-libs -test -vanilla ABI_MIPS="-n32 -n64 -o32" ABI_PPC="-32 -64" ABI_S390="-32 -64" ABI_X86="64 -32 -x32")
Comment 1 Andrew Savchenko gentoo-dev 2014-11-26 03:40:48 UTC
Created attachment 390300 [details]
build.log
Comment 2 Andrew Savchenko gentoo-dev 2014-11-26 03:41:07 UTC
Created attachment 390302 [details]
environment
Comment 3 Andrew Savchenko gentoo-dev 2014-11-26 03:41:26 UTC
Created attachment 390304 [details]
emerge --info