Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 529388 - x11-libs/libva IUSE="-wayland" incomplete - No package 'wayland-scanner' found
Summary: x11-libs/libva IUSE="-wayland" incomplete - No package 'wayland-scanner' found
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Alexis Ballier
Keywords: PATCH
Depends on:
Blocks: 538640
  Show dependency tree
Reported: 2014-11-15 21:47 UTC by Manuel Rüger (RETIRED)
Modified: 2015-06-24 19:48 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

build.log (build.log,21.20 KB, text/plain)
2014-11-15 21:47 UTC, Manuel Rüger (RETIRED)
Bug fix. (libva-1.3.1-autotools-wayland_scanner.patch,777 bytes, patch)
2015-04-17 03:45 UTC, Cecil Curry
Details | Diff
new patch (patch-new,768 bytes, patch)
2015-06-21 10:23 UTC, Oleh
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Rüger (RETIRED) gentoo-dev 2014-11-15 21:47:53 UTC
Created attachment 389458 [details]

configure: error: Package requirements (wayland-scanner) were not met:

No package 'wayland-scanner' found

Fix it with adding "enable-wayland=0", see:

This probably also affects x11-libs/libva-intel-driver.
Comment 1 Manuel Rüger (RETIRED) gentoo-dev 2014-11-15 22:23:41 UTC
(In reply to Manuel Rüger from comment #0)
> Fix it with adding "enable-wayland=0", see:

Sorry, I was wrong, this does not fix it.

If wayland is not installed, everything works as expected.
Comment 2 Alexis Ballier gentoo-dev 2014-11-27 09:52:05 UTC
what wayland version do you have installed ?
Comment 3 Manuel Rüger (RETIRED) gentoo-dev 2015-01-05 14:24:37 UTC
Sorry for the delay.
I tested it today with libva-1.5.0 and wayland-1.6.0.

Error still exists.
Comment 4 Manuel Rüger (RETIRED) gentoo-dev 2015-01-05 14:30:11 UTC
(In reply to Manuel Rüger from comment #3)
> Sorry for the delay.
> I tested it today with libva-1.5.0 and wayland-1.6.0.
> Error still exists.

I solved the issue here.

libva[abi_x86_32] should imply a dependency on wayland[abi_x86_32] which it currently doesn't.
Comment 5 Alexis Ballier gentoo-dev 2015-01-05 15:35:25 UTC
 wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
Comment 6 Manuel Rüger (RETIRED) gentoo-dev 2015-01-05 16:09:55 UTC
(In reply to Alexis Ballier from comment #5)
>  wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
> ???

I'm sorry for the confusion. 
The problem is, that this dep is automagic. 
I don't have wayland in my useflags activated for libva.

Calculating dependencies... done!
[ebuild   R   ~] x11-libs/libva-1.5.0  USE="X drm opengl -egl -vdpau -wayland" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="intel -dummy -fglrx -nvidia" 0 KiB

But I have wayland (ABI_X86_64 only) installed, so it works for ABI_X86_64 (as wayland is available there, and the automagic dep gets satisfied), but it doesn't for ABI_X86_32 (wayland-scanner is missing there).
Comment 7 Pacho Ramos gentoo-dev 2015-02-24 12:57:06 UTC
(In reply to Manuel Rüger from comment #0)
> Fix it with adding "enable-wayland=0", see:

This link is dead now :(
Comment 8 Marc Schiffbauer gentoo-dev 2015-03-14 23:12:37 UTC
Same issue here.

Even with USE=-wayland libva requires dev-libs/wayland[abi_x86_32] if wayland is installed.
Comment 9 Steffen Schaumburg 2015-03-16 00:50:53 UTC
Having the same issue here. I don't have wayland now nor did I ever have it installed. Running a wild mix of amd64 and ~amd64.
Comment 10 Steffen Schaumburg 2015-03-16 01:23:49 UTC
(In reply to Steffen Schaumburg from comment #9)
> Having the same issue here. I don't have wayland now nor did I ever have it
> installed. Running a wild mix of amd64 and ~amd64.

I'm sorry, I actually do have wayland installed. But wayland is ABI_X86="(64) (-32) (-x32)" whilst libva is ABI_X86="32 (64) (-x32)".
After changing wayland to ABI_X86 +32 it works.
Comment 11 Lucas Matt 2015-04-11 18:51:35 UTC
I can confirm this.
Never had wayland installed and x11-libs/libva-intel-driver is -wayland.

System is mostly amd64 with few ~amd64.

emerge --info:

Portage 2.2.14 (python 3.4.1-final-0, default/linux/amd64/13.0/desktop/kde, gcc-4.8.4, glibc-2.20-r2, 3.18.11-gentoo x86_64)
System uname: Linux-3.18.11-gentoo-x86_64-Intel-R-_Core-TM-_i5_CPU_650_@_3.20GHz-with-gentoo-2.2
KiB Mem:     8171168 total,   2533012 free
KiB Swap:    7815616 total,   7813712 free
Timestamp of tree: Sat, 11 Apr 2015 15:00:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
ccache version 3.1.9 [enabled]
app-shells/bash:          4.2_p53
dev-java/java-config:     2.2.0
dev-lang/perl:            5.20.2
dev-lang/python:          2.7.9-r1, 3.4.1
dev-util/ccache:          3.1.9-r4
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.13.11
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6-r1, 1.13.4
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.6
sys-devel/make:           4.1-r1
sys-kernel/linux-headers: 3.18 (virtual/os-headers)
sys-libs/glibc:           2.20-r2
Repositories: gentoo kde brother-overlay x-portage
Installed sets: @kde-plasma-luc-5.2
ACCEPT_LICENSE="* -@EULA PUEL dlj-1.1 googleearth Oracle-BCLA-JavaSE AdobeFlash-10.3 skype- AdobeFlash-11.x"
CFLAGS="-O2 -march=native -mtune=native -pipe"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/themes/oxygen-gtk/gtk-2.0 /usr/share/themes/oxygen-gtk/gtk-3.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -mtune=native -pipe"
EMERGE_DEFAULT_OPTS="--with-bdeps y"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs ccache clean-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/kde /var/lib/layman/brother-overlay /usr/local/portage"
USE="X a52 aac acpi aes alsa amd64 avahi bash-completion bluetooth bojour branding bzip2 cairo cdda cddb cdr cjk cli consolekit crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gdbm gif glamor glibc-omitfp glitz gnutls iconv inotify jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility kipi lcms libnotify libv4l2 lzma mad mmx mmxext mng modules mp3 mp4 mpeg multilib musepack ncurses network-cron networkmanager nls nptl nsplugin ogg openexr opengl openmp pam pango pch pdf phonon plasma png policykit popcnt ppds pulseaudio qt3support qt4 qt5 quicktime readline samba schroedinger sdl session spell sse sse2 sse3 sse4_1 sse4_2 ssl ssse3 startup-notification svg sysfs theora threads tiff truetype udev udisks unicode upnp upower usb v4l v4l2 vcd vdpau vorbis win32codecs wxwidgets x264 xattr xcb xcomposite xinerama xml xscreensaver xulrunner xv xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="author karbon sheets stage words krita" CAMERAS="canon ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" DRACUT_MODULES="plymouth" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python3_4 python2_7" RUBY_TARGETS="ruby19 ruby20" SANE_BACKENDS="epson2" USERLAND="GNU" VIDEO_CARDS="nv nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 12 Pacho Ramos gentoo-dev 2015-04-11 20:22:58 UTC
I think the bug has enough "I confirm" comments ;)

The problem is that no patch is available to fix this and, also, the upstream bug report link looks dead and I couldn't find the new one to see if upstream is working on fixing that :(
Comment 13 Cecil Curry 2015-04-17 03:45:24 UTC
Created attachment 401410 [details, diff]
Bug fix.

Patch "" to perform "wayland-scanner" logic only if performing Wayland logic.
Comment 14 Cecil Curry 2015-04-17 04:07:06 UTC
I just hit this... and it hurt. I didn't like that much, so I fixed it. Heinz Wiesinger correctly identified the underlying issue nearly a year ago at the following upstream bug report:

To quote: "The problem is that the check for wayland-scanner [in] is later, outside of the other wayland checks block and not surrounded by any kind of 'if wayland' conditions."

Heinz nailed it. Since the fix is trivial, I've both attached a working patch and submitted the same patch upstream. To apply this locally:

* Download and copy the attached bug fix to "/usr/portage/x11-libs/libva/files/libva-1.3.1-autotools-wayland_scanner.patch".
* Edit "/usr/portage/x11-libs/libva/libva-1.3.1.ebuild" to add that file to the ${PATCHES} array:
* Regenerate the "/usr/portage/x11-libs/libva/Manifest" (e.g., via "repoman").

Lacking commit permissions, I'm afraid our intrepid Gentoo developers will need to manually apply these changes. Cheers, all!
Comment 15 Pacho Ramos gentoo-dev 2015-06-02 18:42:40 UTC
For what version is that patch for? It doesn't apply to latest 1.5.1 version in the tree :(
Comment 16 Oleh 2015-06-21 10:19:04 UTC
it is a patch for 1.3.2 version. it can be easily adopted to 1.5.1 libva and libva-intel-driver.
Comment 17 Oleh 2015-06-21 10:22:13 UTC
change top_srcdir to top_buildir is sufficient for this patch to apply for 1.5.1 versions.
Comment 18 Oleh 2015-06-21 10:23:54 UTC
Created attachment 405474 [details, diff]
new patch
Comment 19 Pacho Ramos gentoo-dev 2015-06-21 12:23:03 UTC
+  21 Jun 2015; Pacho Ramos <>
+  +files/libva-1.5.1-wayland-automagic.patch, libva-1.5.1.ebuild:
+  Fix automagic dependency on wayland (#529388 by Oleg, Cecil Curry Manuel Rüger
+  and others)
Comment 20 Oleh 2015-06-21 14:16:51 UTC
x11-libs/libva-intel-driver need the patch aswell.
Comment 21 Pacho Ramos gentoo-dev 2015-06-24 19:48:42 UTC
+  24 Jun 2015; Pacho Ramos <>
+  +files/libva-intel-driver-1.5.1-wayland-automagic.patch,
+  libva-intel-driver-1.5.1.ebuild:
+  Fix automagic wayland depend (#529388)