Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 528818 - x11-misc/synergy-1.6.1 should depend on qt4? ( net-dns/avahi )
Summary: x11-misc/synergy-1.6.1 should depend on qt4? ( net-dns/avahi )
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-11-10 13:51 UTC by Martin Kletzander
Modified: 2014-11-11 11:51 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Kletzander 2014-11-10 13:51:53 UTC
Synergy compiles properly without any special configuration even without avahi.  I suggest the dependence on avahi is made conditional based on avahi USE flag.

Reproducible: Always

Steps to Reproduce:
1. On system without avahi, run the following command

  USE="-avahi" emerge -p "=x11-misc/synergy-1.6.1"
Actual Results:  
Portage wants to install net-dns/avahi

Expected Results:  
Portage doesn't want to install net-dns/avahi

Synergy added support for zero configuration based on avahi in version 1.6.0, synergy-1.6.1 is the first ebuild one that requires avahi as a dependency.
Comment 1 Scott 2014-11-10 20:53:43 UTC
Agreed; synergy ebuild does not respect USE settings.

$ egrep 'avahi|zeroconf' /etc/portage/package* /etc/portage/*conf
/etc/portage/package.mask:net-dns/avahi
/etc/portage/make.conf:aac alsa -avahi \
/etc/portage/make.conf:-zeroconf \

USE flags supported:

# equery uses synergy
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for x11-misc/synergy-1.6.1:
 U I
 + + qt4  : Add support for the Qt GUI/Application Toolkit version 4.x
 - - test : Workaround to pull in packages needed to run with FEATURES=test. Portage-2.1.2 handles this internally, so don't set it in make.conf/package.use anymore


Emerge output:

# emerge -puDN world

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The following update has been skipped due to unsatisfied dependencies:

x11-misc/synergy:0

!!! All ebuilds that could satisfy "net-dns/avahi[mdnsresponder-compat]" have been masked.
!!! One of the following masked packages is required to complete your request:
- net-dns/avahi-0.6.31-r6::gentoo (masked by: package.mask)
/etc/portage/package.mask:

- net-dns/avahi-0.6.31-r5::gentoo (masked by: package.mask, ~amd64 keyword)
- net-dns/avahi-0.6.31-r2::gentoo (masked by: package.mask)
- net-dns/avahi-0.6.30-r3::gentoo (masked by: package.mask)

(dependency required by "x11-misc/synergy-1.6.1" [ebuild])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I am working around this by masking 1.6 and above.
Comment 2 Jeroen Roovers gentoo-dev 2014-11-11 10:26:10 UTC
(In reply to Martin Kletzander from comment #0)
> Synergy compiles properly without any special configuration even without
> avahi.

x86_64-pc-linux-gnu-g++ -c -frecord-gcc-switches -g -pipe -O2 -Wall -Wformat-security -march=core2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtGui -I/usr/include/qt4 -I. -Isrc -Itmp/release -I. -o tmp/release/ZeroconfRegister.o src/ZeroconfRegister.cpp
In file included from src/ZeroconfRegister.cpp:18:0:
src/ZeroconfRegister.h:32:20: fatal error: dns_sd.h: No such file or directory
Comment 3 Jeroen Roovers gentoo-dev 2014-11-11 11:48:22 UTC
Ah yes, this is with USE=qt4.
Comment 4 Jeroen Roovers gentoo-dev 2014-11-11 11:51:35 UTC
+  11 Nov 2014; Jeroen Roovers <jer@gentoo.org> synergy-1.6.1.ebuild:
+  net-dns/avahi is only required with USE=qt4 (bug #528818 by Martin
+  Kletzander).