Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 528482 - dev-libs/libdbusmenu-qt-0.9.3_pre20140619 can't find qtdbus-4.8.6 types
Summary: dev-libs/libdbusmenu-qt-0.9.3_pre20140619 can't find qtdbus-4.8.6 types
Status: RESOLVED DUPLICATE of bug 526078
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords: InOverlay, PMASKED
Depends on:
Blocks: 510042
  Show dependency tree
 
Reported: 2014-11-06 20:48 UTC by Andrés Becerra Sandoval
Modified: 2014-11-07 23:44 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build.log (build.log,34.86 KB, text/plain)
2014-11-06 20:51 UTC, Andrés Becerra Sandoval
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrés Becerra Sandoval 2014-11-06 20:48:21 UTC
In file included from /var/tmp/portage/dev-libs/libdbusmenu-qt-0.9.3_pre20140619/work/libdbusmenu-qt-0.9.3+14.10.20140619/src/dbusmenuexporter.cpp:21:0:
/var/tmp/portage/dev-libs/libdbusmenu-qt-0.9.3_pre20140619/work/libdbusmenu-qt-0.9.3+14.10.20140619/src/dbusmenuexporter.h:48:72: error: ‘QDBusConnection’ does not name a type
     DBusMenuExporter(const QString &dbusObjectPath, QMenu *menu, const QDBusConnection &dbusConnection = QDBusConnection::sessionBus());
                                                                        ^
In file included from /var/tmp/portage/dev-libs/libdbusmenu-qt-0.9.3_pre20140619/work/libdbusmenu-qt-0.9.3+14.10.20140619/src/dbusmenuexporter.cpp:21:0:
/var/tmp/portage/dev-libs/libdbusmenu-qt-0.9.3_pre20140619/work/libdbusmenu-qt-0.9.3+14.10.20140619/src/dbusmenuexporter.h:48:134: error: ISO C++ forbids declaration of ‘dbusConnection’ with no type [-fpermissive]
     DBusMenuExporter(const QString &dbusObjectPath, QMenu *menu, const QDBusConnection &dbusConnection = QDBusConnection::sessionBus());
Comment 1 Andrés Becerra Sandoval 2014-11-06 20:51:01 UTC
Created attachment 388690 [details]
build.log
Comment 2 Davide Pesavento gentoo-dev 2014-11-06 20:58:11 UTC
When was the last time you emerged qtcore?
Comment 3 Andrés Becerra Sandoval 2014-11-06 22:36:07 UTC
(In reply to Davide Pesavento from comment #2)
> When was the last time you emerged qtcore?

October 28
Comment 4 Davide Pesavento gentoo-dev 2014-11-06 23:07:46 UTC
Can you verify that your checkout of the qt overlay included commit f1c2941f8b40e41e3413f4465c2edec1bb1a78a8 when you last emerged qtcore?

Or even easier, re-emerge qtcore:4 and try again.
Comment 5 Davide Pesavento gentoo-dev 2014-11-06 23:08:39 UTC
(In reply to Davide Pesavento from comment #4)
> Or even easier, re-emerge qtcore:4 and try again.

Obviously I mean re-emerge using an *up-to-date* clone of the overlay.
Comment 6 Davide Pesavento gentoo-dev 2014-11-07 23:44:51 UTC

*** This bug has been marked as a duplicate of bug 526078 ***