Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 528294 (libltdl-split) - [TRACKER] sys-devel/libtool: libltdl splitted out -> update deps needed
Summary: [TRACKER] sys-devel/libtool: libltdl splitted out -> update deps needed
Status: RESOLVED FIXED
Alias: libltdl-split
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords: Tracker
: 528346 537446 (view as bug list)
Depends on: 528206 528296 528298 528336 539368 539370 539372 539374 539868 590336
Blocks:
  Show dependency tree
 
Reported: 2014-11-05 10:21 UTC by Pacho Ramos
Modified: 2016-12-09 16:20 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2014-11-05 10:21:15 UTC
sys-devel/libtool-2.4.3-r2 lost its abi_* flags, as the library was split into dev-libs/libltdl:
  03 Nov 2014; Mike Frysinger <vapier@gentoo.org> +libtool-2.4.3-r2.ebuild,
  -libtool-1.3.5.ebuild, -libtool-1.5.26-r1.ebuild, libtool-9999.ebuild:
  Split libltdl out of main libtool package per upstream recommendations.

Some reverse deps need to be updated to reflect this then
Comment 1 SpanKY gentoo-dev 2014-11-05 16:07:44 UTC
libtool still pulls in libltdl so reverse deps aren't broken, but depending on the ABI flags won't work i guess.  original plan was to just let it happen organically.

i couldn't really go through the tree and update things automatically as it's not clear who really wants libltdl and who accidentally put it into RDEPEND.  both need fixing though.

these people RDEPEND on it now:
app-admin/collectd
app-antivirus/clamav
app-emulation/emul-linux-x86-baselibs
app-emulation/ski
dev-cpp/pficommon
dev-db/unixODBC
dev-libs/libp11
dev-libs/openct
dev-libs/opensc
dev-libs/redland
dev-scheme/guile
dev-util/confix
dev-util/global
games-arcade/emilia-pinball
games-strategy/freeciv
games-strategy/liquidwar6
media-gfx/graphicsmagick
media-gfx/graphviz
media-gfx/imagemagick
media-libs/libcanberra
media-libs/libextractor
media-libs/libgphoto2
media-sound/moc
media-sound/mpg123
media-sound/pulseaudio
media-sound/sox
media-tv/dvbstreamer
net-analyzer/ettercap
net-dialup/freeradius
net-libs/rb_libtorrent
net-mail/mailutils
net-nds/openldap
net-proxy/squid
sys-apps/hwloc
sys-cluster/pacemaker-gui
www-apache/mod_musicindex
www-plugins/gnash
Comment 2 SpanKY gentoo-dev 2014-11-05 16:11:13 UTC
Commit message: Depend on libltdl rather than libtool
http://sources.gentoo.org/app-emulation/ski/ski-1.3.2-r1.ebuild?rev=1.1
Comment 3 SpanKY gentoo-dev 2014-11-05 16:11:58 UTC
Commit message: Depend on libltdl rather than libtool
http://sources.gentoo.org/dev-libs/libp11/libp11-0.2.8.ebuild?r1=1.13&r2=1.14
Comment 4 SpanKY gentoo-dev 2014-11-05 16:12:14 UTC
Commit message: Depend on libltdl rather than libtool
http://sources.gentoo.org/dev-libs/openct/openct-0.6.20-r4.ebuild?rev=1.1
Comment 5 SpanKY gentoo-dev 2014-11-05 16:13:30 UTC
Commit message: Depend on libltdl rather than libtool
http://sources.gentoo.org/dev-libs/opensc/opensc-0.12.2-r2.ebuild?r1=1.8&r2=1.9
Comment 9 Nikoli 2014-11-05 18:02:25 UTC
Are you sure about 'dev-libs/libltdl'? May be it should be 'dev-libs/libltdl:0'?
Comment 10 Arfrever Frehtes Taifersar Arahesis 2014-11-05 19:38:57 UTC
Vapier: You changed many stable ebuilds to unconditionally depend on dev-libs/libltdl, which currently has 3 versions:
1.3.5     SLOT="1.3"    stable keywords
1.5.26    SLOT="1.5"    stable keywords
2.4.3     SLOT="0"      unstable keywords

This change results in forcing stable users to install old dev-libs/libltdl-1.5.26, which does not provide headers (/usr/include/ltdl.h, /usr/include/libltdl/*).

Potential solutions:
- Fast stabilization of dev-libs/libltdl-2.4.3 and sys-devel/libtool-2.4.3-r2
- Changing of dependencies to e.g. "|| ( dev-libs/libltdl:0 sys-devel/libtool:2 )"
- Addition of stable dev-libs/libltdl-2.4.2 and sys-devel/libtool-2.4.2-r2
Comment 11 Oleh 2014-11-05 19:54:58 UTC
maybe virtuals can be  possible solution?
Comment 12 Pacho Ramos gentoo-dev 2014-11-05 23:09:43 UTC
(In reply to SpanKY from comment #1)

Yeah, the three bugs I opened are the ones affected by latest libtool losing its multilib support in favor of libltdl ebuilds and needing faster action then. About the rest I don't know much as I am not familiar at all with libtool/libltdl :(
Comment 13 SpanKY gentoo-dev 2014-11-06 05:27:15 UTC
(In reply to Nikoli from comment #9)

yeah, it probably should be requiring SLOT 0

(In reply to Arfrever Frehtes Taifersar Arahesis from comment #10)

hmm, that is a bit of a cock up
Comment 14 SpanKY gentoo-dev 2014-11-06 05:28:59 UTC
Commit message: Require libltdl:0 specifically
http://sources.gentoo.org/app-emulation/ski/ski-1.3.2-r1.ebuild?r1=1.1&r2=1.2
Comment 15 SpanKY gentoo-dev 2014-11-06 05:36:49 UTC
Commit message: Require libltdl:0 specifically, and allow older libtool for stable ebuilds
http://sources.gentoo.org/dev-libs/libp11/libp11-0.2.8.ebuild?r1=1.14&r2=1.15
Comment 16 SpanKY gentoo-dev 2014-11-06 05:36:53 UTC
Commit message: Require libltdl:0 specifically, and allow older libtool for stable ebuilds
http://sources.gentoo.org/dev-libs/openct/openct-0.6.20-r3.ebuild?r1=1.13&r2=1.14
http://sources.gentoo.org/dev-libs/openct/openct-0.6.20-r4.ebuild?r1=1.1&r2=1.2
Comment 17 SpanKY gentoo-dev 2014-11-06 05:38:08 UTC
Commit message: Require libltdl:0 specifically, and allow older libtool for stable ebuilds
http://sources.gentoo.org/dev-libs/opensc/opensc-0.12.2-r2.ebuild?r1=1.9&r2=1.10
Comment 20 SpanKY gentoo-dev 2014-11-06 05:48:32 UTC
(In reply to Pacho Ramos from comment #12)

i think the packages that require multilib USE aren't broken in stable, just unstable atm.  the unstable ebuilds can switch to libltdl:0 now and be fine.  the ones that are mixed stable/unstable will probably have to deploy an || (...) atom until we stabilize libltdl.
Comment 21 SpanKY gentoo-dev 2014-11-06 05:48:54 UTC
Commit message: Depend on libltdl rather than libtool
http://sources.gentoo.org/sys-apps/hwloc/hwloc-1.10.0-r1.ebuild?rev=1.1
Comment 22 SpanKY gentoo-dev 2014-11-06 05:51:48 UTC
Commit message: Depend on libltdl rather than libtool by default
http://sources.gentoo.org/net-mail/mailutils/mailutils-2.99.98.ebuild?r1=1.7&r2=1.8
Comment 23 SpanKY gentoo-dev 2014-11-06 05:54:08 UTC
Commit message: Depend on libltdl rather than libtool by default
http://sources.gentoo.org/games-arcade/emilia-pinball/emilia-pinball-0.3.1-r1.ebuild?r1=1.8&r2=1.9
Comment 24 SpanKY gentoo-dev 2014-11-06 05:54:12 UTC
Commit message: Depend on libltdl rather than libtool
http://sources.gentoo.org/games-strategy/freeciv/freeciv-2.4.3.ebuild?r1=1.2&r2=1.3
Comment 26 tman 2014-11-06 08:29:06 UTC
i still have problem with this packages:

    >=sys-devel/libtool-2.4.2 required by (media-sound/pulseaudio-5.0-r3:0/0::gentoo, installed)
    sys-devel/libtool required by (media-libs/libdca-0.0.5-r3:0/0::gentoo, installed)

  (dev-libs/libltdl-2.4.3:0/0::gentoo, installed) pulled in by
    dev-libs/libltdl:0 required by (dev-libs/redland-1.0.17-r1:0/0::gentoo, ebuild scheduled for merge)
    dev-libs/libltdl:0 required by (media-gfx/imagemagick-6.8.9.9:0/6.8.9.9::gentoo, ebuild scheduled for merge)

system updated
Comment 27 Pacho Ramos gentoo-dev 2014-11-06 08:54:14 UTC
(In reply to SpanKY from comment #20)

Yeah, || () will be enough for them to require either new libltdl or older libtool. 

Thanks a lot for taking care of the other reverse deps :), but maybe for next time would be better to give us a bit of time before doing the change to allow us to adapt ebuilds (probably opening a tracker and giving us a week or so to fix things... anyway for this kind of changes in dependencies I don't think people would complaint, then, we would either fix them ourselves or, for cases whose people don't respond in that timeout, I guess they wouldn't have problems on others committing the updated deps ;))
Comment 28 Jeroen Roovers (RETIRED) gentoo-dev 2014-11-06 10:04:47 UTC
*** Bug 528346 has been marked as a duplicate of this bug. ***
Comment 29 Ian Stakenvicius (RETIRED) gentoo-dev 2014-11-06 19:23:16 UTC
(In reply to tman from comment #26)
> i still have problem with this packages:
> 
>     >=sys-devel/libtool-2.4.2 required by
> (media-sound/pulseaudio-5.0-r3:0/0::gentoo, installed)
>     sys-devel/libtool required by (media-libs/libdca-0.0.5-r3:0/0::gentoo,
> installed)
> 
>   (dev-libs/libltdl-2.4.3:0/0::gentoo, installed) pulled in by
>     dev-libs/libltdl:0 required by (dev-libs/redland-1.0.17-r1:0/0::gentoo,
> ebuild scheduled for merge)
>     dev-libs/libltdl:0 required by
> (media-gfx/imagemagick-6.8.9.9:0/6.8.9.9::gentoo, ebuild scheduled for merge)
> 
> system updated


I just fixed pulseaudio.
Comment 30 David Flogeras 2015-01-25 16:06:13 UTC
*** Bug 537446 has been marked as a duplicate of this bug. ***
Comment 31 Lars Wendler (Polynomial-C) gentoo-dev 2016-12-09 14:48:11 UTC
All done here...