Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 525182 - net-libs/gnutls-3.2.x: add multilib support
Summary: net-libs/gnutls-3.2.x: add multilib support
Status: RESOLVED WONTFIX
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Crypto team [DISABLED]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 492522 multilib-stable
  Show dependency tree
 
Reported: 2014-10-12 18:53 UTC by Francisco Blas Izquierdo Riera
Modified: 2014-10-18 23:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Ebuild providing multilib support for 3.2.18 (gnutls-3.2.18-r1.ebuild,4.52 KB, text/plain)
2014-10-12 18:57 UTC, Francisco Blas Izquierdo Riera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco Blas Izquierdo Riera gentoo-dev 2014-10-12 18:53:10 UTC
There is no support for multilib builds on stable branches of gnutls (this is 3.2.x). Since stabilization of 3.3.x is unclear for now the multilib support should be backported.

Reproducible: Always
Comment 1 Francisco Blas Izquierdo Riera gentoo-dev 2014-10-12 18:57:45 UTC
Created attachment 386542 [details]
Ebuild providing multilib support for 3.2.18

I wrote this ebuild to add multilib by backporting the multilib additions from gnutls-3.3.6

Since I couldn't get gnutls to compile when using ECONF_SOURCE I'm using multilib_copy_sources instead.
Comment 2 Francisco Blas Izquierdo Riera gentoo-dev 2014-10-13 12:07:24 UTC
If the stabilization target for gnutls ends up being 3.3.8 this will not be necessary. See https://bugs.gentoo.org/show_bug.cgi?id=492522
Comment 3 Alon Bar-Lev gentoo-dev 2014-10-13 12:52:13 UTC
(In reply to Francisco Blas Izquierdo Riera from comment #2)
> If the stabilization target for gnutls ends up being 3.3.8 this will not be
> necessary. See https://bugs.gentoo.org/show_bug.cgi?id=492522

I agree.