Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 523532 - =sys-apps/portage-2.2.13 - TypeError: unsupported operand type(s) for +=: 'object' and 'int'
Summary: =sys-apps/portage-2.2.13 - TypeError: unsupported operand type(s) for +=: 'ob...
Status: RESOLVED FIXED
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Portage team
URL:
Whiteboard:
Keywords: InVCS, REGRESSION
: 523704 (view as bug list)
Depends on:
Blocks: 484436
  Show dependency tree
 
Reported: 2014-09-23 15:49 UTC by Bertrand Jacquin
Modified: 2014-09-26 19:21 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info (info.log,18.37 KB, text/plain)
2014-09-23 15:50 UTC, Bertrand Jacquin
Details
emerge -pvtDd dev-lang/perl output (portage-2.2.13+debug.log.xz,71.80 KB, application/x-xz)
2014-09-23 15:51 UTC, Bertrand Jacquin
Details
portage-2.2.13+debug.log.xz (portage-2.2.13+debug.log.xz,73.39 KB, application/x-xz)
2014-09-23 15:53 UTC, Bertrand Jacquin
Details
_want_update_pkg: fix bug #523532 (_want_update_pkg-fix-bug-523532.patch,979 bytes, patch)
2014-09-24 02:34 UTC, Zac Medico
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bertrand Jacquin 2014-09-23 15:49:53 UTC
# emerge -pvt dev-lang/perl

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.3/emerge", line 51, in <module>
    retval = emerge_main()
  File "/usr/lib64/python3.3/site-packages/_emerge/main.py", line 1057, in emerge_main
    return run_action(emerge_config)
  File "/usr/lib64/python3.3/site-packages/_emerge/actions.py", line 4069, in run_action
    emerge_config.args, spinner)
  File "/usr/lib64/python3.3/site-packages/_emerge/actions.py", line 320, in action_build
    settings, trees, myopts, myparams, myaction, myfiles, spinner)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 8564, in backtrack_depgraph
    myaction, myfiles, spinner)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 8596, in _backtrack_depgraph
    success, favorites = mydepgraph.select_files(myfiles)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3237, in select_files
    return self._select_files(args)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3573, in _select_files
    return self._resolve(myfavorites)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 3728, in _resolve
    self.altlist()
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 6380, in altlist
    self._serialize_tasks()
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 6631, in _serialize_tasks
    parent=running_portage, strict=False)
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 4012, in _select_atoms_highest_available
    myroot=root, trees=trees)
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 667, in dep_check
    use_binaries=use_binaries, trees=trees)
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 266, in dep_zapdeps
    use_binaries=use_binaries, trees=trees)
  File "/usr/lib64/python3.3/site-packages/portage/dep/dep_check.py", line 477, in dep_zapdeps
    if not want_update_pkg(parent, avail_pkg):
  File "/usr/lib64/python3.3/site-packages/_emerge/depgraph.py", line 4924, in _want_update_pkg
    depth += 1
TypeError: unsupported operand type(s) for +=: 'object' and 'int'

Full emerge -pvtDd and emerge --info attached

Reproducible: Always
Comment 1 Bertrand Jacquin 2014-09-23 15:50:41 UTC
Created attachment 385330 [details]
emerge --info
Comment 2 Bertrand Jacquin 2014-09-23 15:51:20 UTC
Created attachment 385332 [details]
emerge -pvtDd dev-lang/perl output
Comment 3 Bertrand Jacquin 2014-09-23 15:53:11 UTC
Created attachment 385334 [details]
portage-2.2.13+debug.log.xz

Previous file was wrong
Comment 4 Zac Medico gentoo-dev 2014-09-24 02:34:38 UTC
Created attachment 385366 [details, diff]
_want_update_pkg: fix bug #523532

This fixes depth increment to handle _UNREACHABLE_DEPTH. Note that there are some remaining "depth + 1" expressions that are protected by short circuit evaluation (when deep is True).

I'll be maintaining this patch in the following branch:

	https://github.com/zmedico/portage/tree/bug_523532
Comment 5 Bertrand Jacquin 2014-09-24 09:12:26 UTC
(In reply to Zac Medico from comment #4)
> Created attachment 385366 [details, diff] [details, diff]
> _want_update_pkg: fix bug #523532
> 
> This fixes depth increment to handle _UNREACHABLE_DEPTH. Note that there are
> some remaining "depth + 1" expressions that are protected by short circuit
> evaluation (when deep is True).
> 
> I'll be maintaining this patch in the following branch:
> 
> 	https://github.com/zmedico/portage/tree/bug_523532

Hi Zac, happy to see you again there :)

I tested the patch, I now have no python backtrace, but get another issue :

# emerge -pvtD perl
These are the packages that would be merged, in reverse order:
Calculating dependencies... done!
[ebuild   R    ] dev-lang/perl-5.18.2-r1:0/5.18  USE="-berkdb -debug -doc -gdbm -ithreads" 0 KiB
Total: 1 package (1 reinstall), Size of downloads: 0 KiB
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:
dev-lang/perl:0
  (dev-lang/perl-5.20.1:0/5.20::gentoo, ebuild scheduled for merge) conflicts with
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/URI-1.600.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/DBI-1.628.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/Digest-SHA-5.850.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Text-CSV_XS-0.950.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    =dev-lang/perl-5.18* required by (virtual/perl-IO-1.280.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/Storable-2.450.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/Scalar-List-Utils-1.350.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/libwww-perl-6.50.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Unicode-Map-0.112.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    =dev-lang/perl-5.18* required by (virtual/perl-File-Spec-3.400.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2:0/0::gentoo, installed)
                 ^^^^^^^^           
    >=dev-lang/perl-5.8.8:0/5.18= required by (media-gfx/imagemagick-6.8.9.7:0/6.8.9.7::gentoo, installed)
                         ^^^^^^^^
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Message-6.60.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18= required by (media-libs/ming-0.4.5:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/libintl-perl-1.230.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/IO-HTML-1.00.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18= required by (net-print/cups-filters-1.0.54:0/0::gentoo, installed)
                 ^^^^^^^^
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/DBD-SQLite-1.400.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/GD-2.500.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-MimeInfo-0.210.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Error-0.170.210:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Jcode-2.70.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.967.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Digest-Perl-MD5-1.800.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    =dev-lang/perl-5.18* required by (virtual/perl-Compress-Raw-Zlib-2.60.0-r2:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.40.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/TermReadKey-2.300.200-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-vcs/git-2.1.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/Encode-2.550.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.10.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/IO-stringy-2.110.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Crypt-RC4-2.020.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Algorithm-Diff-1.190.200-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Encode-Locale-1.30.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/libnet-1.270.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Net-SSLeay-1.650.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (net-analyzer/net-snmp-5.7.3_pre5-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Text-Unidecode-0.40.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/Spreadsheet-ParseExcel-0.590.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           
    =dev-lang/perl-5.18* required by (virtual/perl-IO-Compress-2.60.0-r1:0/0::gentoo, installed)
    ^              ^^^^^
    dev-lang/perl:0/5.18=[-build(-)] required by (dev-perl/OLE-StorageLite-0.190.0-r1:0/0::gentoo, installed)
                 ^^^^^^^^           

While I have no issue running 'emerge world -pvtuDN'
Comment 6 Zac Medico gentoo-dev 2014-09-24 15:42:46 UTC
(In reply to Bertrand Jacquin from comment #5)
> Hi Zac, happy to see you again there :)

Thanks :)

> I tested the patch, I now have no python backtrace, but get another issue :

Great, thanks for testing.

> # emerge -pvtD perl
> These are the packages that would be merged, in reverse order:
> Calculating dependencies... done!
> [ebuild   R    ] dev-lang/perl-5.18.2-r1:0/5.18  USE="-berkdb -debug -doc
> -gdbm -ithreads" 0 KiB
> Total: 1 package (1 reinstall), Size of downloads: 0 KiB
> WARNING: One or more updates/rebuilds have been skipped due to a dependency
> conflict:
> dev-lang/perl:0

That sort of conflict is expected for this kind of update, since there are typically some reversed dependencies that need to be updated in order for those conflicts to be solved. This is confirmed by the fact that your world update command succeeds.

> While I have no issue running 'emerge world -pvtuDN'
Comment 8 Bertrand Jacquin 2014-09-24 21:39:37 UTC
(In reply to Zac Medico from comment #7)
> This is in git now:
> 
> https://github.com/gentoo/portage/commit/
> d7f7112b410bfead272f3d07829efc8fa80c4023

Thank you !
Comment 9 Brian Evans Gentoo Infrastructure gentoo-dev 2014-09-25 14:47:28 UTC
*** Bug 523704 has been marked as a duplicate of this bug. ***
Comment 10 RedEyedMan 2014-09-26 16:25:18 UTC
(In reply to Bertrand Jacquin from comment #8)
> (In reply to Zac Medico from comment #7)
> > This is in git now:
> > 
> > https://github.com/gentoo/portage/commit/
> > d7f7112b410bfead272f3d07829efc8fa80c4023
> 
> Thank you !

I confirm that bug. Doing downgrade until fix will released
Comment 11 Brian Dolbec gentoo-dev 2014-09-26 19:21:55 UTC
Released in portage-2.2.14_rc1