Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 523158 - =x11-misc/xxkb-1.11-r3 stable request
Summary: =x11-misc/xxkb-1.11-r3 stable request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Desktop Misc. Team
URL:
Whiteboard:
Keywords: STABLEREQ
: 525018 (view as bug list)
Depends on: 496116 523360 527728
Blocks: EAPI1Removal
  Show dependency tree
 
Reported: 2014-09-18 18:43 UTC by Jeroen Roovers
Modified: 2015-02-20 09:35 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeroen Roovers gentoo-dev 2014-09-18 18:43:49 UTC
Arch teams, please test and mark stable:
=x11-misc/xxkb-1.11-r3
Targeted stable KEYWORDS : amd64 ppc x86
Comment 1 Alex Efros 2014-09-21 08:50:51 UTC
This change http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-misc/xxkb/files/svg-appdefaults.patch?r1=1.1&r2=1.2 broke both ARCH 1.11-r2 and ~ARCH 1.11-r3 (with USE=svg) - they now fail with:

 * Applying svg-appdefaults.patch ...

 * Failed Patch: svg-appdefaults.patch !
 *  ( /usr/portage/x11-misc/xxkb/files/svg-appdefaults.patch )

because there are no XXkb.ad file in sources.


But, even after fixing that patch (by naming file XXkb.ad.var) 1.11-r3 (and -r2 too) still fail to build, now with:

>>> Source compiled.
>>> Test phase [not enabled]: x11-misc/xxkb-1.11-r3

>>> Install xxkb-1.11-r3 into /var/tmp/portage/x11-misc/xxkb-1.11-r3/image/ category x11-misc
make -j8 'PIXMAPS=flags/de.svg flags/pl.svg flags/il.svg flags/by.svg 		flags/ua.svg flags/su.svg flags/ru.svg flags/bg.svg flags/en.svg' DESTDIR=/var/tmp/portage/x11-misc/xxkb-1.11-r3/image/ install 
make: *** No rule to make target `flags/de.svg'.  Stop.

This is because of change http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/x11-misc/xxkb/files/svg-flags.patch?r1=1.1&r2=1.2 - this patch now create *.svg files in a/flags/ directory instead of flags/.
Comment 2 Jeroen Roovers gentoo-dev 2014-09-21 09:26:54 UTC
(In reply to Alex Efros from comment #1)

Please file a new bug report.
Comment 3 Jeroen Roovers gentoo-dev 2014-09-21 09:34:52 UTC
> (In reply to Alex Efros from comment #1)

  21 Sep 2014; Jeroen Roovers <jer@gentoo.org> files/svg-appdefaults.patch:
  Fix patch cleanup (Alex Efros).
Comment 4 Manuel Rüger (RETIRED) gentoo-dev 2014-10-14 23:18:53 UTC
*** Bug 525018 has been marked as a duplicate of this bug. ***
Comment 5 Chema Alonso Josa (RETIRED) gentoo-dev 2014-10-31 15:47:21 UTC
amd64 stable
Comment 6 Manuel Rüger (RETIRED) gentoo-dev 2015-02-10 18:06:51 UTC
@ppc, x86: ping?
Comment 7 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-02-20 09:35:44 UTC
All done.