Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522878 - x11-base/xorg-drivers - replace video_cards_intel with video_cards_i915 and video_cards_i965 for x11-drivers/xf86-video-intel
Summary: x11-base/xorg-drivers - replace video_cards_intel with video_cards_i915 and v...
Status: RESOLVED DUPLICATE of bug 431794
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo X packagers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-15 14:33 UTC by charles17
Modified: 2014-09-15 21:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description charles17 2014-09-15 14:33:19 UTC
When /etc/portage/make.conf has either of VIDEO_CARDS=i915 or VIDEO_CARDS=i965,
x11-base/xorg-drivers should pull in x11-drivers/xf86-video-intel

This way, the same VIDEO_CARDS=  value will apply for x11-base/xorg-drivers as it does for media-libs/mesa.

And it would cause much less confusion for noobs not having to put two values into VIDEO_CARDS=
Comment 1 Chí-Thanh Christopher Nguyễn gentoo-dev 2014-09-15 15:29:50 UTC
i915 and i965 are only flags for mesa, in order to allow more fine-grained control over which drivers to build. They are meant to be specified in addition to intel, not as a replacement.
Comment 2 Rémi Cardona gentoo-dev 2014-09-15 19:18:18 UTC
The one USE flag to control support for _ALL_ Intel GPUs is VIDEO_CARDS=intel. Some ebuilds offer finer grained support, such as mesa.

IMHO, if we were to "clean up" Intel-related USE flags, I would remove all USE flags and just keep "intel". But right now, we have no such plan.

VIDEO_CARDS=intel is the way to go

*** This bug has been marked as a duplicate of bug 431794 ***