Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 522028 - sys-libs/glibc-2.19-r1 - Your old kernel is broken. You need to update it to a newer version as syscall(<bignum>) will break.
Summary: sys-libs/glibc-2.19-r1 - Your old kernel is broken. You need to update it to...
Status: RESOLVED DUPLICATE of bug 513308
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Toolchain Maintainers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-09-03 08:34 UTC by Hiroshi Takenaka
Modified: 2014-09-09 17:10 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
build log (20140904_glibc-build.log,1.33 KB, text/plain)
2014-09-03 08:34 UTC, Hiroshi Takenaka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hiroshi Takenaka 2014-09-03 08:34:52 UTC
Created attachment 384148 [details]
build log

While world update, emergeing sys-libs/glibc failed.

The build log is saying:
 * Your old kernel is broken.  You need to update it to
 * a newer version as syscall(<bignum>) will break.
 * http://bugs.gentoo.org/279260
 * ERROR: sys-libs/glibc-2.19-r1::gentoo failed (setup phase):
 *   keeping your system alive, say thank you

I took a look in the bug mentioned above, however,
it is a very old log in 2009.

emerge --info is:
---
Portage 2.2.8-r1 (default/linux/x86/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.14.14-gentoo i686)
=================================================================
System uname: Linux-3.14.14-gentoo-i686-Intel-R-_Celeron-R-_CPU_450_@_2.20GHz-with-gentoo-2.2
KiB Mem:     1679732 total,    114200 free
KiB Swap:     524284 total,    524284 free
Timestamp of tree: Tue, 02 Sep 2014 06:15:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.6, 3.3.3
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://ftp.jaist.ac.jp/pub/Linux/Gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync3.jp.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa avahi berkdb bluetooth branding bzip2 cairo cdda cddb cjk cli consolekit cracklib crypt cups cxx dbus dri dts dvd emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv icu inotify ipv6 jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support readline samba sdl session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vnc vorbis wxwidgets x264 x86 xcb xml xv xvid zeroconf zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="vmware" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

emerge -pqv sys-libs/glibc is:
---
[ebuild     U ] sys-libs/glibc-2.19-r1 [2.17] USE="-debug -gd (-hardened) (-multilib) -nscd -profile (-selinux) -suid -systemtap -vanilla" 

The complete build log is attached.
Comment 1 Lars Wendler (Polynomial-C) gentoo-dev 2014-09-03 08:49:43 UTC
Did you read comment 58 and following in the aforementioned bug? https://bugs.gentoo.org/279260#c58

Seems like there's a similar problem in later kernels. Please try vanilla kernel-3.14.17 (dunno if that version already has the fix) or kernel-3.15.8 (that version definitely has the fix according to comment 59 in the ther bug).
Comment 2 Hiroshi Takenaka 2014-09-03 12:14:37 UTC
I'm sorry I didn't notice;
https://bugs.gentoo.org/279260#c58

I have updated the kernel to 3.14.16-gentoo.
With this kernel, I can emerge sys-libs/glibc-2.19-r1.

Thank you.
Comment 3 SpanKY gentoo-dev 2014-09-09 17:10:25 UTC

*** This bug has been marked as a duplicate of bug 513308 ***