Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 521884 - net-analyzer/nikto-2.1.5 with net-libs/libwhisker-2.5 - file collision in /usr/lib64/perl5/vendor_perl/5.18.2/LW2.pm
Summary: net-analyzer/nikto-2.1.5 with net-libs/libwhisker-2.5 - file collision in /us...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Patrice Clement
URL:
Whiteboard:
Keywords:
: 527920 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-09-01 11:44 UTC by Melendro
Modified: 2014-11-09 01:39 UTC (History)
8 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
nikto-2.1.5.ebuild.patch (nikto-2.1.5.ebuild.patch,686 bytes, patch)
2014-11-06 14:37 UTC, Patrice Clement
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Melendro 2014-09-01 11:44:49 UTC
The file "/usr/lib64/perl5/vendor_perl/5.18.2/LW2.pm" is provided by two packages: net-analyzer/nikto-2.1.5 and net-libs/libwhisker-2.5.

This file is the only file provided by libwhisker, and also libwhisker is pulled in only by nikto (at least in my box), so probably the best solution is to removed the dependency in nikto-2.1.5, or maybe remove the LW2.pm file from nikto-2.1.5.
Comment 1 mAhdi 2014-09-04 18:58:52 UTC
Same here for x86

 * Detected file collision(s):
 * 
 * 	/usr/lib/perl5/vendor_perl/5.16.3/LW2.pm
 * 
 * Searching all installed packages for file collisions...
 * 
 * Press Ctrl-C to Stop
 * 
 * net-libs/libwhisker-2.5:0::gentoo
 * 	/usr/lib/perl5/vendor_perl/5.16.3/LW2.pm
Comment 2 Zentoo 2014-09-29 05:48:04 UTC
I confirm the problem too:

both packages net-analyzer/nikto-2.1.5 and net-libs/libwhisker-2.5 provides the same file: /usr/lib64/perl5/vendor_perl/5.18.2/LW2.pm
Comment 3 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2014-11-02 18:28:38 UTC
*** Bug 527920 has been marked as a duplicate of this bug. ***
Comment 4 Patrice Clement gentoo-dev 2014-11-06 14:37:28 UTC
Created attachment 388668 [details, diff]
nikto-2.1.5.ebuild.patch

Here's my patch. I'm at work at the moment so I'll push the changes tonight. Basically, as it stands, portage creates a symlink from a list of .pm files. I´ve simply removed LW2.pm from that list to mend the collision problem.
Comment 5 Patrice Clement gentoo-dev 2014-11-09 01:39:09 UTC
--- ./ChangeLog
+++ ./ChangeLog
@@ -4,0 +5,3 @@
+  09 Nov 2014; Patrice Clement <monsieurp@gentoo.org> nikto-2.1.5.ebuild:
+  Removing LW2.pm from modules list. See #521884.
+