Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 521484 - app-text/calibre-2.* unmask
Summary: app-text/calibre-2.* unmask
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal with 3 votes (vote)
Assignee: Ian Stakenvicius (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on: qt5-porting 477484
Blocks:
  Show dependency tree
 
Reported: 2014-08-29 08:15 UTC by Kalisox
Modified: 2015-02-02 15:21 UTC (History)
20 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Verstion bump to 2.4.0 (calibre-2.4.0.ebuild,7.45 KB, text/plain)
2014-10-04 09:18 UTC, Stefan Radermacher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kalisox 2014-08-29 08:15:27 UTC
http://calibre-ebook.com/whats-new

That needs qt5, i don't know what is gentoo plan about it.

Reproducible: Always
Comment 1 Ian Stakenvicius (RETIRED) gentoo-dev 2014-09-02 21:12:49 UTC
QT5 will enter the tree sometime in the future, not sure when.  I'll eventually add a p.masked ebuild to support those users that have the qt5 overlay installed.
Comment 2 Kalisox 2014-09-20 06:06:26 UTC
qt5 is there masked now
Comment 3 Andreas Klauer 2014-09-20 20:54:19 UTC
more specifically, it needs PyQt5, so it probably also depends on Bug #477484?
Comment 4 Stefan Radermacher 2014-10-04 09:18:39 UTC
Created attachment 386028 [details]
Verstion bump to 2.4.0

Here's an app-text/calibre-2.4.0.ebuild for Calibre 2.4.0.

You will need my ebuild  for PyQt5 version 5.3.2 from Bug #477484 before you emerge this.
Comment 5 Stefan Radermacher 2014-10-05 05:59:04 UTC
For Calibre 2.5.0, just rename the attached ebuild to app-text/calibre-2.5.0.ebuild.
Comment 6 Ian Stakenvicius (RETIRED) gentoo-dev 2014-10-06 18:01:15 UTC
I'm working on getting qt5 installed on my development system, once i cna test this i'll commit it (masked) in the tree and i'll be sure to unmask it alongside the qt5 unmasking

Please feel free to keep updating the attachments here in the meantime, if applicable!
Comment 7 Manuel Rüger (RETIRED) gentoo-dev 2014-10-20 23:07:40 UTC
pyqt5 is available in the tree now.
Comment 8 Stefan Radermacher 2014-10-24 10:48:24 UTC
Using the PyQt5 from the tree you will have to remove the X use flag from this COMMON_DEPENDS entry:

>=dev-python/PyQt5-5.2.0[X,svg,webkit,widgets,python_targets_python2_7(-)]

However, I'm getting errors when trying to compile Calibre, it tries to import QWebView and QWebPage from PyQt5 and fails, both bindings are in the QWebKitWidgts module
Comment 9 Ian Stakenvicius (RETIRED) gentoo-dev 2014-10-24 14:51:45 UTC
(In reply to Stefan Radermacher from comment #8)
> Using the PyQt5 from the tree you will have to remove the X use flag from
> this COMMON_DEPENDS entry:
> 
> >=dev-python/PyQt5-5.2.0[X,svg,webkit,widgets,python_targets_python2_7(-)]
> 
> However, I'm getting errors when trying to compile Calibre, it tries to
> import QWebView and QWebPage from PyQt5 and fails, both bindings are in the
> QWebKitWidgts module

More than that, actually -- USE="X" on PyQt4 controlled QtGui, this is USE="gui" in the PyQt5 package in portage.

I too am getting build failures on PyQt5, although mine is related to qtprinter.h not being found (regardless of USE="printsupport" on that package).  So that's the blocker for me right now, if i can sort that out today then i should be able to commit this to the tree.
Comment 10 Ian Stakenvicius (RETIRED) gentoo-dev 2014-10-24 20:56:18 UTC
app-text/calibre-2.7.0 is now committed to the tree, p.masked alongside the rest of the QT5 packages.  I have only tested this with the in-tree QT5 packages, I do not know if it works or builds against those in the qt5 overlay.

leaving bug open until package can be unmasked.
Comment 11 Ben de Groot (RETIRED) gentoo-dev 2014-10-27 13:58:30 UTC
(In reply to Ian Stakenvicius from comment #10)
> app-text/calibre-2.7.0 is now committed to the tree, p.masked alongside the
> rest of the QT5 packages.  I have only tested this with the in-tree QT5
> packages, I do not know if it works or builds against those in the qt5
> overlay.

Building against the 5.4.0_beta in qt overlay, it ultimately fails with:


Setting up command-line completion...
Installing bash completion to: /var/tmp/portage/app-text/calibre-2.7.0/image/usr/share/bash-completion/completions/calibre
Setting up desktop integration...
xdg-icon-resource: icon name 'calibre-gui' does not have a proper vendor prefix
A vendor prefix consists of alpha characters ([a-zA-Z]) and is terminated
with a dash ("-"). An example icon name is 'example-calibre-gui'
Use --novendor to override or 'xdg-icon-resource --manual' for additional info.

____________________ WARNING ____________________
Setting up desktop integration failed with error:
__________________________________________________
        Traceback (most recent call last):
          File "/var/tmp/portage/app-text/calibre-2.7.0/work/calibre-2.7.0/src/calibre/linux.py", line 798, in setup_desktop_integration
            cc('xdg-icon-resource install --mode user --noupdate --size 256 calibre-gui.png calibre-gui', shell=True)
          File "/usr/lib64/python2.7/subprocess.py", line 540, in check_call
            raise CalledProcessError(retcode, cmd)
        CalledProcessError: Command 'xdg-icon-resource install --mode user --noupdate --size 256 calibre-gui.png calibre-gui' returned non-zero exit status 1

Creating un-installer: /var/tmp/portage/app-text/calibre-2.7.0/image/usr/bin/calibre-uninstall
Installing calibre environment module: /var/tmp/portage/app-text/calibre-2.7.0/image/usr/lib64/python2.7/site-packages/init_calibre.py


calibre successfully installed. You can start it by running the command calibre

There were 1 warning(s):

* Setting up desktop integration failed with error:

mv: cannot stat ‘/var/tmp/portage/app-text/calibre-2.7.0/temp/fake_homedir/.local/share/mime/packages/*’: No such file or directory
 * ERROR: app-text/calibre-2.7.0::gentoo failed (install phase):
 *   failed to register mime types
 * 
 * Call stack:
 *     ebuild.sh, line  93:  Called src_install
 *   environment, line 2125:  Called die
 * The specific snippet of code:
 *       mv "${HOME}"/.local/share/mime/packages/* "${ED}"usr/share/mime/packages/ || die "failed to register mime types";
Comment 12 Ian Stakenvicius (RETIRED) gentoo-dev 2014-10-27 14:39:51 UTC
(In reply to Ben de Groot from comment #11)
> Setting up desktop integration...
> xdg-icon-resource: icon name 'calibre-gui' does not have a proper vendor
> prefix
> A vendor prefix consists of alpha characters ([a-zA-Z]) and is terminated
> with a dash ("-"). An example icon name is 'example-calibre-gui'
> Use --novendor to override or 'xdg-icon-resource --manual' for additional
> info.
> 

..so this looks like it's the actual failure point.  I don't see this error, which seems odd as the failure looks to be xdg related rather than python or calibre related.  I'll look into it; i'm not running full ~arch so maybe there's some additional strictness in the newer xdg-* packages....



The error below is essentially the catchall for any error that occurred earlier -- the mime files aren't created unless "setup.py install" finishes successfully:

> * Setting up desktop integration failed with error:
> 
> mv: cannot stat
> ‘/var/tmp/portage/app-text/calibre-2.7.0/temp/fake_homedir/.local/share/mime/
> packages/*’: No such file or directory
>  * ERROR: app-text/calibre-2.7.0::gentoo failed (install phase):
>  *   failed to register mime types
>  * 
>  * Call stack:
>  *     ebuild.sh, line  93:  Called src_install
>  *   environment, line 2125:  Called die
>  * The specific snippet of code:
>  *       mv "${HOME}"/.local/share/mime/packages/*
> "${ED}"usr/share/mime/packages/ || die "failed to register mime types";
Comment 13 Dennis Schridde 2014-11-09 10:57:24 UTC
Version 2.9 was released on Friday.
Comment 14 Ben de Groot (RETIRED) gentoo-dev 2014-11-09 13:19:57 UTC
I've bumped to 2.9.0 and fixed the failure I reported before.
Comment 15 Manuel Rüger (RETIRED) gentoo-dev 2014-12-08 22:22:09 UTC
2.12 is out since a while. Possible to bump or should I create a new bug?
Comment 16 Ian Stakenvicius (RETIRED) gentoo-dev 2014-12-09 16:25:04 UTC
Just bumped it.
Comment 17 Ben de Groot (RETIRED) gentoo-dev 2015-02-02 15:21:17 UTC
Unmasked together with Qt5.