Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 520698 - app-office/libreoffice-4.2.6.2 should depend on dev-perl/Archive-Zip-1.300.0-r1 - configure: error: The missing Perl modules are: Archive::Zip
Summary: app-office/libreoffice-4.2.6.2 should depend on dev-perl/Archive-Zip-1.300.0-...
Status: RESOLVED DUPLICATE of bug 41124
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-08-23 13:50 UTC by Joakim Tjernlund
Modified: 2014-08-23 13:54 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joakim Tjernlund 2014-08-23 13:50:39 UTC
trying to build libreoffice 4.2.6.2:
 
 * Package:    app-office/libreoffice-4.2.6.2
 * Repository: gentoo
 * Maintainer: openoffice@gentoo.org
 * USE:        abi_x86_64 amd64 bluetooth branding cups dbus elibc_glibc gtk kernel_linux opengl python_single_target_python2_7 python_targets_python2_7 python_targets_python3_3 userland_GNU vba webdav
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Checking for at least 512 MiB RAM ...
 [ ok ]
 * Checking for at least 6 GiB disk space at "/var/tmp/portage/app-office/libreoffice-4.2.6.2/temp" ...
 [ ok ]
 * Applying libreoffice-3.7-system-pyuno.patch ...
 [ ok ]
 * Applying libreoffice-4.2.0.4-curl-config.patch ...
 [ ok ]
 * Running eautoreconf in '/var/tmp/portage/app-office/libreoffice-4.2.6.2/work/libreoffice-4.2.6.2' ...
 * Running aclocal -I m4 ...
 [ ok ]
 * Running autoconf -I m4 ...
 [ ok ]
 * Running autoheader -I m4 ...
 [ !! ]
 * Running elibtoolize in: libreoffice-4.2.6.2/
‘/var/tmp/portage/app-office/libreoffice-4.2.6.2/work/branding-intro.png’ -> ‘/var/tmp/portage/app-office/libreoffice-4.2.6.2/work/libreoffice-4.2.6.2/icon-themes/galaxy/brand/intro.png’
********************************************************************
*
*   Running LibreOffice build configuration.
*
********************************************************************

checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking for product name... LibreOffice
checking for product version... 4.2
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for grep... (cached) /bin/grep
checking for sed... /bin/sed
checking whether build target is Release Build... yes
checking whether to sign windows build... no
checking for gawk... gawk
checking for gawk... /usr/bin/gawk
checking for bash... /bin/sh
checking for GNU or BSD tar... tar
checking for tar's option to strip components... --strip-components
checking how to build and package galleries... internal src images for desktop
checking gcc home... /usr
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for x86_64-pc-linux-gnu-gcc... /usr/bin/x86_64-pc-linux-gnu-gcc
checking whether to use link-time optimization... no
checking whether to build with Java support... no
checking whether to treat the installation as read-only... no
checking whether GCC is actually Clang... no
checking the GCC version... gcc 4.7.3
checking whether x86_64-pc-linux-gnu-gcc supports -ggdb2... yes
checking whether x86_64-pc-linux-gnu-gcc supports -finline-limit=0... yes
checking whether x86_64-pc-linux-gnu-gcc supports -fno-inline... yes
checking for -Bsymbolic-functions linker support ... found 
checking for -isystem ... yes
checking whether to build with additional debug utilities... no
checking whether to do a debug build... no
checking whether to include symbols while preserve optimization... no
checking for explicit AFLAGS... no
checking for explicit CFLAGS... -O2 -pipe -march=native
checking for explicit CXXFLAGS... -O2 -pipe -march=native
checking for explicit OBJCFLAGS... no
checking for explicit OBJCXXFLAGS... no
checking for explicit LDFLAGS... -Wl,-O1 -Wl,--as-needed
checking which package format to use... none
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking syslog.h usability... yes
checking syslog.h presence... yes
checking for syslog.h... yes
checking whether to enable crashdump feature... no
checking whether to turn warnings to errors... no
checking whether to have assert to abort in release code... no
checking whether to use ooenv for the instdir installation... yes
checking whether to enable CUPS support... yes
checking whether cups support is present... checking for cupsPrintFiles in -lcups... yes
checking cups/cups.h usability... yes
checking cups/cups.h presence... yes
checking for cups/cups.h... yes
checking for x86_64-pc-linux-gnu-pkg-config... /usr/bin/x86_64-pc-linux-gnu-pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for FONTCONFIG... yes
checking whether we want to fetch tarballs... no
checking whether to build help... no
checking whether to include MySpell dictionaries... no
checking whether to use dicts from external paths... yes
checking for spelling dictionary directory... file:///usr/share/myspell
checking for hyphenation patterns directory... file:///usr/share/myspell
checking for thesaurus directory... file:///usr/share/myspell
checking whether to enable pch feature... no
checking for GNU make... /usr/bin/make
checking the GNU make version... /usr/bin/make 3.82
checking whether GNU make supports the 'file' function... no
checking for --hash-style gcc linker support ... gnu 
checking for perl... /usr/bin/perl
checking the Perl version... checked (perl 5)
checking for required Perl modules... failed to find some modules
configure: error: 
    The missing Perl modules are: Archive::Zip
    Install them as superuser/administrator with "cpan -i Archive::Zip"

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-office/libreoffice-4.2.6.2/work/libreoffice-4.2.6.2/config.log
 * ERROR: app-office/libreoffice-4.2.6.2::gentoo failed (configure phase):
 *   econf failed
 * 
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 7172:  Called econf '--docdir=/usr/share/doc/libreoffice-4.2.6.2/' '--with-system-headers' '--with-system-libs' '--with-system-jars' '--with-system-dicts' '--enable-cairo-canvas' '--enable-graphite' '--enable-largefile' '--enable-mergelibs' '--enable-python=system' '--enable-randr' '--enable-randr-link' '--enable-release-build' '--disable-hardlink-deliver' '--disable-ccache' '--disable-crashdump' '--disable-dependency-tracking' '--disable-epm' '--disable-fetch-external' '--disable-gnome-vfs' '--disable-gstreamer-0-10' '--disable-report-builder' '--disable-kdeab' '--disable-kde' '--disable-online-update' '--disable-systray' '--with-alloc=system' '--with-build-version=Gentoo official package' '--enable-extension-integration' '--with-external-dict-dir=/usr/share/myspell' '--with-external-hyph-dir=/usr/share/myspell' '--with-external-thes-dir=/usr/share/myspell' '--with-external-tar=/var/tmp/portage/app-office/libreoffice-4.2.6.2/distdir' '--with-lang=' '--with-parallelism=9' '--with-system-ucpp' '--with-vendor=Gentoo Foundation' '--with-x' '--without-afms' '--without-fonts' '--without-myspell-dicts' '--without-help' '--with-helppack-integration' '--without-sun-templates' '--enable-sdremote-bluetooth' '--enable-cups' '--disable-debug' '--enable-dbus' '--disable-evolution2' '--disable-firebird-sdbc' '--disable-gconf' '--disable-gio' '--disable-lockdown' '--disable-gstreamer' '--enable-gtk' '--disable-gtk3' '--disable-kde4' '--disable-ext-mariadb-connector' '--disable-odk' '--enable-opengl' '--disable-postgresql-sdbc' '--disable-telepathy' '--enable-vba' '--disable-vlc' '--enable-neon' '--without-java' '--without-system-mysql-cppconn' '--without-doxygen' '--without-system-sane' '--without-system-vigra' '--disable-ext-nlpsolver' '--disable-scripting-beanshell' '--disable-scripting-javascript' '--disable-ext-wiki-publisher'


However I got dev-perl/Archive-Zip-1.300.0 installed already.
Manually upgrading to dev-perl/Archive-Zip-1.300.0-r1 and remerging libreoffice
makes it pass the configure test.
Comment 1 Jeroen Roovers gentoo-dev 2014-08-23 13:54:24 UTC

*** This bug has been marked as a duplicate of bug 41124 ***