Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 519860 - [qt overlay] dev-qt/qtgui-5.3.1-r1 USE=ibus - In file included from qibusinputcontextproxy.cpp:12:0: qibusinputcontextproxy.h:27:1: error: expected class-name before ‘{’ token
Summary: [qt overlay] dev-qt/qtgui-5.3.1-r1 USE=ibus - In file included from qibusinpu...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qt5-porting
  Show dependency tree
 
Reported: 2014-08-14 02:18 UTC by smelenchuk
Modified: 2014-09-02 03:22 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (qtgui-5.3.1-r1-ibus.build.log,826.89 KB, text/plain)
2014-08-14 02:19 UTC, smelenchuk
Details
emerge --info (emerge-info,19.93 KB, text/plain)
2014-08-14 02:19 UTC, smelenchuk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description smelenchuk 2014-08-14 02:18:53 UTC
Attempting to build dev-qt/qtgui-5.3.1-r1 with USE=ibus fails.

Reproducible: Always

Steps to Reproduce:
1. Attempt to build dev-qt/qtgui with USE=ibus.
Actual Results:  
In file included from qibusinputcontextproxy.cpp:12:0:
qibusinputcontextproxy.h:27:1: error: expected class-name before ‘{’ token
 {

(and many other errors; see build log)

Expected Results:  
qtgui should build successfully.

USE=-ibus works properly.

Build log and emerge --info to be attached in a moment.
Comment 1 smelenchuk 2014-08-14 02:19:14 UTC
Created attachment 382864 [details]
Build log
Comment 2 smelenchuk 2014-08-14 02:19:33 UTC
Created attachment 382866 [details]
emerge --info
Comment 3 smelenchuk 2014-08-26 02:17:47 UTC
USE="accessibility" causes this to build. I am guessing this is because "-dbus-linked" is only specified if USE has both accessibility and xcb. I'm not sure if there's an interdependence there, but this could probably be fixed if the conditional instead checks for ((accessibility && xcb) || ibus).
Comment 4 Davide Pesavento gentoo-dev 2014-09-02 03:06:21 UTC
(In reply to smelenchuk from comment #3)
> USE="accessibility" causes this to build. I am guessing this is because
> "-dbus-linked" is only specified if USE has both accessibility and xcb. I'm
> not sure if there's an interdependence there, but this could probably be
> fixed if the conditional instead checks for ((accessibility && xcb) || ibus).

Correct.
Comment 5 Davide Pesavento gentoo-dev 2014-09-02 03:22:37 UTC
Fixed in git without revbump. Thanks for reporting and finding the root cause.