Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 519110 - [qt overlay] dev-qt/qtcore-4.8.6 multilib won't install because header file mismatch between ABIs
Summary: [qt overlay] dev-qt/qtcore-4.8.6 multilib won't install because header file m...
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 498010 524164
  Show dependency tree
 
Reported: 2014-08-05 08:18 UTC by Mads
Modified: 2014-10-14 20:08 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mads 2014-08-05 08:18:39 UTC
dev-qt/qtcore-4.8.6 with abi_x86_64 and abi_x86_32 won't install properly because each abi have a few differing header files.

Reproducible: Always

Steps to Reproduce:
1. USE="abi_x86_64 abi_x86_32" emerge -av1 dev-qt/qtcore:4::qt

Actual Results:  
>>> Failed to emerge dev-qt/qtcore-4.8.6, Log file:

>>>  '/var/tmp/portage/dev-qt/qtcore-4.8.6/temp/build.log'

 * Messages for package dev-qt/qtcore-4.8.6:

 * Header files have changed between ABIs.
 * --- /var/tmp/portage/dev-qt/qtcore-4.8.6/temp/.multilib_header_cksum 2014-08-05 07:44:24.825899174 +0000
 * +++ /var/tmp/portage/dev-qt/qtcore-4.8.6/temp/.multilib_header_cksum.new     2014-08-05 07:46:58.550897707 +0000
 * @@ -72,7 +72,6 @@
 *  535750689 16614 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qabstractitemmodel.h
 *  3272283072 16640 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qatomic_armv6.h
 *  3272283072 16640 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qatomic_armv6.h
 * -57087924 16 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Gentoo/gentoo-qtcore-qconfig.h
 *  531224743 17054 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qatomic_sparc.h
 *  531224743 17054 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qatomic_sparc.h
 *  1949018296 17958 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qatomic_sh4a.h
 * @@ -536,6 +535,7 @@
 *  4244800795 3258 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qtextcodecplugin.h
 *  833743761 3266 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qsignalmapper.h
 *  833743761 3266 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qsignalmapper.h
 * +2961110690 32 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Gentoo/gentoo-qtcore-qconfig.h
 *  3827291969 32 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/QAbstractAnimation
 *  1816294777 32 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/QAbstractItemModel
 *  1816294777 32 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/QAbstractListModel
 * @@ -737,8 +737,8 @@
 *  3036007876 7644 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qprocess.h
 *  403300655 7776 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qtconcurrentfunctionwrappers.h
 *  403300655 7776 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qtconcurrentfunctionwrappers.h
 * -2377108888 7809 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qconfig.h
 * -2377108888 7809 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qconfig.h
 * +2231116856 7813 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qconfig.h
 * +2231116856 7813 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qconfig.h
 *  670690462 7869 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtCore/qabstractfileengine.h
 *  670690462 7869 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/Qt/qabstractfileengine.h
 *  3910114564 8175 /var/tmp/portage/dev-qt/qtcore-4.8.6/image/usr/include/qt4/QtNetwork/qsslsocket.h
 * ERROR: dev-qt/qtcore-4.8.6::qt failed (install phase):
 *   Header checksum mismatch, aborting.
 * 
 * Call stack:
 *     ebuild.sh, line   93:  Called src_install
 *   environment, line 3343:  Called multilib-minimal_src_install
 *   environment, line 2232:  Called multilib_foreach_abi 'multilib-minimal_abi_src_install'
 *   environment, line 2419:  Called multibuild_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
 *   environment, line 2025:  Called _multibuild_run '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_install'
 *   environment, line 2023:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_install'
 *   environment, line  435:  Called multilib-minimal_abi_src_install
 *   environment, line 2229:  Called multilib_check_headers
 *   environment, line 2282:  Called die
 * The specific snippet of code:
 *               die "Header checksum mismatch, aborting.";
 * 
 * If you need support, post the output of `emerge --info '=dev-qt/qtcore-4.8.6::qt'`,
 * the complete build log and the output of `emerge -pqv '=dev-qt/qtcore-4.8.6::qt'`.
 * The complete build log is located at '/var/tmp/portage/dev-qt/qtcore-4.8.6/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-qt/qtcore-4.8.6/temp/environment'.
 * Working directory: '/var/tmp/portage/dev-qt/qtcore-4.8.6/work/qt-everywhere-opensource-src-4.8.6-abi_x86_64.amd64'
 * S: '/var/tmp/portage/dev-qt/qtcore-4.8.6/work/qt-everywhere-opensource-src-4.8.6'

Expected Results:  
No mismatch between header (or choose the native ABI header or something)

# emerge --info
Portage 2.2.11 (python 2.7.8-final-0, default/linux/amd64/13.0, gcc-4.8.3, glibc-2.19-r1, 3.15.3-gentoo x86_64)
=================================================================
System uname: Linux-3.15.3-gentoo-x86_64-Intel-R-_Atom-TM-_CPU_N2600_@_1.60GHz-with-gentoo-2.2
KiB Mem:     2043476 total,    538504 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Unknown
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p47
dev-lang/python:          2.7.8
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.15 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo brunvoll qt local
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=native -pipe -fno-stack-protector"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=native -pipe -fno-stack-protector"
DISTDIR="/var/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://10.10.1.19/ http://distfiles.gentoo.org"
INSTALL_MASK="     /usr/share/bash-completion     /usr/share/gtk-doc     /usr/share/man     /usr/share/doc     /usr/share/info     /etc/runlevels     /etc/conf.d     /etc/init.d     "
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/brunvoll /var/lib/layman/qt /usr/portage/local"
SYNC="rsync://10.10.1.19/gentoo-portage"
USE="X acl amd64 apci bzip2 caps cli cracklib crypt cxx dbus dri fortran gif gudev iconv icu jpg lxqt lzma lzo mmx modules multilib ncurses nls nptl opengl pam pcre png policykit qt qt4 readline session sse sse2 sse3 ssl ssse3 svg systemd tcpd threads tiff udev unicode upower xattr xdg zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en en_US" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev modesetting" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Mads 2014-08-05 08:48:41 UTC
The differing files are:
/usr/include/qt4/Gentoo/gentoo-qtcore-qconfig.h (missing from abi_x86_32)
/usr/include/qt4/QtCore/qconfig.h
/usr/include/qt4/Qt/qconfig.h

multilib_src_install_all have some sed statements that changes these files - can it be possible that the same files are edited twice, and then the checksum changes because of that? I'm not completely certain yet...

Maybe those sed-changes could be run in src_prepare()
Comment 2 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2014-08-05 08:51:46 UTC
It's a known issue, the overlay is work-in-progress :).
Comment 3 Mads 2014-08-05 10:22:00 UTC
Nice :)

I got rid of the gentoo-qtcore-qconfig.h extranous file by commenting out QCONFIG_DEFINE="QT_ZLIB" in the ebuild - but I'm not sure what the consequences of doing this are...

I ended up just disabling header checking in the multilib-build.eclass do get this to install. It seems to install the abi_x86_64 version last, so it seems to do the right thing.
Comment 4 Davide Pesavento gentoo-dev 2014-10-14 20:08:13 UTC
This should have been fixed by mgorny's pull request #80