Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 518942 - app-portage/eix on x32 - eix-update Could not start /usr/libx32/portage/bin/ebuild.sh
Summary: app-portage/eix on x32 - eix-update Could not start /usr/libx32/portage/bin/e...
Status: RESOLVED DUPLICATE of bug 506596
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: x32
  Show dependency tree
 
Reported: 2014-08-03 14:53 UTC by Thibaud "thican" CANALE
Modified: 2014-08-03 17:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge --info 'sys-apps/portage' (file_518942.txt,5.98 KB, text/plain)
2014-08-03 14:53 UTC, Thibaud "thican" CANALE
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thibaud "thican" CANALE 2014-08-03 14:53:30 UTC
Created attachment 382140 [details]
emerge --info 'sys-apps/portage'

Hello,

On ABI x86_x32 system, when executing "eix-update" with overlays (providing by layman or personal overlays), app-portage/eix will display those messages “Could not start /usr/libx32/portage/bin/ebuild.sh” and "Could not properly execute /usr/local/portage/xxx/xxx/xxx.ebuild", as follow:

[0] "gentoo" /usr/portage/ (cache: metadata-md5-or-flat)
     Reading category 163|163 (100%) Finished
[1] "thican" /usr/local/portage (cache: parse|ebuild*#metadata-md5#metadata-flat#assign)
     Reading category 108|163 ( 66%): net-p2p ..
Could not start /usr/libx32/portage/bin/ebuild.sh
     Reading category 108|163 ( 66%): net-p2p ..
Could not properly execute /usr/local/portage/net-p2p/deluge/deluge-1.3.7.ebuild
     Reading category 144|163 ( 88%): thican-base ..
Could not start /usr/libx32/portage/bin/ebuild.sh
     Reading category 144|163 ( 88%): thican-base ..
Could not properly execute /usr/local/portage/thican-base/hello-world/hello-world-1.0.ebuild
     Reading category 163|163 (100%) Finished

Here you can found as attachment the ebuild for thican-base/hello-world-1.0, and "emerge --info 'sys-apps/portage'".

Thanks for support.
Comment 1 Thibaud "thican" CANALE 2014-08-03 14:57:37 UTC
Here you can found the content of my ebuild, thican-base/hello-world/hello-world-1.0.ebuild:

-------- begin --------
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=5
SLOT=0

DESCRIPTION="A classical example to use when starting on something new."
HOMEPAGE="http://thican.net/~thican/"
SRC_URI="http://thican.net/~thican/hello-world-1.0.tar.gz"

LICENSE="GPL-3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"

src_install() {
	dobin hello-world
}
-------- end --------

As you can see, it is a very simple ebuild.
Comment 2 Thibaud "thican" CANALE 2014-08-03 15:28:46 UTC
Reproducible: NOT always ... kind of a mean bug, but even with the error message, it looks like eix-update and specially emerge are not impacted.
Comment 3 Martin Väth 2014-08-03 17:56:18 UTC

*** This bug has been marked as a duplicate of bug 506596 ***