Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 518542 - [qt overlay] dev-qt/qtmultimedia-5.3.1[widgets] should depend on dev-qt/qtopengl
Summary: [qt overlay] dev-qt/qtmultimedia-5.3.1[widgets] should depend on dev-qt/qtopengl
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Qt Bug Alias
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: qt5-porting
  Show dependency tree
 
Reported: 2014-07-29 23:14 UTC by Alexander van der Meij
Modified: 2014-08-16 11:30 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
dev-qt/qtmultimedia-5.3.1 build log (build.log,334.72 KB, text/x-log)
2014-07-29 23:15 UTC, Alexander van der Meij
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander van der Meij 2014-07-29 23:14:59 UTC
I am unable to build dev-qt/qtmultimedia-5.3.1 on a fresh installation because of the build failures attached to this bug. It appears this library depends on dev-qt/qtopengl-5. Building qtmultimedia after manually installing said library is successful on my ~amd64 machine. 

Reproducible: Always
Comment 1 Alexander van der Meij 2014-07-29 23:15:35 UTC
Created attachment 381850 [details]
dev-qt/qtmultimedia-5.3.1 build log
Comment 2 Davide Pesavento gentoo-dev 2014-08-05 00:24:28 UTC
The problem is that both QT_OPENGL and QT_NO_OPENGL are defined (the former presumably because of qtgui[opengl], the latter because multimediawidgets.pro adds it to DEFINES when qtopengl is not installed), therefore QtCore/qconfig.h #undef's QT_NO_OPENGL and the code tries to include some qtopengl headers.
Comment 3 Davide Pesavento gentoo-dev 2014-08-16 11:30:20 UTC
Should be "fixed" with https://git.overlays.gentoo.org/gitweb/?p=proj/qt.git;a=commit;h=ea04ace482dc579e72e7aa74ecb412390fe19911

Although technically depending on qtgui[-opengl] with USE=-opengl would not be necessary if qtmultimedia used a different macro to disable opengl support.

Thanks for reporting.