Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 518094 - =dev-lang/ruby-2.1.6-r1 and dependencies stabilization request
Summary: =dev-lang/ruby-2.1.6-r1 and dependencies stabilization request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Ruby Team
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on: 517382 556414
Blocks:
  Show dependency tree
 
Reported: 2014-07-25 13:14 UTC by Manuel Rüger
Modified: 2015-08-24 05:03 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Manuel Rüger gentoo-dev 2014-07-25 13:14:11 UTC
Time to get ruby-2.1 stable
Comment 1 Hans de Graaff gentoo-dev 2014-08-02 09:22:38 UTC
For this to work properly we either need to force the ruby_targets_ruby21 USE flag for the core ruby packages (like we did for ruby20) or offer a proper eclass for packages with an optional ruby dependency, so that those will pull in ruby20 by default rather than ruby21.
Comment 2 Hans de Graaff gentoo-dev 2015-06-07 14:25:49 UTC
(In reply to Hans de Graaff from comment #1)
> For this to work properly we either need to force the ruby_targets_ruby21
> USE flag for the core ruby packages (like we did for ruby20) or offer a
> proper eclass for packages with an optional ruby dependency, so that those
> will pull in ruby20 by default rather than ruby21.

The ruby-single.eclass is now available for this case.
Comment 3 Hans de Graaff gentoo-dev 2015-06-07 14:45:38 UTC
Please test and mark stable this new version of ruby and its dependencies.

=virtual/ruby-minitest-0-r4
=virtual/rubygems-10
=dev-ruby/json-1.8.2-r1
=dev-ruby/minitest-4.7.5-r1
=dev-ruby/minitest-5.3.3-r1
=dev-ruby/racc-1.4.11
=dev-ruby/rake-0.9.6-r1
=dev-ruby/rdoc-4.0.1-r2
=dev-ruby/rubygems-2.2.4
=dev-lang/ruby-2.1.6-r1
Comment 4 Jeroen Roovers gentoo-dev 2015-06-13 06:13:59 UTC
!!! One of the following masked packages is required to complete your request:
- dev-ruby/rspec-core-3.2.3::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-3.2.1::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-3.2.0::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-3.1.7::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-2.99.2-r1::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-2.14.8-r4::gentoo (masked by: ~hppa keyword)

Which?
Comment 5 Hans de Graaff gentoo-dev 2015-06-13 06:20:43 UTC
(In reply to Jeroen Roovers from comment #4)
> !!! One of the following masked packages is required to complete your
> request:
> - dev-ruby/rspec-core-3.2.3::gentoo (masked by: ~hppa keyword)
> - dev-ruby/rspec-core-3.2.1::gentoo (masked by: ~hppa keyword)
> - dev-ruby/rspec-core-3.2.0::gentoo (masked by: ~hppa keyword)
> - dev-ruby/rspec-core-3.1.7::gentoo (masked by: ~hppa keyword)
> - dev-ruby/rspec-core-2.99.2-r1::gentoo (masked by: ~hppa keyword)
> - dev-ruby/rspec-core-2.14.8-r4::gentoo (masked by: ~hppa keyword)
> 
> Which?

None of these. How did this get into the dependency tree?
Comment 6 Jeroen Roovers gentoo-dev 2015-06-13 11:03:19 UTC
!!! All ebuilds that could satisfy ">=dev-ruby/rspec-core-2.14.8-r2[ruby_targets_ruby21]" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-ruby/rspec-core-3.2.3::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-3.2.1::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-3.2.0::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-3.1.7::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-2.99.2-r1::gentoo (masked by: ~hppa keyword)
- dev-ruby/rspec-core-2.14.8-r4::gentoo (masked by: ~hppa keyword)
            
(dependency required by "dev-ruby/multi_json-1.10.1::gentoo[ruby_targets_ruby21,test]" [ebuild])
(dependency required by "dev-util/cucumber-1.3.17::gentoo[ruby_targets_ruby19,test]" [installed])
(dependency required by "dev-ruby/rake-compiler-0.9.2::gentoo[ruby_targets_ruby19,test]" [installed])
(dependency required by "dev-ruby/nokogiri-1.6.4.1::gentoo[ruby_targets_ruby19]" [installed])
(dependency required by "dev-ruby/rspec-core-2.14.8-r2::gentoo[ruby_targets_ruby20,test]" [installed])
(dependency required by "dev-ruby/rspec-2.14.1::gentoo[ruby_targets_ruby19]" [installed])
(dependency required by "dev-ruby/rr-1.1.2::gentoo[ruby_targets_ruby19,test]" [installed])
(dependency required by "dev-ruby/test-unit-rr-1.0.3::gentoo[ruby_targets_ruby20,test]" [installed])
(dependency required by "dev-ruby/locale-2.1.0-r1::gentoo[ruby_targets_ruby19,test]" [installed])
(dependency required by "dev-ruby/ruby-gettext-3.1.1::gentoo[ruby_targets_ruby20]" [installed])
(dependency required by "dev-ruby/yard-0.8.7.3::gentoo[ruby_targets_ruby19,test]" [installed])
(dependency required by "dev-ruby/test-unit-2.5.5-r1::gentoo[doc,ruby_targets_ruby19]" [installed])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
            
Maybe some of these are left over from keyword requests. I'll check.
Comment 7 Hans de Graaff gentoo-dev 2015-06-14 07:13:33 UTC
(In reply to Jeroen Roovers from comment #6)

> "dev-ruby/test-unit-2.5.5-r1::gentoo[doc,ruby_targets_ruby19]" [installed])

This package is not on the list I provided. Did this get pulled in by something else?
Comment 8 Jeroen Roovers gentoo-dev 2015-06-14 08:57:57 UTC
Setting RUBY_TARGETS+=" ruby21" is a requirement:

emerge: there are no ebuilds built with USE flags to satisfy ">=dev-ruby/rake-0.9.6[ruby_targets_ruby21]".
!!! One of the following packages is required to complete your request:
- dev-ruby/rake-0.9.6-r1::gentoo (Change USE: +ruby_targets_ruby21)
(dependency required by "dev-lang/ruby-2.1.6-r1::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

But when I do that, all sorts of packages start requiring unstable versions and revisions.
Comment 9 Pacho Ramos gentoo-dev 2015-07-23 20:56:57 UTC
ppc stable
Comment 10 Markus Meier gentoo-dev 2015-07-26 08:39:58 UTC
arm stable
Comment 11 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-07-29 15:39:13 UTC
amd64 stable
Comment 12 Tobias Klausmann gentoo-dev 2015-07-30 13:10:49 UTC
Stable on alpha.
Comment 13 Pacho Ramos gentoo-dev 2015-08-02 09:49:19 UTC
sparc stable
Comment 14 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-08-05 09:54:05 UTC
x86 stable
Comment 15 Mikle Kolyada archtester Gentoo Infrastructure gentoo-dev Security 2015-08-09 16:04:13 UTC
ia64 stable
Comment 16 Jeroen Roovers gentoo-dev 2015-08-24 05:03:42 UTC
Stable for HPPA PPC64. Closing.