Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 51775 - kdvdbackup ebuild
Summary: kdvdbackup ebuild
Status: RESOLVED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High enhancement (vote)
Assignee: media-video herd
URL: http://agmanager.sourceforge.net/kdvd...
Whiteboard:
Keywords: EBUILD
: 110291 114169 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-05-22 17:51 UTC by JoWilly
Modified: 2005-12-01 10:42 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kdvdbackup-0.1.ebuild (kdvdbackup-0.1.ebuild,472 bytes, text/plain)
2004-05-22 17:52 UTC, JoWilly
Details
kdvdbackup-0.2.ebuild (kdvdbackup-0.2.ebuild,423 bytes, text/plain)
2004-10-01 08:24 UTC, Petri Damstén
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JoWilly 2004-05-22 17:51:51 UTC
kdvdbackup is a utility for backing up movie DVD's to hard disk. It uses the libdvdread library, and if the libdvdcss library is installed, then can backup and encrypted DVD's.
Based on dvdbackup from Olaf Beck <olaf_sc@yahoo.com> 

Features:
Kdvdbackup is a standard KDE application. Has a progress bar and a log window.
Comment 1 JoWilly 2004-05-22 17:52:42 UTC
Created attachment 31860 [details]
kdvdbackup-0.1.ebuild
Comment 2 Petri Damstén 2004-10-01 08:24:30 UTC
Created attachment 40865 [details]
kdvdbackup-0.2.ebuild

Updated ebuild
Comment 3 Chris White (RETIRED) gentoo-dev 2005-03-28 20:48:21 UTC
root@secures /var/tmp/portage/kdvdbackup-0.2/work/kdvdbackup/src # LC_ALL=C LANG=C make
i686-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/kde/3.3/include -I/usr/qt/3/include -I.   -DQT_THREAD_SUPPORT  -D_REENTRANT  -Wnon-virtual-dtor -Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -Wchar-subscripts -Wall -W -Wpointer-arith -Wwrite-strings -DNDEBUG -DNO_DEBUG -O2 -mtune=pentium4 -mmmx -msse -O2 -ftracer -fomit-frame-pointer -pipe -Wformat-security -Wmissing-format-attribute -fno-exceptions -fno-check-new -fno-common  -c -o main.o `test -f 'main.cpp' || echo './'`main.cpp
In file included from main.cpp:21:
frmmainform.h:40:28: dvdnav/dvd_udf.h: No such file or directory
make: *** [main.o] Error 1

This needs to be fixed upstream first.  More information here:

Portage 2.0.51.19 (default-linux/x86/2004.2/gcc34, gcc-3.4.3-20050110-hardened, glibc-2.3.4.20050125-r0, 
=================================================================
System uname: 2.6.11-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 1.60GHz

Python:              python-2.3.5 [2.3.5 (#1, Feb 25 2005, 01:42:58)]
autoconf:  2.13, 2.59-r6
automake:  1.5, 1.8.5-r3, 1.9.4, 1.6.3, 1.7.9-r1, 1.4_p6
binutils:  2.15.92.0.2-r4
libtool:   1.5.10-r5
os-headers:  2.6.8.1-r2
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2005-10-24 01:07:39 UTC
*** Bug 110291 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2005-12-01 10:42:25 UTC
*** Bug 114169 has been marked as a duplicate of this bug. ***