Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 517536 - net-vpn/iodine-0.7.0 - automagic dependencies on systemd and selinux
Summary: net-vpn/iodine-0.7.0 - automagic dependencies on systemd and selinux
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Server (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Jason A. Donenfeld
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-19 21:06 UTC by Alex Xu (Hello71)
Modified: 2018-02-07 18:18 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Xu (Hello71) 2014-07-19 21:06:11 UTC
some patching required to remove osflags
Comment 1 Jason A. Donenfeld archtester Gentoo Infrastructure gentoo-dev Security 2014-07-25 00:06:12 UTC
https://github.com/yarrick/iodine/commit/cc4bc22447d15deacf44bc1d369621a63c934427.patch

Fixes systemd issue.
Comment 2 Alex Xu (Hello71) 2015-04-04 19:55:35 UTC
well, it fixes the part where systemd isn't checked right, but not the part where it shouldn't be checked at all.
Comment 3 Mike Auty (RETIRED) gentoo-dev 2016-11-13 11:49:05 UTC
With more recent versions of iodine, libsystemd-daemon is no longer the pkg-config name, it's just libsystemd.  I'm not sure which version of systemd this change was made in though...