Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 516134 - dev-lang/tcl-8.5.15-r1 dev-lang/tk-8.5.15 stable request
Summary: dev-lang/tcl-8.5.15-r1 dev-lang/tk-8.5.15 stable request
Status: RESOLVED DUPLICATE of bug 512012
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Keywording and Stabilization (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: TCL/TK Project
URL:
Whiteboard:
Keywords: STABLEREQ
Depends on:
Blocks: 516130
  Show dependency tree
 
Reported: 2014-07-03 09:16 UTC by Pacho Ramos
Modified: 2014-07-27 10:34 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pacho Ramos gentoo-dev 2014-07-03 09:16:01 UTC
.
Comment 1 Justin Lecher gentoo-dev 2014-07-03 10:09:49 UTC
arches please go ahead.
Comment 2 Jeroen Roovers gentoo-dev 2014-07-03 19:56:27 UTC
                                                                                                                                    
These are the packages that would be merged:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=dev-lang/tcl-8.4" has unmet requirements.
- dev-lang/tcl-8.5.15-r1::gentoo USE="threads -debug"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64 abi_mips_o32 abi_ppc_32 abi_ppc_64 abi_s390_32 abi_s390_64 
)

And do what exactly?
Comment 3 Jeroen Roovers gentoo-dev 2014-07-04 12:24:30 UTC
Wouldn't you want =dev-lang/tk-8.5.15 going stable along with that?
Comment 4 Pacho Ramos gentoo-dev 2014-07-04 12:58:16 UTC
At least from a repoman point of view tcl is enough... but I don't know if it's better to try to keep them in sync :/
Comment 5 Justin Lecher gentoo-dev 2014-07-04 13:53:03 UTC
sure, tk should go stable as well.
Comment 6 Pacho Ramos gentoo-dev 2014-07-04 13:54:51 UTC
(In reply to Jeroen Roovers from comment #2)
>                                                                             
> 
> These are the packages that would be merged:
> 
> Calculating dependencies... done!
> 
> !!! The ebuild selected to satisfy ">=dev-lang/tcl-8.4" has unmet
> requirements.
> - dev-lang/tcl-8.5.15-r1::gentoo USE="threads -debug"
> 
>   The following REQUIRED_USE flag constraints are unsatisfied:
>     any-of ( abi_x86_32 abi_x86_64 abi_x86_x32 abi_mips_n32 abi_mips_n64
> abi_mips_o32 abi_ppc_32 abi_ppc_64 abi_s390_32 abi_s390_64 
> )
> 
> And do what exactly?

mgorny fixed it at eclass level some minutes ago, thanks for noticing!
Comment 7 Jeroen Roovers gentoo-dev 2014-07-06 12:08:01 UTC
Stable for HPPA.
Comment 8 Markus Meier gentoo-dev 2014-07-11 18:55:54 UTC
arm stable
Comment 9 Pacho Ramos gentoo-dev 2014-07-18 19:36:15 UTC
Will handle the remaining arches in parent bug as it's preferred by Ago and this can wait for those arches until the rest is done

*** This bug has been marked as a duplicate of bug 512012 ***
Comment 10 Paweł Hajdan, Jr. (RETIRED) gentoo-dev 2014-07-27 10:34:52 UTC
x86 stable