Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 515760 - media-sound/rezound-0.12.3_beta-r2 fails to build
Summary: media-sound/rezound-0.12.3_beta-r2 fails to build
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Deadline: 2017-07-05
Assignee: Professional Audio Applications Maintainers
Keywords: PMASKED
: 582420 586640 (view as bug list)
Depends on:
Reported: 2014-06-30 03:31 UTC by Patrick Lauer
Modified: 2017-07-05 13:38 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---

Patch to fix the compile error (missing mode argument) (rezound-missing-open-mode.patch,791 bytes, patch)
2016-02-14 16:57 UTC, Watcom
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Lauer gentoo-dev 2014-06-30 03:31:19 UTC
Cold_rezSoundTranslator.cpp: In member function 'virtual bool Cold_rezSoundTranslator::supportsFormat(std::string) const':
Cold_rezSoundTranslator.cpp:150:22: warning: ignoring return value of 'size_t fread(void*, size_t, size_t, FILE*)', declared with attribute warn_unused_result [-Wunused-result]
In file included from /usr/include/fcntl.h:302:0,
                 from CMIDISDSSoundTranslator.cpp:37:
In function 'int open(const char*, int, ...)',
    inlined from 'virtual bool CMIDISDSSoundTranslator::onSaveSound(std::string, const CSound*, sample_pos_t, sample_pos_t, bool) const' at CMIDISDSSoundTranslator.cpp:520:76:
/usr/include/bits/fcntl2.h:50:26: error: call to '__open_missing_mode' declared with attribute error: open with O_CREAT in second argument needs 3 arguments
    __open_missing_mode ();
Makefile:676: recipe for target 'CMIDISDSSoundTranslator.lo' failed
make[3]: *** [CMIDISDSSoundTranslator.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: Leaving directory '/var/tmp/portage/media-sound/rezound-0.12.3_beta-r2/work/rezound-0.12.3beta/src/backend'
Makefile:691: recipe for target 'all-recursive' failed
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-sound/rezound-0.12.3_beta-r2/work/rezound-0.12.3beta/src/backend'
Makefile:440: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-sound/rezound-0.12.3_beta-r2/work/rezound-0.12.3beta/src'
Makefile:584: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
 * ERROR: media-sound/rezound-0.12.3_beta-r2::gentoo failed (compile phase):
 *   emake failed

Portage 2.2.10 (default/linux/amd64/13.0, gcc-4.9.0, glibc-2.19-r1, 3.7.10-gentoo x86_64)
System uname: Linux-3.7.10-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E31275_@_3.40GHz-with-gentoo-2.2
KiB Mem:    32800928 total,   2213184 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Mon, 30 Jun 2014 00:00:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p47
dev-lang/python:          2.7.7, 3.2.5-r4, 3.3.5, 3.4.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.9.0
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.15 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync parallel-fetch preserve-libs protect-owned sandbox sfperms split-log strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl amd64 berkdb bzip2 cli cracklib crypt cxx dri fortran gdbm iconv ipv6 mmx modules multilib ncurses nls nptl openmp pam pcre readline session sse sse2 ssl tcpd unicode zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 python3_3 python3_4" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Comment 1 Watcom 2016-02-14 16:57:53 UTC
Created attachment 425490 [details, diff]
Patch to fix the compile error (missing mode argument)

This patch fixes it for me.
Comment 2 yves.caniou 2016-04-02 15:34:13 UTC
Thanks, it worked here too.
Comment 3 groepaz 2016-04-17 09:54:18 UTC
same issue here... how do i apply this patch during emerge?
Comment 4 Watcom 2016-04-17 13:52:27 UTC
(In reply to groepaz from comment #3)
> same issue here... how do i apply this patch during emerge?

Create directory /etc/portage/patches/media-sound/rezound and put the patch there (not sure if its name needs to end with .patch, mine is). Then re-emerge.
Comment 5 groepaz 2016-04-17 14:04:55 UTC
mmmh, that gives me the same result here *shrug*
Comment 6 Watcom 2016-04-17 14:26:26 UTC
(In reply to groepaz from comment #5)
> mmmh, that gives me the same result here *shrug*

Make sure the file is readable by user portage all the way to directory rezound, and the patch itself. And I just checked, the filename must end with .patch. So the complete path should be something like: /etc/portage/patches/media-sound/rezound/rezound-missing-open-mode.patch

If you emerge with --jobs=1 you can see it actually being applied at the beginning.
Comment 7 groepaz 2016-04-17 14:41:55 UTC
i did exactly that ... chmod -R 755 on /etc/portage/patches - still no dice :(
Comment 8 Watcom 2016-04-17 14:56:50 UTC
(In reply to groepaz from comment #7)
> i did exactly that ... chmod -R 755 on /etc/portage/patches - still no dice
> :(

Check for typos in the path and make sure you see the lines:

 * Applying user patches from /etc/portage/patches//media-sound/rezound ..
 *   rezound-missing-open-mode.patch ...

when emerging with --jobs=1

Also, are you sure it's failing with the same error?
Comment 9 groepaz 2016-04-17 15:00:45 UTC
checked for typos, i dont see those lines, and yes, its the same error (of course, since the patch was not applied :)) - some googling suggests that user patches do not work for every ebuild, and that you have to enable them globally with some hack first (not sure if i want that). perhaps that is the case here?
Comment 10 Watcom 2016-04-17 15:17:59 UTC
(In reply to groepaz from comment #9)
> checked for typos, i dont see those lines, and yes, its the same error (of
> course, since the patch was not applied :)) - some googling suggests that
> user patches do not work for every ebuild, and that you have to enable them
> globally with some hack first (not sure if i want that). perhaps that is the
> case here?

Hmmm, now that you mention it. Sorry, I've completely forgotten that I did that in the past, the file /etc/portage/bashrc mentioned in needs to exist. Mine is like this:

pre_src_prepare() {
	if ! type epatch_user > /dev/null 2>&1; then
		local names="epatch_user epatch evar_push evar_push_set evar_pop estack_push estack_pop"
		source <(awk "/^# @FUNCTION: / { p = 0 } /^# @FUNCTION: (${names// /|})\$/ { p = 1; } p { print  }" /usr/portage/eclass/eutils.eclass)


	for name in $names; do
		unset $name

The alternative requires more work, which is to duplicate the ebuild to /usr/local/portage/... and modify it to apply the patch.
Comment 11 groepaz 2016-04-17 15:27:18 UTC
yeah, thats the "hack" i referred to ... i think i'll prefer to wait until this patch goes into the tree :) thanks anyway!
Comment 12 Alexis Ballier gentoo-dev 2017-02-08 16:54:56 UTC
*** Bug 582420 has been marked as a duplicate of this bug. ***
Comment 13 Alexis Ballier gentoo-dev 2017-02-08 16:55:54 UTC
*** Bug 586640 has been marked as a duplicate of this bug. ***
Comment 14 Alexis Ballier gentoo-dev 2017-02-08 16:56:55 UTC
this one is already very heavily patched and seems unmaintained upstream for years; ccing treecleaners
Comment 15 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-06-05 17:54:42 UTC
# Michał Górny <> (05 Jun 2017)
# (on behalf of Treecleaner project)
# Unmaintained upstream. Already suffers heavy patching in Gentoo.
# Multiple bugs filed, including build failures.
# Removal in 30 days. Bug #515760.
Comment 16 Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2017-07-05 13:38:28 UTC
commit 03d583af7161787c20d903985ae9715c2f554b5b
Author:     Michał Górny <>
AuthorDate: Wed Jul 5 15:34:31 2017
Commit:     Michał Górny <>
CommitDate: Wed Jul 5 15:35:46 2017

    media-sound/rezound: Remove last-rited pkg, #515760