Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 515660 - games-strategy/ufo-ai 2.5 version bump
Summary: games-strategy/ufo-ai 2.5 version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: All Linux
: Normal enhancement with 2 votes (vote)
Assignee: Gentoo Games
URL: http://ufoai.org/wiki/News
Whiteboard:
Keywords:
Depends on:
Blocks: games.eclass 424445
  Show dependency tree
 
Reported: 2014-06-29 10:29 UTC by DrSlony
Modified: 2018-06-06 20:36 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
ufo-ai-2.5.ebuild (ufo-ai-2.5.ebuild,2.86 KB, text/plain)
2014-07-12 15:00 UTC, M. B.
Details
ufo-ai-2.5.ebuild (ufo-ai-2.5.ebuild,2.83 KB, text/plain)
2014-07-23 00:45 UTC, M. B.
Details
build.log (build.log,53.70 KB, text/plain)
2014-08-05 08:58 UTC, Sven Müller
Details
emerge --info (emerge_info.txt,14.46 KB, text/plain)
2014-08-05 08:59 UTC, Sven Müller
Details
ufo-ai-2.5.ebuild (ufo-ai-2.5-r1.ebuild,2.84 KB, text/plain)
2014-08-09 22:06 UTC, M. B.
Details
emerge --info (file_515660.txt,5.21 KB, text/plain)
2015-05-20 22:55 UTC, Christoph Ellenberger
Details
build.log (build.log,54.05 KB, text/x-log)
2015-05-20 23:01 UTC, Christoph Ellenberger
Details
ufo-ai-2.5.ebuild (ufo-ai-2.5.ebuild,3.29 KB, text/plain)
2017-01-04 17:27 UTC, Wojciech Myrda
Details
ufoai-2.5.0 ebuild, metadata.xml, filesdir with a patch-collection (ufoai-2.5.0-gentoo.tar.bz2,371.35 KB, application/x-bzip2)
2018-05-29 20:57 UTC, geever0
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2014-06-29 10:29:03 UTC
2.5 is out!
http://ufoai.org/wiki/News

Reproducible: Always
Comment 1 M. B. 2014-07-12 15:00:06 UTC
Created attachment 380608 [details]
ufo-ai-2.5.ebuild

From my overlay, tbc.

Enjoy.
Comment 2 M. B. 2014-07-23 00:45:32 UTC
Created attachment 381402 [details]
ufo-ai-2.5.ebuild

a few minor changes
Comment 3 Sven Müller 2014-08-05 08:56:37 UTC
doesn't work here. 

>>> Compiling source in /var/tmp/portage/games-strategy/ufo-ai-2.5/work/ufoai-2.5-source ...
Running emake!
make -j13 
/bin/sh: line 0: cd: /var/tmp/portage/games-strategy/ufo-ai-2.5/work/ufoai-2.5-source/contrib/installer/mojosetup/scripts: No such file or directory
ls: cannot access *.lua: No such file or directory
find: 'base/maps': No such file or directory
build/maps.mk:45: target '.' doesn't match the target pattern
build/maps.mk:45: target 'base' doesn't match the target pattern
build/maps.mk:45: target 'src' doesn't match the target pattern
build/maps.mk:45: target 'src/po' doesn't match the target pattern
...
build/maps.mk:45: target 'android-project/libs' doesn't match the target pattern
find: 'base/models': No such file or directory
find: 'base/models': No such file or directory
find: 'base/models': No such file or directory
find: 'base/models': No such file or directory
make: *** No rule to make target 'release-linux-x86_64/ufo/libs/SDL_ttf/external/freetype-2.4.12/src/base/ftbase.c.o', needed by 'ufo'.  Stop.
make: *** Waiting for unfinished jobs....
emake failed
 * ERROR: games-strategy/ufo-ai-2.5::Local-Overlay failed (compile phase):


The contrib folder isn't included in the unpacked sources.
Comment 4 Sven Müller 2014-08-05 08:58:42 UTC
Created attachment 382308 [details]
build.log
Comment 5 Sven Müller 2014-08-05 08:59:39 UTC
Created attachment 382310 [details]
emerge --info
Comment 6 M. B. 2014-08-09 22:06:35 UTC
Created attachment 382602 [details]
ufo-ai-2.5.ebuild

Was caused by the switch to sdl2. This should work.
Comment 7 Sven Müller 2014-08-18 09:06:30 UTC
(In reply to M. B. from comment #6)
> Created attachment 382602 [details]
> ufo-ai-2.5.ebuild
> 
> Was caused by the switch to sdl2. This should work.

Thanks, works.
Comment 8 DJ Dunn 2014-10-24 03:10:23 UTC
not in portage tree?
Comment 9 Christoph Ellenberger 2015-05-20 22:54:52 UTC
doesn't work here:
...
build/maps.mk:45: target 'android-project/src/org/ufoai' doesn't match the target pattern
build/maps.mk:45: target 'android-project/res/values' doesn't match the target pattern
build/maps.mk:45: target 'android-project/res/layout' doesn't match the target pattern
build/maps.mk:45: target 'android-project/jni/src' doesn't match the target pattern
build/maps.mk:45: target 'radiant/i18n' doesn't match the target pattern
build/maps.mk:45: target 'eclipse/net.sourceforge.ufoai.dsl.ui/src-gen' doesn't match the target pattern
build/maps.mk:45: target 'eclipse/net.sourceforge.ufoai.dsl/src-gen' doesn't match the target pattern
build/maps.mk:45: target 'android-project/libs' doesn't match the target pattern
find: `base/models': No such file or directory
find: `base/models': No such file or directory
find: `base/models': No such file or directory
find: `base/models': No such file or directory
===> CXX [game] src/game/g_spawn.cpp
===> CXX [game] src/game/g_main.cpp
i686-pc-linux-gnu-g++: error: -pg and -fomit-frame-pointer are incompatible
i686-pc-linux-gnu-g++: error: -pg and -fomit-frame-pointer are incompatible
Makefile:171: recipe for target 'release-linux-i386/game/game/g_spawn.cpp.o' failed
make: *** [release-linux-i386/game/game/g_spawn.cpp.o] Error 1
make: *** Waiting for unfinished jobs....
Makefile:171: recipe for target 'release-linux-i386/game/game/g_main.cpp.o' failed
make: *** [release-linux-i386/game/game/g_main.cpp.o] Error 1
emake failed
Comment 10 Christoph Ellenberger 2015-05-20 22:55:49 UTC
Created attachment 403704 [details]
emerge --info
Comment 11 Christoph Ellenberger 2015-05-20 23:01:21 UTC
Created attachment 403706 [details]
build.log
Comment 12 Sergey 'L29Ah' Alirzaev 2015-08-15 20:17:03 UTC
Fixed the ebuild to work with hardened and pushed to ::booboo.
Comment 13 Julian Ospald 2015-08-15 20:30:25 UTC
(In reply to Sergey 'L29Ah' Alirzaev from comment #12)
> Fixed the ebuild to work with hardened and pushed to ::booboo.

I'm not sure if anyone is interested in booboo, provide a pull request instead: https://github.com/gentoo/gentoo
Comment 14 quazgar 2015-10-18 18:36:53 UTC
Pull request created with a slightly modified ebuild (mainly EAPI 5):
https://github.com/gentoo/gentoo/pull/256

Builds and starts for me.
Comment 15 Mr. Bones. (RETIRED) gentoo-dev 2015-11-17 16:18:33 UTC
I'm not sure profiling needs to be supported.  Also, the dedicated use flag is preferred.
Comment 16 DrSlony 2015-12-25 22:43:17 UTC
Portage still ships only 2.4.
Comment 17 quazgar 2015-12-31 11:02:29 UTC
(In reply to DrSlony from comment #16)
> Portage still ships only 2.4.

Good point, I don't know what to do to accelerate this next step.  If anyone wants the ebuild already (I squashed my commits into one and rebased it on top of master), get it from here: https://github.com/quazgar/gentoo/tree/master/games-strategy/ufo-ai
Comment 18 DrSlony 2016-08-16 11:44:08 UTC
Meanwhile, halfway through 2016...
Comment 19 Wojciech Myrda 2017-01-04 17:27:58 UTC
Created attachment 458768 [details]
ufo-ai-2.5.ebuild

Hence there seems to be a shortage of an ebuilds here I add one of my own ;) It is based on previous work in here and somewhat updated to reflect changes in ebuild writing guidelines.
Ebuild works well. What puzzles me is how did ufoded got build if I did not use dedicated flag. Maybe it is build with "ufo" or "game" configure switch. I do not know.
Comment 20 geever0 2018-05-29 20:57:27 UTC
Created attachment 534042 [details]
ufoai-2.5.0 ebuild, metadata.xml, filesdir with a patch-collection

Hi, I'm Geever from the UFO:AI Team. I created an ebuild for UFO:AI 2.5.0 (based on the previous ones in this thread). As you will see I changed a few things:

- (For consistency) I would like the package name to be changed from ufo-ai to ufoai if possible
- The main version to be extended to 3 parts (2.5.0)
- Changed the USE flags so every component has one (client server mapeditor). Added metadata.xml with short explanation of the flags

I included the code patches that we applied since the 2.5.0 release. Some of them are necessary for the game to build with a recent gcc, others fix some known issues. The game and the editor compiles with lots of warnings, but compiles and works. (2.6.0 will be better in this area hopefully.)

I fixed installation of the UFORadiant (map editor), added installation of map sources if mapeditor is requested.

A added some basic man files that the Debian guys created for us.


I hope you find it okay and the ebuild can be added to the portage soon.

I'm going to add the scripts to our repository as well, if needs any change I'd be happy to hear about it and update our version as well.

Thx!
-geever
Comment 21 DrSlony 2018-05-30 05:08:33 UTC
Thank you Geever.
Comment 22 James Le Cuirot gentoo-dev 2018-06-02 23:10:47 UTC
Note to devs, I've done some work on this and hope to finish soon.
Comment 23 Larry the Git Cow gentoo-dev 2018-06-06 20:36:38 UTC
The bug has been closed via the following commit(s):

https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=43d65c90b2161ef8205f0aaa3dfd3b9bd034f257

commit 43d65c90b2161ef8205f0aaa3dfd3b9bd034f257
Author:     James Le Cuirot <chewi@gentoo.org>
AuthorDate: 2018-06-05 22:24:18 +0000
Commit:     James Le Cuirot <chewi@gentoo.org>
CommitDate: 2018-06-06 20:36:28 +0000

    games-strategy/ufoai: Rename from ufo-ai and bump to 2.5.0_p20180603
    
    The rename and bump could not be done separately in a safe
    manner. Upstream has requested this rename for consistency. They also
    kindly provided an ebuild, which I fixed up.
    
    Closes: https://bugs.gentoo.org/515660
    Package-Manager: Portage-2.3.40, Repoman-2.3.9

 games-strategy/ufo-ai/Manifest                     |   3 -
 games-strategy/ufo-ai/files/ufo-ai-2.4-anon.patch  |  17 ---
 .../ufo-ai/files/ufo-ai-2.4-locale.patch           |  15 --
 .../ufo-ai/files/ufo-ai-2.4-mathlib.patch          |  29 ----
 games-strategy/ufo-ai/ufo-ai-2.4.ebuild            | 118 ---------------
 games-strategy/ufoai/Manifest                      |   3 +
 .../files/ufoai-2.5.0_p20180603-install.patch      |  37 +++++
 games-strategy/{ufo-ai => ufoai}/metadata.xml      |   4 +-
 games-strategy/ufoai/ufoai-2.5.0_p20180603.ebuild  | 166 +++++++++++++++++++++
 profiles/updates/2Q-2018                           |   1 +
 10 files changed, 210 insertions(+), 183 deletions(-)