Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 515554 - dev-lang/lua: uses system-wide libtool rather than generating local copy (needed to cross-compile)
Summary: dev-lang/lua: uses system-wide libtool rather than generating local copy (nee...
Status: CONFIRMED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: William Hubbs
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-27 20:51 UTC by Michał Górny
Modified: 2020-05-28 18:10 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Build log (dev-lang:lua-5.1.5-r3:20140627-091905.log,10.58 KB, text/x-log)
2014-06-27 20:51 UTC, Michał Górny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Górny archtester Gentoo Infrastructure gentoo-dev Security 2014-06-27 20:51:21 UTC
Created attachment 379804 [details]
Build log

Long story short, /usr/bin/libtool uses whatever random CC/CXX was used when libtool was last installed. So, using system-wide libtool means mixing CC/CXX used when building the package with CC/CXX used when building libtool, with the latter likely no longer installed.

Solution: only possible I know is to use autotools macros to have proper local libtool suited for currently used CC/CXX. Or not use libtool at all.
Comment 1 Matti Bickel (RETIRED) gentoo-dev 2014-07-04 21:09:29 UTC
Well, as we now continue to ship slot :5.1, I'll look into using configure.in for this one, too (notice how lua-5.2 already generates it's own libtool files).
Comment 2 SpanKY gentoo-dev 2015-12-18 19:26:25 UTC
lua-5.2 also runs /usr/bin/libtool